Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: time always changes on reboot

  1. #1

    Default time always changes on reboot

    i set the clock and done every setting i can think of, the time get sets correctly and at reboot goes back to a differnt time.?

  2. #2
    Vahis NNTP User

    Default Re: time always changes on reboot

    diablo1 wrote:
    >
    > i set the clock and done every setting i can think of, the time get sets
    > correctly and at reboot goes back to a differnt time.?
    >
    >


    You might want to tell which openSUSE version you are running?

    Vahis
    --
    http://waxborg.servepics.com
    openSUSE 11.4 (x86_64) 2.6.37.6-0.9-default main host
    openSUSE 12.1 (x86_64) 3.1.1-48-desktop Tumbleweed in VirtualBox
    openSUSE 12.1 (i586) 3.1.0-1.2-desktop in EeePC 900

  3. #3

    Default Re: time always changes on reboot

    opensuse 12.1(x86_64)3.1.0-1.2 kde 4.7.2 release 5

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,195
    Blog Entries
    3

    Default Re: time always changes on reboot

    Quote Originally Posted by diablo1 View Post
    i set the clock and done every setting i can think of, the time get sets correctly and at reboot goes back to a differnt time.?
    When you reboot, is the time off by minutes or by hours?

    Are you running other operating systems (such as Windows)? If so, perhaps they have incompatible settings for the hardware clock.

    What's the output from
    Code:
    grep HWCLOCK /etc/sysconfig/clock
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5

    Default Re: time always changes on reboot

    [CODEsuse@linux-bv9r:~> grep HWCLOCK /etc/sysconfig/clock
    HWCLOCK="-u"
    ][/CODE]

    off by hours 4 hours. just windows networked with opensuse

  6. #6
    Vahis NNTP User

    Default Re: time always changes on reboot

    diablo1 wrote:
    >
    > opensuse 12.1(x86_64)3.1.0-1.2 kde 4.7.2 release 5
    >
    >


    Do you have NTP running?

    Vahis
    --
    http://waxborg.servepics.com
    openSUSE 11.4 (x86_64) 2.6.37.6-0.9-default main host
    openSUSE 12.1 (x86_64) 3.1.1-48-desktop Tumbleweed in VirtualBox
    openSUSE 12.1 (i586) 3.1.0-1.2-desktop in EeePC 900

  7. #7

    Default Re: time always changes on reboot

    in system services no.
    ill turn it on

  8. #8

    Default Re: time always changes on reboot

    turned NTP on but time is still 4 hours off after I set it then reboot

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,733

    Default Re: time always changes on reboot

    When you are multi boot with a Windows system, you should use "set hardware clock to local time" (not to UTC), because Windows does not understand a good time system and sets the clock to local time (you are apperently 4 hours off from UTC).

    YaST > System > Date and time. Uncheck the box lower left.

    And settinf the NTP service ON in services (runlevel) is not enough. You must configure a server. use
    YaST > Network services > NTP configuration. Add > Server > Public server.
    Henk van Velden

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,195
    Blog Entries
    3

    Default Re: time always changes on reboot

    As root, run the following command:
    Code:
    # hwclock -w
    The system clock is supposed to be written back to the hardware clock on shutdown. However, it is possible that systemd is skipping that step (in which case it is a bug that needs reporting).

    I did notice that my system clock was 22 seconds off today. I had set it correctly yesteday. But I rebooted this morning. It normally does not drift that much. However, if when setting it yesterday, that never got written back to the hardware clock on rebooting, then the 22 seconds error makes sense.

    I'm going to do some testing, to see if the hardware clock is being written back.
    openSUSE Leap 15.1; KDE Plasma 5;

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •