Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Raw Studio Error

  1. #1

    Default Raw Studio Error

    Raw Studio as well as MyPaint 1.0 not working in opensuse 12.1. Raw Studio get all kinds of warning errors when going to run application. And MyPaint 1.0 get icon cache problem. May end up going back to Ubuntu.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Raw Studio Error

    On 12/16/2011 06:26 AM, jedimasterk wrote:
    >
    > Raw Studio as well as MyPaint 1.0 not working in opensuse 12.1.


    how did you install those?

    rpms for both are available for install by 1-Click at
    http://software.opensuse.org/search

    type in the application name, spin the dial to 12.1 and if you find
    nothing then click on "(Search option)" and select "Include users' home
    projects"

    NOTE 1: as far as i am aware there are no community controls on what
    users might put in their home repos! so, select and use at your own risk.

    NOTE 2: during the 1-Click (which takes FAR more than just one click)
    you will be asked if you wanna keep the repo enabled, i advise you to
    not keep it enabled after the initial install..

    NOTE 3: if you install from a home, factory, playground, unstable
    release there is usually very little to _nothing_ we here in the forums
    can do for you....so, be prepared to contact the home owner via PM and
    see what they say about your problems with _their_ package...and, in the
    case of factory/playground/unstable you are pretty much out of luck
    because you *are* running pre-release/Alpha/Beta software which is *not*
    for discussion/questions/help in this forum...instead only in the
    pre-release/beta forum here http://tinyurl.com/2du7r4s, or on a mail
    list directly with the developer

    > May end up going back to Ubuntu.


    what is the purpose of that line? if you find openSUSE too difficult or
    not suitable for you, then please use what works for you..

    what i'm saying is: you don't need to tell us that in order to get an
    answer...or get a fast answer....or get a correct answer....if you wanna
    leave: Bye, stop in again sometime. . .

    i guess if you add such a line in discussion with developers you will
    have probably ended the conversation.

    ymmv

    --
    DD http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,516
    Blog Entries
    15

    Default Re: Raw Studio Error

    Quote Originally Posted by jedimasterk
    Raw Studio as well as MyPaint 1.0 not working in opensuse 12.1. Raw
    Studio get all kinds of warning errors when going to run application.
    And MyPaint 1.0 get icon cache problem. May end up going back to Ubuntu.

    Hi
    Reporting a bug will help get it fixed....

    As one of the mypaint maintainers, I'm about to push a fix (missing
    macro to update the database). In the meantime if you run the following
    command (as root user);
    Code:
    gtk-update-icon-cache -tf /usr/share/icons/hicolor/
    You should be fine then.

    I suggest you raise a bug for raw studio.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
    up 3 days 1:25, 3 users, load average: 0.31, 0.19, 0.10
    GPU GeForce 8600 GTS Silent - Driver Version: 290.10


  4. #4

    Default Re: Raw Studio Error

    Thanks I will give mypaint a try again.

  5. #5

    Default Re: Raw Studio Error

    That worked for Mypaint 1.0!. Thanks!. Hopefully the next update won't require you to update the cache.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,516
    Blog Entries
    15

    Default Re: Raw Studio Error

    Quote Originally Posted by jedimasterk
    That worked for Mypaint 1.0!. Thanks!. Hopefully the next update won't
    require you to update the cache.
    Hi
    No, the rpm macro will do it automatically

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
    up 3 days 2:11, 3 users, load average: 0.35, 0.20, 0.22
    GPU GeForce 8600 GTS Silent - Driver Version: 290.10


  7. #7
    Join Date
    Oct 2009
    Location
    Berlin.
    Posts
    90

    Default Re: Raw Studio Error

    Hi, I updated MyPaint directly from the opensuse.org/graphics repository and got the icon error. After running as root what you have suggested:

    Code:
    gtk-update-icon-cache -tf /usr/share/icons/hicolor/
    I got:
    Code:
    ...@linux-439d:~> sudo gtk-update-icon-cache -tf /usr/local/share/icons/hicolor
    gtk-update-icon-cache: Failed to open file /usr/local/share/icons/hicolor/.icon-theme.cache : No such file or directory
    and MyPaint still doesn't run any idea?

    opensuse 11.4

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,516
    Blog Entries
    15

    Default Re: Raw Studio Error

    Quote Originally Posted by drnn1076
    Hi, I updated MyPaint directly from the opensuse.org/graphics repository
    and got the icon error. After running as root what you have suggested:


    Code:
    --------------------

    gtk-update-icon-cache -tf /usr/share/icons/hicolor/

    --------------------


    I got:

    Code:
    --------------------
    ...@linux-439d:~> sudo gtk-update-icon-cache
    -tf /usr/local/share/icons/hicolor gtk-update-icon-cache: Failed to
    open file /usr/local/share/icons/hicolor/.icon-theme.cache : No such
    file or directory --------------------


    and MyPaint still doesn't run any idea?

    opensuse 11.4

    Hi
    You added a local in the path.... it's /usr/share/icons/hicolor.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
    up 3 days 1:10, 4 users, load average: 0.17, 0.16, 0.11
    GPU GeForce 8600 GTS Silent - Driver Version: 290.10


  9. #9
    Join Date
    Oct 2009
    Location
    Berlin.
    Posts
    90

    Default Re: Raw Studio Error

    Oh, that was an absolutely newbie's mistake Now myPaint is working again. Thanks

  10. #10
    Join Date
    May 2011
    Location
    Reno, Nevada, USA
    Posts
    22

    Default Re: Raw Studio Error

    I get an error with Rawstudio 2.0-1.3 using a reasonably freshly installed OpenSUSE 12.1 with Gnome 3. Basically the app never manages to get started. I have tried several Rawstudio version 2.0 RPMs found with package search, and they all fail with this way. Is anyone else having problems with Rawstudio under 12.1 and Gnome3 ?

    joe@GARY:~> rawstudio

    ** (rawstudio:26859): WARNING **: Could not instantiate filter of type "RSInputImage16"

    ** (rawstudio:26859): WARNING **: Could not instantiate filter of type "RSDemosaic"

    ** (rawstudio:26859): WARNING **: Could not instantiate filter of type "RSFujiRotate"

    ** (rawstudio:26859): WARNING **: Could not instantiate filter of type "RSCache"

    (rawstudio:26859): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed

    ** (rawstudio:26859): WARNING **: Could not instantiate filter of type "RSLensfun"

    ** (rawstudio:26859): WARNING **: Could not instantiate filter of type "RSRotate"

    ** (rawstudio:26859): WARNING **: Could not instantiate filter of type "RSCrop"

    ** (rawstudio:26859): WARNING **: Could not instantiate filter of type "RSCache"

    ** (rawstudio:26859): WARNING **: Could not instantiate color space of type "RSProphoto"
    **
    ERROR:rs-filter.c:459:rs_filter_set_recursive: assertion failed: (RS_IS_FILTER(filter))
    Aborted

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •