Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

  1. #1

    Default KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    I just noticed that I can no longer mount optical media (CD/DVD) when I insert them in my internal SATA drive.

    When plugging in USB-sticks or disks, the device notifier plasmoid appears and I can chose what to do with the devices. If I insert a CD, /var/log/messages reads
    Code:
    Dec 15 20:34:13 eisbaer dbus-daemon[1118]: **** CHANGING /sys/devices/pci0000:00/0000:00:11.0/host2/target2:0:0/2:0:0:0/block/sr0
    Dec 15 20:34:13 eisbaer dbus-daemon[1118]: **** UPDATING /sys/devices/pci0000:00/0000:00:11.0/host2/target2:0:0/2:0:0:0/block/sr0
    Dec 15 20:34:13 eisbaer dbus-daemon[1118]: **** EMITTING CHANGED for /sys/devices/pci0000:00/0000:00:11.0/host2/target2:0:0/2:0:0:0/block/sr0
    Dec 15 20:34:13 eisbaer dbus-daemon[1118]: **** CHANGED /sys/devices/pci0000:00/0000:00:11.0/host2/target2:0:0/2:0:0:0/block/sr0
    but nothing else happens. I can, however, become root, mount the CD manually and use it normally.

    I don't know if this is a KDE 4.7.4 problem, as this is the first time since months I've used a CD, so the problem might be lurking around for quite some time.

    Any ideas what could be wrong?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    So I might suggest you take a look at the file called /etc/udev/rules.d/70-persistent-cd.rules where your optical drives are given a name. If you have added, removed or moved around your optical drives, this file can be wrong. You can even delete the file, restart openSUSE and it will be recreated for you correctly for the present setup. The other consideration is that perhaps the optical drive is dirty and needs to have the dust blown out or it is even went defective, which also can happen.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    Quote Originally Posted by jdmcdaniel3 View Post
    So I might suggest you take a look at the file called /etc/udev/rules.d/70-persistent-cd.rules where your optical drives are given a name. If you have added, removed or moved around your optical drives, this file can be wrong. You can even delete the file, restart openSUSE and it will be recreated for you correctly for the present setup.
    Thanks for the advice, tried it, but it didn't help (:.

    Quote Originally Posted by jdmcdaniel3 View Post
    The other consideration is that perhaps the optical drive is dirty and needs to have the dust blown out or it is even went defective, which also can happen.
    As root can mount the drive in a bash window and then every user can flawlessly access the disc, this doesn't apply.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    Quote Originally Posted by Larx View Post
    Thanks for the advice, tried it, but it didn't help (:.



    As root can mount the drive in a bash window and then every user can flawlessly access the disc, this doesn't apply.
    Then, the normal advice is to create a new regular user and see if they have a problem. If they do not, you can remove your KDE settings with this command to see if that is the problem:

    Code:
    mv .kde4 .kde4-old
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    Quote Originally Posted by jdmcdaniel3 View Post
    Then, the normal advice is to create a new regular user and see if they have a problem. If they do not, you can remove your KDE settings with this command to see if that is the problem:
    Code:
    mv .kde4 .kde4-old
    I'd rather not delete the whole KDE config, it would be better to delete only specific files. However, as a newly created user account suffers from the same problem, the problem does not seem to be with a messed up KDE configuration.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,008
    Blog Entries
    1

    Default Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    What is the output of
    Code:
    ls -l /dev/sr0
    (ie who owns the DVD device?)

    Check KDE System Settings >> Action Policy for policy configuration. In particular org.freedsktop >> The Udisks Project. Have a look at the 'Mount a system-internal device' policy.

  7. #7

    Default Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    Strange new observations: For a few disks (both CD and DVD) the device notifier plasmoid lets me mount them as user, for some others I have to mount them from the console, manually, as root (then I can access them as user, too). Maybe the way the discs were burned is important (multisession and stuff)? I have to dig into this - nowadays it's really seldom that I still handle optical discs...

    Concerning your proposal: The entry you hint at says at "implicit authorizations": Any: No, Inactive console: No, Active console: Administrator Authorization (retain). What does that tell me?

  8. #8
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,160

    Default Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    Larx,
    You could try this it WFM
    1. Dangerous but this is one of times it'll be necessary to login as root
    2.put in the USB
    3.open it in Dolphin
    4.right click the file get properties go to the Permissions tab
    5.change user from root to you click OK
    Then log out go back to user should work.
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,008
    Blog Entries
    1

    Default Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    Concerning your proposal: The entry you hint at says at "implicit authorizations": Any: No, Inactive console: No, Active console: Administrator Authorization (retain). What does that tell me?
    The openSUSE documentation may be helpful to you:

    Chapter

    BTW, the settings you have for that policy mean that only the active console can mount, and only with root credentials supplied.

    Another thought I had: Have you checked the device notifier settings, to make sure that removable media mounting is enabled?

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,008
    Blog Entries
    1

    Default Re: KDE 4.7.4: Can no longer mount optical media, USB stick/hd still OK

    Referring to the PolicyKit documentation, it is mentioned in '9.3.3. Restoring the Default Privileges'
    Each application supporting PolicyKit comes with a default set of implicit policies defined by the application's developers, the so-called “upstream defaults”. The privileges defined by the upstream defaults are not necessarily the ones that are activated by default on openSUSE. openSUSE comes with a predefined set of privileges (see Section 9.3.2.1, “Modifying Configuration Files for Implicit Privileges” for more information) that is activated by default, overriding the upstream defaults.

    Since the Authorization tool and the PolicyKit command line utilities always operate on the upstream defaults, openSUSE comes with the command-line tool set_polkit_default_privs that resets privileges to the values defined in /etc/polkit-default-privs.*. However, set_polkit_default_privs will only reset policies that are set to the upstream defaults. To reset all policies to the upstream defaults first and then apply the openSUSE defaults, run the following command:

    rm -f /var/lib/PolicyKit-public/* && set_polkit_default_privs

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •