Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: openSUSE 12.1 Gnucash Crashing

  1. #1

    Default openSUSE 12.1 Gnucash Crashing

    I just installed 12.1 and am having issues with Gnucash. When I start it I get the splash screen, tips screen and then it stops. When I try to start it from the command line this is what I get:

    gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

    WARNING: no socket to connect to
    ;;; note: auto-compilation is enabled, set GUILE_AUTO_COMPILE=0
    ;;; or pass the --no-auto-compile argument to disable.
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/main.scm
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/core-utils.scm
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/core-utils.scm failed:
    ;;; ERROR: no code for module (sw_core_utils)
    ;;; compiling /usr/share/gnucash/guile-modules/gnucash/gnc-module.scm
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/gnc-module.scm failed:
    ;;; ERROR: no code for module (sw_gnc_module)
    ;;; WARNING: compilation of /usr/share/gnucash/guile-modules/gnucash/main.scm failed:
    ;;; ERROR: In procedure debug-options-interface: Unknown option name: maxdepth
    Backtrace:
    In ice-9/boot-9.scm:
    170: 12 [catch #t #<catch-closure 847cc00> ...]
    In unknown file:
    ?: 11 [catch-closure]
    In ice-9/boot-9.scm:
    2497: 10 [#<procedure 843f1a0 at ice-9/boot-9.scm:2485:4 (name #ptional autoload version #:key ensure)> # ...]
    2763: 9 [try-module-autoload (gnucash main) #f]
    2103: 8 [save-module-excursion #<procedure 85419c0 at ice-9/boot-9.scm:2764:17 ()>]
    2774: 7 [#<procedure 85419c0 at ice-9/boot-9.scm:2764:17 ()>]
    In unknown file:
    ?: 6 [primitive-load-path "gnucash/main" #f]
    In ice-9/eval.scm:
    458: 5 [#<procedure 83d56c0 at ice-9/eval.scm:452:4 (exp)> #]
    In ice-9/psyntax.scm:
    1024: 4 [chi-top-sequence ((debug-set! maxdepth 100000)) () ...]
    922: 3 [scan ((debug-set! maxdepth 100000)) () ...]
    1015: 2 [scan ((#(syntax-object debug-options # ...) (# # #))) () ...]
    In ice-9/boot-9.scm:
    2854: 1 [debug-options (show-file-name #t stack ...)]
    In unknown file:
    ?: 0 [debug-options-interface (show-file-name #t stack ...)]

    ERROR: In procedure debug-options-interface:
    ERROR: In procedure debug-options-interface: Unknown option name: maxdepth

    Can anyone help on this?

    Thanks!

  2. #2

    Default Re: openSUSE 12.1 Gnucash Crashing

    Can't help - but I have exactly the same problem - 12.1 with LXDE. Is there a gnome dependency missing we should know about?
    Cheers,
    Pete

  3. #3

    Default Re: openSUSE 12.1 Gnucash Crashing

    Doing a quick google on gnucash and "WARNING: no socket to connect to", this seemed to be a problem before the official release date.

    Is there anything moving on this, please, guys?

  4. #4

  5. #5
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Re: openSUSE 12.1 Gnucash Crashing

    I'm not sure if you got your fixes, but I had the same issue here: GnuCash 2.8 in Opensuse 12.1 issues with guile 2.0

    Here's how I got it to work, I'm not sure how stable the fix is.
    I downloaded/updated the following:
    gnucash-2.4.8-27.6.x86_64.rpm
    guile-2.0.3-36.1.x86_64.rpm
    libguile-2_0-22-2.0.3-36.1.x86_64.rpm .
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

  6. #6
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Re: openSUSE 12.1 Gnucash Crashing

    Note GNUCash runs, but there is an error when running reports as said Re: [opensuse-packaging] Re: GnuCash in 12.1 (Was: [reminder] openSUSE 1 there are some things that are still getting worked on.
    Unfortunately, it seems, this package still has some lacking features.
    The fact that a bunch of it is written in guile doesn't make it easier
    to debug. The more exotic the languages, the less people you can find to
    debug the stuff
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

  7. #7

    Default Re: openSUSE 12.1 Gnucash Crashing

    Use Yast to delete Guile and Gnucash. In the process delete slib when it asks.
    Goto software.opensuse.org: Download openSUSE 12.1. Select the 11.4 version in the tab below the search box.
    Install in order

    1) guile-1.8.7-8.2.x86_64.rpm from openSUSE:11.4/standard
    2) gnucash-2.4.0-5.3.x86_64.rpm from openSUSE:11.4/standard
    3) gnucash-2.4.7-25.2.x86_64.rpm from GNOME:Apps/openSUSE_11.4+GNOME_STABLE_3.2

    This obviously solves some weird dependency bug. You need first to disable the 12.1 CD repository because otherwise it reloads the wrong version of Guile. I don't know if step 2 is necessary, but it works! gnucash 2.7 and 2.8 from the 12.1 branch don't work, you have to use the version from 11.4.

    I have ended up with versions
    Guile 1.8.7-8.2
    libGuile 2.0.2-7.1.2
    Gnucash 2.4.7-25.2
    Gnucash docs 2.4.1-4.1.1
    slib 3b3-5.1.1

    with which I can open accounts and reports.
    Now I only need to fix the disaster that kmail2 has made in conversion ....

    Edit: The advantage of this over methods in other posts is that it only uses standard repos, not personal ones by who knows whom.

  8. #8

    Default Re: openSUSE 12.1 Gnucash Crashing

    These solutions are unacceptable. I am using this for a production environment. I will wait for the team to produce
    and push a patch to solve this problem. I am thinking that it should be done soon since everyone knows about this, including
    the repository teams....I am NOT going to break my repositories and get a "mixed" system which always causes other
    problems. I hate to have to use gnucash on a Windows machine....LOL...I DO have one laying around for testing purposes....but
    that would kind of be like blasphemy....LOL!

  9. #9
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: openSUSE 12.1 Gnucash Crashing

    On Mon, 28 Nov 2011 21:36:07 +0000, Bobmeister wrote:

    > These solutions are unacceptable. I am using this for a production
    > environment. I will wait for the team to produce and push a patch to
    > solve this problem. I am thinking that it should be done soon since
    > everyone knows about this, including the repository teams....I am NOT
    > going to break my repositories and get a "mixed" system which always
    > causes other problems. I hate to have to use gnucash on a Windows
    > machine....LOL...I DO have one laying around for testing purposes....but
    > that would kind of be like blasphemy....LOL!


    You always have the option of going back to 11.4 or running it in a
    virtual machine. Pan is similarly broken in 12.1, so I run it remotely
    from a VM that's installed with 11.4. X forwarding puts it on my local
    desktop so I don't have to remote control another system.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  10. #10
    Join Date
    Jun 2010
    Location
    Michigan, USA
    Posts
    267

    Default Re: openSUSE 12.1 Gnucash Crashing

    So, what can I do as a member of the community to help out with this issue? I am not an expert in building packages but I can learn. This is one of those programs that I NEED to function in my day to day life and would like to do something about it to better everyone.
    If I am going to be spontaneous, I have to plan for it.

    www.CubicleNate.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •