Results 1 to 10 of 10

Thread: Network Manager problem when checking "connect automatically"

  1. #1

    Default Network Manager problem when checking "connect automatically"

    I'm on openSUSE 12.1 x86_64, Wireless card Broadcom bcm4311, driver b43.

    First time I configured wireless connection to my router (access point) I left checked "connect automatically". System asked me to seta a Wallet password, then connected well. But after a reboot my access point wasn't being recognized, and obviously not connecting. There was no network available and I'm just by my router.

    Tried deleting that configured network, reboot, reseting my router just in case, and it was recognized again. Configured again the access point, this time unchecking "connect automatically", and now it has connected well even after reboots, just as normal.

    However I felt kind of uncomfortable... did I do well? Will I have problems at long term? Should I reinstall whole openSUSE system again or b43 driver? (Hope there was no need...) Why is it that "connect automatically" doesn't work?

    Call me paranoid or what you want, I'm still learning Linux and this time I'm entirely on my own, relying only on online help from the forum community here. Mercy, please...

  2. #2

    Default Re: Network Manager problem when checking "connect automatically"

    Some help?

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Network Manager problem when checking "connect automatically"

    On 14/12/11 21:06, F style wrote:
    >
    > Some help?
    >
    >


    I'm struggling to see what help you need
    It sorta sounds like you sorted it?

    I do this
    http://dl.dropbox.com/u/10573557/SUS...reless-new.png

  4. #4
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: Network Manager problem when checking "connect automatically"

    I have recently experienced the OP problem (wireless con openSUSEnection, set to "connect automatically"). Problem appeared after maintenance updates to KDE.

    On openSUSE 11.3, with BCM4311/BCM4306, problem occurs only in KDE. Gnome functions correctly.
    Code:
    NetworkManager: 0.8.2-15.4.3
    NetworkManager-kde4-libs: 0.9.1git20110911-2.4
    On openSUSE 11.4, with Atheros Communications Inc. AR928X Wireless Network Adapter, problem occurs only in KDE (again). Gnome functions correctly.
    Code:
    NetworkManager: 0.8.2-15.28.1
    NetworkManager-kde4-libs: 0.9.1git20110911-2.6
    On openSUSE 12.1, with Atheros Communications Inc. AR928X Wireless Network Adapter, both KDE and Gnome 3 function correctly.
    Code:
    NetworkManager: 0.9.1.90-4.6.1
    NetworkManager-gnome: 0.9.1.90-3.9
    NetworkManager-kde4-libs: 0.9.1git20110911-2.2
    In the failing cases, symptom presented in "wireless not conneicted". Clicking (selecting) an available wireless connection immediately connects successfully. Symptom(s) are presented at boot as well as after resumption from suspension/hibernation. Further, transient network failures do NOT automatically recover.

    Problem presents on both WEP and WPA/WPA2 wireless connections, and on connections defined as system connections as well.

    Summary: Gnome works in each and every case, KDE fails under openSUSE 11.3 and 11.4 as noted above. The good news is that in openSUSE 12.1, every case works. Please note that the KDE level in each of the platforms is derived from Index of /repositories/KDE:/Release:/47.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  5. #5
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: Network Manager problem when checking "connect automatically"

    Problem resolved by procedure found in http://forums.opensuse.org/english/g...ml#post2256250.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  6. #6

    Default Re: Network Manager problem when checking "connect automatically"

    You say everything works well on 12.1, when it was/is not working for me.
    Besides I checked out and I don't have this directory: ~/.kde4/share/apps/networkmanager. That post is a year old, perhaps it worked on openSUSE 11.3.

  7. #7
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: Network Manager problem when checking "connect automatically"

    Quote Originally Posted by F_style View Post
    You say everything works well on 12.1, when it was/is not working for me.
    Besides I checked out and I don't have this directory: ~/.kde4/share/apps/networkmanager. That post is a year old, perhaps it worked on openSUSE 11.3.
    As I noted in post #4, the problem was not experienced in 12.1. Would you post the package information on:

    NetworkManager
    NetworkManager-gnome
    NetworkManager-kde4-libs

    ?
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  8. #8

    Default Re: Network Manager problem when checking "connect automatically"

    NetworkManager 0.9.1.90-4.6.1-x86_64
    NetworkManager-kde4-libs 0.9.1git20111027-1.1.2-x86_64
    Both from openSUSE.
    I don't have NetworkManager-gnome installed.

    Is this what you mean?

    This is after I updated my system through Yast via Caf4926's method. After this update I haven't tried checking "connect automatically" again, but I don't want for now...

  9. #9
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: Network Manager problem when checking "connect automatically"

    Quote Originally Posted by F_style View Post
    NetworkManager 0.9.1.90-4.6.1-x86_64
    NetworkManager-kde4-libs 0.9.1git20111027-1.1.2-x86_64
    Both from openSUSE.
    I don't have NetworkManager-gnome installed.

    Is this what you mean?

    This is after I updated my system through Yast via Caf4926's method. After this update I haven't tried checking "connect automatically" again, but I don't want for now...
    The installed kde4 NetworkManager (NetworkManager-kde4-libs) package is from the openSUSE 12.1 install. The same package I have installed is from Index of /repositories/KDE:/Release:/47/openSUSE_12.1.

    If your problem is resolved, there is no necessity for further change.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  10. #10

    Default Re: Network Manager problem when checking "connect automatically"

    My original questions were, from my first post,
    "However I felt kind of uncomfortable... did I do well? Will I have problems at long term? Should I reinstall whole openSUSE system again or b43 driver? (Hope there was no need...) Why is it that "connect automatically" doesn't work?"

    Until now there were a few times Application section of openSUSE forums were not loading and one time in which opensuse-guide repo didn't load immediately in Yast. Though right now they seem to work... Hope it was just a server or ISP issue... I don't know if there's something on KDE wallet or NetworkManager settings that will give problems at long term...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •