Results 1 to 2 of 2

Thread: No sound w/ICH6 in 64-bit VM on 64-bit

  1. #1

    Default No sound w/ICH6 in 64-bit VM on 64-bit

    I have OpenSUSE 12.1 and I'm using virt-manager w/qemu-kvm with a 64-bit Windows 7 guest. The Windows 7 guest correctly sees the ICH6 sound device and it appears to work from the Windows point-of-view. I get no sound, however.

    At first, I thought it was a permissions issue, but I added the "qemu" user to various groups including audio, pulse, and pulse-access. I even went crazy and executed qemu-kvm with the aoss wrapper. I see that qemu-kvm is linked against libpulse, so I believe it should work just fine.

    I asked this question on the qemu-devel mailing list and they believe it should work and it could be a distro bug.

    Any thoughts or ideas? Does anyone else have this working?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: No sound w/ICH6 in 64-bit VM on 64-bit

    Quote Originally Posted by erikvcl View Post
    I have OpenSUSE 12.1 and I'm using virt-manager w/qemu-kvm with a 64-bit Windows 7 guest. The Windows 7 guest correctly sees the ICH6 sound device and it appears to work from the Windows point-of-view. I get no sound, however.

    At first, I thought it was a permissions issue, but I added the "qemu" user to various groups including audio, pulse, and pulse-access. I even went crazy and executed qemu-kvm with the aoss wrapper. I see that qemu-kvm is linked against libpulse, so I believe it should work just fine.

    I asked this question on the qemu-devel mailing list and they believe it should work and it could be a distro bug.

    Any thoughts or ideas? Does anyone else have this working?
    Have you considered trying VirtualBox by chance? By the way, we have a new forum on this very subject here: Virtualization

    We would love to have your help in building up the posts in this forum so that it can be as useful as possible for all openSUSE users. Your assistance in posting VM related questions and solutions there is requested. Just start a new thread there with this problem. The forum is brand new so don't worry about missing it.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •