Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade to ver 1.2.5 if need be.

  1. #1

    Default SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade to ver 1.2.5 if need be.

    hello all, I am kinda of new to the unix/linux process. I have a web admin who is getting error.
    [The installer cannot continue until Zlib is installed. / Zlib Not Supported

    I installed zlib with the yum command
    yum update zlib-devel
    it seems to have installed ok. I tried running the command again and now I get message
    setting up install process
    nothing to do
    does that mean its already installed?
    where is the zlib folder located by default?
    do I need to update to ver 1.2.5 for the zlib-devel?

    I also stopped and restarted the apache service, I was told that might be the problem as well.

    question is suse linux 11.3 very old? is it the back end for Novell?
    do you recommend an update of the sue linux?

    thx for all your help.

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade to ver 1.2.5 if need be.

    Please post the exact error (in a CODE tag, you need to Go Advanced to get the # button), otherwise we are all guessing. FYI zlib-devel contains files for compiling with zlib, while the zlib package is the important one containing the actual shared libraries.

    And yes 11.3 is reaching end of life, so you might want to think about migrating off it soon.

    PS: Welcome to the forums.

  3. #3

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade to ver 1.2.5 if need be.

    Quote Originally Posted by ken_yap View Post
    Please post the exact error (in a CODE tag, you need to Go Advanced to get the # button), otherwise we are all guessing. FYI zlib-devel contains files for compiling with zlib, while the zlib package is the important one containing the actual shared libraries.

    And yes 11.3 is reaching end of life, so you might want to think about migrating off it soon.

    PS: Welcome to the forums.
    thx ken_yap, its not giving an error. when I ran the command the first time I was expecting more info. I did not get much. and when I run it again. it says
    "nothing to do"

    I am at the root
    hbs-ftp:~ # this is where I am typing in the yum command yum update zlib-devel
    when I hit enter I get
    "setting up install process
    nothing to do"

    fyi the web admin. is getting error
    [The installer cannot continue until Zlib is installed. / Zlib Not Supported

    so I went down the road of installing zlib.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade to ver 1.2.5 if need be.

    Hmm, how come you are using yum when this is openSUSE? You should be using zypper.

    Anyway if yum says there is nothing to do that means that it is already installed or there are no updates. Or yum doesn't really work on openSUSE. I don't have yum on my 11.3 system so I'm puzzled where you got it from.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade tover 1.2.5 if need be.

    On 2011-12-14 02:16, ken yap wrote:
    >
    > Hmm, how come you are using yum when this is openSUSE? You should be
    > using zypper.
    >
    > Anyway if yum says there is nothing to do that means that it is already
    > installed or there are no updates. Or yum doesn't really work on
    > openSUSE. I don't have yum on my 11.3 system so I'm puzzled where you
    > got it from.


    Do a "zypper se yum" and you will see it. I was also curious about yum, I
    thought it was not available. I wonder why it is there and what it does.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade tover 1.2.5 if need be.

    On 2011-12-14 01:36, arcolino wrote:
    > fyi the web admin. is getting error
    > [The installer cannot continue until Zlib is installed. / Zlib Not
    > Supported
    >


    Who or what is that web admin? Please explain how you are getting that
    error. Installing what and how?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade to ver 1.2.5 if need be.

    Quote Originally Posted by ken_yap View Post
    Hmm, how come you are using yum when this is openSUSE? You should be using zypper.

    Anyway if yum says there is nothing to do that means that it is already installed or there are no updates. Or yum doesn't really work on openSUSE. I don't have yum on my 11.3 system so I'm puzzled where you got it from.
    you maybe right, went down the yum road as per manager but he maybe wrong is the command the same I just need to put zypper where yum was?

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade to ver 1.2.5 if need be.

    Better study the command set of zypper, it's not a drop in replacement. IMO zypper has a more logical organisation of commands than yum.

  9. #9

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade to ver 1.2.5 if need be.

    I think we answered the question. see output below. I rand the zypper command. It's saying its the zlib 1.2.3 is the highest ver. maybe starting and stopping the apache service will do the trick, I'll hear back tomorrow from the web admin.

    hbs-ftp:~ # zypper update zlib-devel
    Retrieving repository 'Updates for openSUSE 11.3 11.3-1.82' metadata [done]
    Building repository 'Updates for openSUSE 11.3 11.3-1.82' cache [done]
    Retrieving repository 'Packman Repository' metadata [done]
    Building repository 'Packman Repository' cache [done]
    Loading repository data...
    Reading installed packages...
    No update candidate for 'zlib-devel-1.2.3-141.1.i586'. The highest available version is already installed.
    Resolving package dependencies...

    Nothing to do.
    hbs-ftp:~ #

  10. #10

    Default Re: SuSE Linux 11.3 zlib ver 1.2.3-141.1.i586 trying to upgrade tover 1.2.5 if need be.

    Quote Originally Posted by robin_listas View Post
    On 2011-12-14 01:36, arcolino wrote:
    > fyi the web admin. is getting error
    > [The installer cannot continue until Zlib is installed. / Zlib Not
    > Supported
    >


    Who or what is that web admin? Please explain how you are getting that
    error. Installing what and how?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)
    he is installing the captcha app the one that you have to type info to verify u are a human being and not a spam program.
    when he tries to run install he gets that error.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •