I have an OpenSuse 12.1 client running within VirtualBox 4.1.6

Naslite-2 v 2.65 box exposing CIFS/NFS shares and accessible from other versions of linux (Ubuntu) and Windows clients without issues.

I can see but cannot browse the Server machine in Nautilus file manager in the Suse client.

From Suse:
I can access the Naslite machine using Telnet (Administration)
I can mount the Naslite Shares by entering them in /etc/fstab on the client
I can mount the shares using mount.cifs w/ guest option in terminal.
I simply cannot browse the Naslite box.

Things I've tried:
Turned off Firewall on client.
Made sure smb and nmb services are running.
Added 'Client Lanman Auth = Yes' to smb.conf

Here is my smb.conf Global section:
[global]
workgroup = MSHOME
netbios name = linux-s5cb
map to guest = Bad User
name resolve order = bcast host lmhosts
printcap name = cups
#add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody $
#logon path = \\%L\profiles\.msprofile
#logon drive = P:
#logon home = \\%L\%U\.9xprofile
domain master = No
usershare allow guests = Yes
usershare max shares = 100
#idmap config * : backend = tdb
hosts allow = 192.168.0.0/255.255.255.0
cups options = raw
#security = share
client lanman auth = Yes
lanman auth = Yes
include = /etc/samba/dhcp.conf
ldap suffix =
passdb backend = smbpasswd
wins support = Yes
#client ntlmv2 = No

Running: smbclient -L NAS2A -Uguest% yields the following error message:

cli_rpc_pipe_open_noauth: rpc_pipe_bind for pipe \srvsvc failed with error NT_STATUS_IO_DEVICE_ERROR
Error returning browse list: NT_STATUS_UNSUCCESSFUL
Domain=[MSHOME] OS=[Unix] Server=[Samba 2.2.12]

Thanks for any help