Results 1 to 7 of 7

Thread: opengl packages?

  1. #1

    Default opengl packages?

    I'm trying to work on a uni assignment but I couldn't get it to run on windows, so I installed opensuse, because I was told it would work better on linux. Now from a classmate I got the following list, with a single apt-get command that should install all the packages I need, however, zypper doesn't recognize the names of any of the packages, how do I find out what the equivalent packages are?

    Code:
    #'libsdl' :
    
    #libsdl-ttf2.0-0
    #libsdl-ttf2.0-dev
    #libsdl-image1.2
    #libsdl-image1.2-dev
    #libsdl-mixer1.2
    #libsdl-mixer1.2-dev
    #libsdl1.2-dev
    #libsdl1.2debian-all
    
    #'libgl' :
    
    #libgl1-mesa-dev
    
    #'libglu' :
    
    #libglu1-mesa-dev
    #libglut3-dev
    
    #'glew'
    
    #libglewmx1.5-dev
    #glew-utils
    
    #install command :
    sudo apt-get install libsdl-ttf2.0-0 libsdl-ttf2.0-dev libsdl-image1.2 libsdl-image1.2-dev libsdl-mixer1.2 libsdl-mixer1.2-dev libsdl1.2-dev libsdl1.2debian-all libgl1-mesa-dev libglu1-mesa-dev libglut3-dev libglewmx1.5-dev glew-utils
    
    #sudo apt-get install libsdl-ttf2.0-0 libsdl-ttf2.0-dev libsdl-image1.2 #libsdl-image1.2-dev libsdl-mixer1.2 libsdl-mixer1.2-dev libsdl1.2-dev #libsdl1.2debian-all libgl1-mesa-dev libglu1-mesa-dev freeglut3-dev #libglewmx1.5-dev glew-utils

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: opengl packages?

    To find the corresponding package names you can just run
    Code:
    zypper se sdl | grep devel
    repeat the same for glew, mesa and glut.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
    nVidia ION | 3GB Ram

  3. #3

    Default Re: opengl packages?

    That worked, thanks. I can now compile the program.

    I can't, however, run it because it says GLSL 1.40 is not supported, but I can't seem to find where to get that. I tried googling but I didn't find anything. can someone point me in the right direction?

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: opengl packages?

    Am 13.12.2011 21:56, schrieb zoefschildpad:
    >
    > That worked, thanks. I can now compile the program.
    >
    > I can't, however, run it because it says GLSL 1.40 is not supported,
    > but I can't seem to find where to get that. I tried googling but I
    > didn't find anything. can someone point me in the right direction?
    >
    >

    That is not a software or package. GLSL is the openGL shading language,
    in your case you seem to need version 1.4 or higher, that means your
    graphics card and your driver have to support it otherwise you have
    absolutely no chance to use that.

    What graphics card do you have and what driver do you have installed (in
    short no older card with whatever driver you use will support that, they
    will at best support GLSL 1.2).

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
    nVidia ION | 3GB Ram

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: opengl packages?

    Check the output of
    Code:
    glxinfo | grep -i opengl
    and post it here.
    If you see an openGL version less than 3.1 your driver supports no glsl
    1.4. Your only option if you have luck is then that there is a better
    driver available for your card.


    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
    nVidia ION | 3GB Ram

  6. #6

    Default Re: opengl packages?

    Code:
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD BARTS
    OpenGL version string: 2.1 Mesa 7.11
    OpenGL extensions:
    I'm using an ati radeon HD 6870 and I installed the 64 bit drivers from ati.com latest version as of 2 hours ago (though they may not have installed correctly) I googled my card and it's supposed to support openGL 4.1, so clearly that's the problem. am I using crappy drivers?

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: opengl packages?

    Am 13.12.2011 22:46, schrieb zoefschildpad:
    >
    > Code:
    > --------------------
    > OpenGL vendor string: X.Org
    > OpenGL renderer string: Gallium 0.4 on AMD BARTS
    > OpenGL version string: 2.1 Mesa 7.11
    > OpenGL extensions:
    >
    > --------------------
    >
    >
    > I'm using an ati radeon HD 6870 and I installed the 64 bit drivers from
    > ati.com latest version as of 2 hours ago (though they may not have
    > installed correctly) I googled my card and it's supposed to support
    > openGL 4.1, so clearly that's the problem. am I using crappy drivers?
    >
    >

    The output shows that something went wrong with your driver
    installation. You are using the open source driver which cannot fully
    use the capabilities of your card.
    I do not use ati myself but nvidia everywhere so I cannot help with the
    drivers.
    You should open a new thread (maybe hardware forum or multimedia forum)
    to get help with the driver installation, after that is fixed
    everything should be fine since you checked the opengl version your card
    is able to support and that is more than sufficient.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.4 |
    nVidia ION | 3GB Ram

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •