Results 1 to 8 of 8

Thread: virtual box direct3d and a black line that won't go away, even after reboot

  1. #1

    Default virtual box direct3d and a black line that won't go away, even after reboot

    I was excited to use virtualbox, having never done it b4. Now I may be wishing I hadn't. I installed the guest additions and used the experimental direct3d. I checked the 3d acceleration and 2d accelartion options, made my video memory 256mb and started my windows vista virtual machine. Well all seemed good and my screen savers that were using direct3d were now working. But then I got a black line about 1/3 up the screen. I thought this was just virtualbox acting up because it would destroy my linux windows and I would have to resize the window to get it looking right again. Well I exited virtualbox, restarted gnome-shell, I logged out and rebooted and none of it is getting the black line to disappear. I'm worried that it did something to my internal video "card". my linux box is in my signature. What can I possibly do to correct this.
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

  2. #2

    Default Re: virtual box direct3d and a black line that won't go away, even after reboot

    well I'm a little stupid. I connected another monitor and it didn't have the black line. So either it damaged my monitor or my monitor just happened to get a black line the same time as running virtual box. I just repaired this monitor 3 months ago and it goes and does something like this. I still think it may have done something to my monitor. I once had gnome-shell fade like it was going to locked screen mode and the fade stayed after a reboot. I had to turn the power off to the monitor. Unfortunately that isn't working this time. If I turn the monitor off, and back on the line is gray but quickly turns black.
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,098

    Default Re: virtual box direct3d and a black line that won't go away, evenafter reboot

    On Sat, 10 Dec 2011 19:46:14 +0000, cw9000 wrote:

    > So either it damaged my monitor or my monitor just happened to get a
    > black line the same time as running virtual box.


    It's highly unlikely that software damaged your monitor, sounds like a
    coincidence to me.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4

    Default Re: virtual box direct3d and a black line that won't go away, evenafter reboot

    yeah, I have a hard time believing it was software too. But its weird. Today has not been a good day for my computer. My wireless pci network card was acting very funky/not working. It was connecting to the router, just not to any web pages. I don't know what the problem is. Its working now after I tried using a usb wireless card. The usb wireless card didn't work, but maybe by turning the pci wireless card on and off it did something to get it working again. I really like virtual machines. I also downloaded vmplayer. I don't know, its the newest thing that I've been doing lately and two things go wrong in the same day. oh well. computers are strange.
    Thanks for commenting, I'll try not to run to the forums next time.
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: virtual box direct3d and a black line that won't go away, evenafter reboot

    Quote Originally Posted by cw9000 View Post
    yeah, I have a hard time believing it was software too. But its weird. Today has not been a good day for my computer. My wireless pci network card was acting very funky/not working. It was connecting to the router, just not to any web pages. I don't know what the problem is. Its working now after I tried using a usb wireless card. The usb wireless card didn't work, but maybe by turning the pci wireless card on and off it did something to get it working again. I really like virtual machines. I also downloaded vmplayer. I don't know, its the newest thing that I've been doing lately and two things go wrong in the same day. oh well. computers are strange.
    Thanks for commenting, I'll try not to run to the forums next time.
    Let me say that all things work great until they break at a time of their own choosing and without regard to what you where doing at the time. Just as Jim suggests, it is doubtful running VirtualBox did anything to your hardware. Once I did overclock a video card until it over heating and went out, but that’s about as close as you can get. I use VirtualBox and even loaded Windows Vista and Windows 7 into it. I had the best luck using 32 bit versions of Windows which is what I would recommend, mainly due to the video support problems with 64 bit and Windows guests only. I have had great success with Linux guest under a Linux host all using 64 bit, just not good luck with 64 bit Windows guests and 3D video support.

    Thank You,
    Last edited by jdmcdaniel3; 12-Dec-2011 at 16:15.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6

    Default Re: virtual box direct3d and a black line that won't go away, even after reboot

    I think I found out what went wrong with my internet. Well I plugged my Samsung 204b monitor into the DVI and my old CRT into D-Sub. Well apparently a DVI cable running a monitor at 1600x1200 can interfere with the wireless signal. I never heard that b4 but it happened to a lot of people using mini dvi cables on a mac. Sure enough, when I changed the resolution down to a lower res, the internet was there no problem. So if anybody ever gets into that kind of mess you can either opt for D-Sub, lower res, or change the channel of your router from the default of 6, 11 was recommended. At least that's what the forums tell me. Coincidentally I must have turned the monitor off around the same time as messing with the usb wireless. The problem with my monitor is dead pixels unfortunately, one lousy line of them. So I went to ebay for another one.

    One strange thing. VirtualBox was destroying my windows on my Samsung lcd. Now that I'm using the CRT VirtualBox has been playing very nicely with gnome3. Not a single window has broken. I don't get it. Maybe I should experiment some more.
    Anyway, thanks for the info jdmcdaniel3.
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

  7. #7

    Default Re: virtual box direct3d and a black line that won't go away, even after reboot

    OH and another thing.
    about VMware (not virtualbox)
    VMware player is very buggy with gnome 3 and even completely locked up my computer. The bug was when I would change programs using activities hot corner and it would get stuck displaying all my windows, wouldn't let me switch desktop, wouldn't let me switch windows, wouldn't let me alt-F2. gnome shell was stuck. So I went into a terminal using ctl-alt-F1 and used the command killall -HUP gnome-shell. That saved me some hassel, as I was installing the os at the time. To make a long story shorter I feel I wasted my time with VMware and also trying to convert a .vmdk into a .vdi. .vmdk didn't work in Virtualbox and converting to .vdi using qemu-img and VBoxManage convertfromraw didn't work either. I didn't even get my direct3d working in vmware. And saving state and restarting state takes forever in vmware, might as well shutdown and boot. I don't recommend vmware.

    I do recommend making a clone of your .vdi after your initial os install on virtualbox( well I did it after I installed service pack 2 etc...) save you some time if you want to change anything.

    Another thing, I can't get my flash drives to work in virtualbox. I add them as filters and then they say "state: not supported" when I mouse over them. I installed the extension pack for 4.1.4. Oh, well, not that big of a deal.
    DESKTOP: Home built OS: opensuse 13.2 64 bit
    Asus p8h61-M LE/CSM | Intel i5-2500k 3.3Ghz Sandy Bridge | 4gb DDR3 | Intel integrated Video
    LAPTOP: Acer Aspire 4730z OS: opensuse 13.2 32 bit
    Intel Pentium dual-core 2.16Ghz T3400 | 3gb DDR2 | Intel Video

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: virtual box direct3d and a black line that won't go away, even after reboot

    We have a new forum for VM questions that you can find here and its brand new:

    Virtualization

    Please use it to post any new questions on Virtualizations.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •