Results 1 to 10 of 10

Thread: Root Password for Local Shutdown?

  1. #1
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Root Password for Local Shutdown?

    I keep getting a password prompt for local shutdown since doing a fresh install of OS 12.1 64-bit KDE. I understand why this is needed for a remote shutdown, but this machine is only used locally, not remotely. I didn't get this in 11.3, and while its not a serious problem, its a bit annoying.

    Is there a way to turn it off?
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,891
    Blog Entries
    3

    Default Re: Root Password for Local Shutdown?

    I'm not sure what is causing this.

    I am using 12.1 with on 4 systems: my desktop (64 bit), my laptop (64 bit), an older system used as a test machine (32 bit), my work desktop (even older, and 32 bit).

    I am not having the problem you describe on any of those. Shutdown works fine from within KDE (I use right click on desktop and select "leave" to get the shutdown menu). And it works fine from kdm.

    I did notice, however, that shutdown does not work from Gnome. If running Gnome, I have to exit back to kdm to shutdown. However, when testing with gdm, instead of kdm, shutdown from gnome was fine.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Root Password for Local Shutdown?

    Quote Originally Posted by walla299 View Post
    I keep getting a password prompt for local shutdown since doing a fresh install of OS 12.1 64-bit KDE. I understand why this is needed for a remote shutdown, but this machine is only used locally, not remotely. I didn't get this in 11.3, and while its not a serious problem, its a bit annoying.

    Is there a way to turn it off?
    Just as nrickert says, I have not seen this problem after loading openSUSE 12.1 three time with one being a VM and never have I had such a prompt as a normal user. So walla299 can you give us a screen shot to show what you get? Now I have never tried to do that while trying to shutdown before but any hints of exactly what you see could be helpful. Are there any other oddities there? Did you keep your old /home area by chance?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Root Password for Local Shutdown?

    On 2011-12-10 02:56, walla299 wrote:
    > Is there a way to turn it off?


    Have a look at the sysconfig settings, maybe it is there. Or perhaps you
    changed to "secure" settings.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5
    Taki NNTP User

    Default Re: Root Password for Local Shutdown?

    On 12/09/2011 05:56 PM, walla299 wrote:
    >
    > I keep getting a password prompt for local shutdown since doing a fresh
    > install of OS 12.1 64-bit KDE. [...]
    > Is there a way to turn it off?
    >
    >


    Become 'root' and fire up YaST2:

    YaST2 > System > /etc/sysconfig Editor:
    click on "Search" at the bottom,
    enter: shutdown
    highlight: DISPLAYMANAGER_SHUTDOWN
    click on "Go to"
    change the value to "auto" (you may want to read the comment)
    click "OK".

  6. #6
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: Root Password for Local Shutdown?

    Quote Originally Posted by jdmcdaniel3 View Post
    Just as nrickert says, I have not seen this problem after loading openSUSE 12.1 three time with one being a VM and never have I had such a prompt as a normal user. So walla299 can you give us a screen shot to show what you get? Now I have never tried to do that while trying to shutdown before but any hints of exactly what you see could be helpful. Are there any other oddities there? Did you keep your old /home area by chance?

    Thank You,
    I've got 1 system running OS 12.1 64-bit with KDE. I did a fresh install, including wiping out the /home directory to make sure there were no "carry overs" from 11.3.

    When exiting KDE, I can use the "leave" option you mentioned, the menu, or the leave widget near the clock display and I get the same thing. Shutdown starts as it always did in 11.3, but after the KDE desktop goes away . . . I get a same dialog box that wants the root password for shutdown (normal user account). I don't think I can do a screen shot at that point since there is no terminal prompt or menu to access the screen shot program. X shuts down right after the prompt, followed by the machine itself, so everything seems normal except for that password prompt.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  7. #7
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: Root Password for Local Shutdown?

    Quote Originally Posted by Taki View Post
    On 12/09/2011 05:56 PM, walla299 wrote:[color=blue]
    Become 'root' and fire up YaST2:

    YaST2 > System > /etc/sysconfig Editor:
    click on "Search" at the bottom,
    enter: shutdown
    highlight: DISPLAYMANAGER_SHUTDOWN
    click on "Go to"
    change the value to "auto" (you may want to read the comment)
    click "OK".
    Thanks for that suggestion. I changed the setting, but still get that password prompt to shutdown. I may try again before shutting down tonight and see what happens.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Root Password for Local Shutdown?

    On 2011-12-11 04:06, walla299 wrote:
    > Thanks for that suggestion. I changed the setting, but still get that
    > password prompt to shutdown. I may try again before shutting down
    > tonight and see what happens.


    What do you have here:
    /etc/sysconfig/security: PERMISSION_SECURITY

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9
    Join Date
    Jun 2008
    Location
    Phoenix, AZ, US
    Posts
    188

    Default Re: Root Password for Local Shutdown?

    Good news! Made the changes Taki recommended and now there's no more password prompt for shutdown. Thanks for the help. I had no idea that setting was buried in there.
    Go for it! You can always re-install...

    Registered Linux User #452291

    Windows Vista Boot Error: (S)hout, (P)arty, (D)ance, (L)inux? (L/L)?

  10. #10
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Root Password for Local Shutdown?

    Quote Originally Posted by Taki View Post
    On 12/09/2011 05:56 PM, walla299 wrote:
    >
    > I keep getting a password prompt for local shutdown since doing a fresh
    > install of OS 12.1 64-bit KDE. [...]
    > Is there a way to turn it off?
    >
    >


    Become 'root' and fire up YaST2:

    YaST2 > System > /etc/sysconfig Editor:
    click on "Search" at the bottom,
    enter: shutdown
    highlight: DISPLAYMANAGER_SHUTDOWN
    click on "Go to"
    change the value to "auto" (you may want to read the comment)
    click "OK".
    Thanks Taki for your help. You should consider signing up for a standard user account here.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •