Results 1 to 3 of 3

Thread: You may wish to restart these processes. See 'man zypper'

  1. #1

    Default You may wish to restart these processes. See 'man zypper'

    i got a message that is too long to post after running http://forums.opensuse.org/content/6...ion-guide.html

    multi media and restricted format install guide for 12.1
    what does it mean and what do i have to do, at the bottom it says You may wish to restart these processes, do i do that by just rebooting?

    this is the message i got in the beginning
    The following running processes use deleted files:
    at the end of the message it says
    You may wish to restart these processes.
    See 'man zypper' for information about the meaning of values in the above table.

    the code is too long to post, i cut out the middle of it

    [CODElinux-fjj3:/home/xxxxx # zypper ps
    The following running processes use deleted files:

    PID | PPID | UID | Login | Command | Service | Files
    ------+-------+------+-------+-----------------------------------+---------+-------------------------------------------------
    8189 | 1 | 0 | root | agetty | | /sbin/agetty (deleted)
    8656 | 1 | 1000 | suse1 | kdeinit4 | | /lib64/libuuid.so.1.3.0
    9051 | 8656 | 1000 | suse1 | klauncher | | /lib64/libuuid.so.1.3.0
    9062 | 1 | 1000 | suse1 | kded4 | | /lib64/libuuid.so.1.3.0
    9062 | 1 | 1000 | suse1 | kded4 | | /lib64/libuuid.so.1.3.0
    9062 | 1 | 1000 | suse1 | kded4 | | /lib64/libuuid.so.1.3.0
    9641 | 1 | 1000 | suse1 | kuiserver | | /lib64/libuuid.so.1.3.0
    9811 | 1 | 1000 | suse1 | kglobalaccel | | /lib64/libuuid.so.1.3.0
    9831 | 1 | 1000 | suse1 | kwalletd | | /lib64/libuuid.so.1.3.0
    9880 | 1 | 1000 | suse1 | knotify4 | | /lib64/libuuid.so.1.3.0
    9880 | 1 | 1000 | suse1 | knotify4 | | /lib64/libuuid.so.1.3.0
    9880 | 1 | 1000 | suse1 | queue0:src | | /lib64/libuuid.so.1.3.0
    9880 | 1 | 1000 | suse1 | queue1:src | | /lib64/libuuid.so.1.3.0
    9880 | 1 | 1000 | suse1 | oggdemux2:sink | | /lib64/libuuid.so.1.3.0
    9880 | 1 | 1000 | suse1 | knotify4 | | /lib64/libuuid.so.1.3.0
    9880 | 1 | 1000 | suse1 | threaded-ml | | /lib64/libuuid.so.1.3.0
    9888 | 8656 | 1000 | suse1 | ksmserver | | /lib64/libuuid.so.1.3.0
    9888 | 8656 | 1000 | suse1 | ksmserver | | /lib64/libuuid.so.1.3.0
    9901 | 9888 | 1000 | suse1 | kwin | | /lib64/libuuid.so.1.3.0
    9901 | 9888 | 1000 | suse1 | kwin | | /lib64/libuuid.so.1.3.0
    9901 | 9888 | 1000 | suse1 | kwin | | /lib64/libuuid.so.1.3.0
    10086 | 1 | 1000 | suse1 | kactivitymanagerd | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10347 | 1 | 1000 | suse1 | plasma-desktop | | /lib64/libuuid.so.1.3.0
    10603 | 1 | 1000 | suse1 | kaccess | | /lib64/libuuid.so.1.3.0
    10698 | 1 | 1000 | suse1 | krunner | | /lib64/libuuid.so.1.3.0
    10698 | 1 | 1000 | suse1 | krunner | | /lib64/libuuid.so.1.3.0
    10698 | 1 | 1000 | suse1 | krunner | | /lib64/libuuid.so.1.3.0
    10700 | 1 | 1000 | suse1 | nepomukserver | | /lib64/libuuid.so.1.3.0
    10700 | 1 | 1000 | suse1 | nepomukserver | | /lib64/libuuid.so.1.3.0
    10798 | 1 | 1000 | suse1 | polkit-kde-authentication-agent-1 | | /lib64/libuuid.so.1.3.0
    10798 | 1 | 1000 | suse1 | polkit-kde-authentication-agent-1 | | /lib64/libuuid.so.1.3.0
    10798 | 1 | 1000 | suse1 | polkit-kde-authentication-agent-1 | | /lib64/libuuid.so.1.3.0
    10801 | 1 | 1000 | suse1 | nepomukcontroller | | /lib64/libuuid.so.1.3.0
    10805 | 1 | 1000 | suse1 | kmix | | /lib64/libuuid.so.1.3.0
    10805 | 1 | 1000 | suse1 | kmix | | /lib64/libuuid.so.1.3.0
    10828 | 1 | 1000 | suse1 | klipper | | /lib64/libuuid.so.1.3.0
    10891 | 1 | 1000 | suse1 | pulseaudio | | /lib64/libuuid.so.1.3.0


    | | | | | | /usr/lib64/firefox/libxul.so
    | | | | | | /usr/lib64/firefox/libmozsqlite3.so
    | | | | | | /usr/lib64/firefox/libmozalloc.so
    28289 | 28269 | 1000 | suse1 | kmozillahelper | | /lib64/libuuid.so.1.3.0
    29387 | 8656 | 1000 | suse1 | kdeinit4 | | /lib64/libuuid.so.1.3.0
    29421 | 1 | 1000 | suse1 | konsole | | /lib64/libuuid.so.1.3.0
    29421 | 1 | 1000 | suse1 | konsole | | /lib64/libuuid.so.1.3.0

    You may wish to restart these processes.
    See 'man zypper' for information about the meaning of values in the above table.
    linux-fjj3:/home/xxxxx #
    ][/CODE]


    thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: You may wish to restart these processes. See 'man zypper'

    The warning means, that (part of) software running at the moment you performed the update has changed. So, this software should be restarted. The easiest way to achieve a restart of the software concerned is to logout and log back in. For example: if an update to banshee includes new plugins, they cannot be loaded by banshees currently running version. It needs a restart to become aware of the newly installed plugins.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: You may wish to restart these processes. See 'man zypper'

    It means that those processes are using older, deleted versions of the libraries and taking up unnecessary RAM. Most of those are KDE or GUI processes so you can fix most of them by logging out and in again. Rebooting fixes everything but I consider that a brute force approach as I'm used to machines running continuously (they do a lot of work even when I'm not . Still, if you were going to shutdown at the end of the session anyway, it will "fix itself" next boot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •