Results 1 to 7 of 7

Thread: Can't load package from repos. Yast2 can't find file /repodata/repomd.xml

  1. #1

    Default Can't load package from repos. Yast2 can't find file /repodata/repomd.xml

    I usually use PClinuxOS but I just installed Suse 12.1 and am trying to find and load Cinelerra or Open Shot

    When I try to add programs I get an error from Yast2:

    "Cannot access installation media
    Index of /distribution/12.1/repo/non-oss
    (medium 1)

    Check whether the server is accessible.

    URL
    Index of /distribution/12.1/repo/non-oss

    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/12.1/repo/non-oss/' "

    It appears that it is looking for " '/repodata/repomd.xml'"

    When I go to "http://download.opensuse.org/distribution/12.1/repo/non-oss/" Via cutting and pasting the address in Fire Fox I do not see it either.

  2. #2
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Re: Can't load package from repos. Yast2 can't find file /repodata/repomd.xml

    It is possible that your mirror is refreshing The error then will just go away in a few hours. If you need a change right now you may try to register by hand a mirror that is geographically near to you from the mirror list.
    Just "clicking away" security warnings about a change in repo signature ? Not able to control?
    Then please vote for
    https://features.opensuse.org/312047
    openSUSE should have an efficient web of trust.

  3. #3

    Default Re: Can't load package from repos. Yast2 can't find file /repodata/repomd.xml

    Thanks! I checked out a couple of other repos and found some that had a directory ....../repodata/repomd.xml and added that into yast and it worked.

    example: Index of /distribution/openSUSE-stable/repo/oss/suse

    I looked back and checked the default URL for download.opensuse and seems there is an error in the stock URL or there is no "/repodata" directory in the repo.














    url

  4. #4
    Join Date
    Jan 2009
    Location
    Somewhere in Fictionland
    Posts
    1,479

    Default Re: Can't load package from repos. Yast2 can't find file /repodata/repomd.xml

    Happy to know that it works. The original directory is by itself only a server that is redirecting to other mirrors. In theory it should choose the one that is answering the fastest, that is "wins the race". Now sometimes either this server or others are updated. Not all mirrors update with the same frequency and not all are fast. Think of it as a lake. You through a stone (the update) and it takes time for all mirrors in the water to be hit, depending on how they are set up. Some mirrors may be in the process of building up or in restoring. So I would think that the repo.xml is restored soon, as the process of refresh will go on.
    Have fun.
    Just "clicking away" security warnings about a change in repo signature ? Not able to control?
    Then please vote for
    https://features.opensuse.org/312047
    openSUSE should have an efficient web of trust.

  5. #5

    Default Re: Can't load package from repos. Yast2 can't find file /repodata/repomd.xml

    Quote Originally Posted by skikir View Post
    Thanks! I checked out a couple of other repos and found some that had a directory ....../repodata/repomd.xml and added that into yast and it worked.

    example: Index of /distribution/openSUSE-stable/repo/oss/suse

    I looked back and checked the default URL for download.opensuse and seems there is an error in the stock URL or there is no "/repodata" directory in the repo.

    url
    Hi,

    I have the same problem, for all repositories I tried, (including packman), even when the target file is available (tested url in the "show details" and it loaded a file).
    I tried changing the url in yast, I tried with command line (zypper ar ...), no way :-(
    I read that dns could be an issue (?) -->I ed the ip address instead, still no way
    I thought that I could use wireshark to analyze the traffic and see what really happens, but for this the install must be working :-(
    I am lost now, stuck since yesterday.

    ----> Is there some troubleshooting tool / script I could use to check my configuration of the default repositories or reset to working defaults - make sure it works, at least for oss and non-oss default repositories?

    thx

    Pierre

  6. #6
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Can't load package from repos. Yast2 can't find file /repodata/repomd.xml

    i'm having the same problem now, but only with the packman repo (Index of /suse/12.1/ ). both YAST software management & zypper complain that the file http://packman.inode.at/suse/12.1/repodata/repomd.xml isn't available. the error message (zypper):
    Code:
    Download (curl) error for 'http://packman.inode.at/suse/12.1/repodata/repomd.xml':
    Error code: Unrecognized error
    Error message: Empty reply from server
    strangely, the file contents of repomd.xml shows fine if accessed in a browser, but YAST & zypper keep complaining that there's an "empty reply" from the server.

    i've removed the repo, removed anything i found in zypper's cache, but re-adding it isn't possible because of the above error. trying "curl" from the command line produces the same error, while wget returns this:
    Code:
    phani@phani:~/tmp> wget http://packman.inode.at/suse/12.1/repodata/repomd.xml
    --2012-04-05 10:44:25--  http://packman.inode.at/suse/12.1/repodata/repomd.xml
    Connecting to 192.168.1.3:3128... connected.
    Proxy request sent, awaiting response... No data received.
    Retrying.
    
    --2012-04-05 10:44:26--  (try: 2)  http://packman.inode.at/suse/12.1/repodata/repomd.xml
    Connecting to 192.168.1.3:3128... failed: Connection refused.
    phani@phani:~/tmp>
    i'm beginning to suspect that the server in question may be using some blacklist to block spammy IP addresses. (i'm living in india, and my ISP often gets included in one or the other blacklist.)

    i'll be writing to the packman people next and let you know if i find anything useful.

    --
    phani.

  7. #7
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Can't load package from repos. Yast2 can't find file /repodata/repomd.xml

    i'm sorry, in my case at least this was caused by my proxy settings. (i'm using squid proxy, together with a custom ip table and some rules to be able to use two ISPs simultaneously, via different proxy ports.) after switching off the proxy, i was able to refresh the packman repo. ok.

    for anybody else having a similar problem, i suggest that you try to download the file in question via wget, from a terminal. that's a little more verbose than curl, it seems.

    --
    phani.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •