Results 1 to 3 of 3

Thread: Digikam on 12.1

  1. #1

    Question Digikam on 12.1

    Hi!
    Digikam 2.2 on Suse 12.1 and Gnome 3.x fails to work since no connection to a database can be established.
    This also happens when instructing Digikam to create a new DB.
    Migrating the DB fails with same problem, creating hash values fails also.
    I'd like to re-use my already populated DB but this also fails.

    The DB itself seems to be OK, I'm able to open it with SQLite extension of Firefox and it worked with Digikam 1.8 on Suse 11.4 and Gnome 2.x.

    New picture folder cannot be added since the DB is missing, Digikam is useless, therefore.

    Any ideas?

  2. #2

    Default Re: Digikam on 12.1

    Found in bugzilla:


    2 packages are missing
    libqt4 sqlite and
    libqt4 sqlite 320 bit
    and also
    pierre L.
    https://bugs.kde.org/show_bug.cgi?id=285994

    (...)The problem fo digikam was just with Gnome ,

    In this version (Gnome) during the instal

    libqt4 sqlite and
    libqt4 sqlite 320 bit ARE MISSING

    THis information is to correct the suse 12.1
    supposed to be corrected (soon(?))
    Christian T.
    Fixed package submitted to KDEistro:Stable

  3. #3

    Default Re: Digikam on 12.1

    Found the problem and validated the proposed solution as 'working'.

    Adding the library
    libqt4-sql-sqlite - Qt 4 sqlite plugin

    on a 64 bit Suse 12.1 and Gnome 3.x makes Digikam work.
    I guess in 32 bit versions one has to pick the appropriate libraries. There's no need to install 32 and 64 bit versions at the same time (as it was written somewhere else.)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •