Results 1 to 3 of 3

Thread: Apache not starting after upgrade t 12.1

  1. #1
    Join Date
    Dec 2011
    Location
    Pune, India
    Posts
    13

    Exclamation Apache not starting after upgrade t 12.1

    Hello,

    Few days back, I upgraded to openSuse 12.1 from openSuse 11.04 vai online upgrade.
    Now if try to start apache server as -

    Code:
     sudo /etc/init.d/apache2 start
    it gives error as -
    Code:
     redirecting to systemctl
     Job failed. See system logs and 'systemctl status' for details
    What might be causing this. Tried googling but no help.
    Thanks in advance.

  2. #2
    Join Date
    Dec 2011
    Location
    Pune, India
    Posts
    13

    Default Re: Apache not starting after upgrade t 12.1

    Update:

    Code:
    rtdp@linux-vai9:~> systemctl status apache2.service
    apache2.service - apache
    	  Loaded: loaded (/lib/systemd/system/apache2.service; disabled)
    	  Active: failed since Tue, 06 Dec 2011 13:21:11 +0530; 3min 54s ago
    	 Process: 2688 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -k start (code=exited, status=1/FAILURE)
    	  CGroup: name=systemd:/system/apache2.service

  3. #3
    Join Date
    Dec 2011
    Location
    Pune, India
    Posts
    13

    Default Re: Apache not starting after upgrade t 12.1

    This is solved now.

    Found that issue was upgrade caused - Opensuse to switched from sysvinit to systemd.

    More details here - apache2 - Apache not starting after upgrade to OpenSuse 12.1 - Server Fault

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •