Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Spotify en ondersteuning in opensource software, zoals in clementine

  1. #11
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    370

    Default Re: Spotify en ondersteuning in opensource software, zoals in clementine

    Dat had ik kunnen weten: een waslijst van missende 64 bits dependencies.

    Verzoekje: als je me nou per e-mail een uitleg stuurt over hoe je het hebt aangepakt, ga ik proberen een rpm te maken voor 32 bits configuraties. Dan post ik het resultaat. Mijn idee zou zijn: bij howto's of een ander onderwerp.
    Ik denk dat de nieuwswaarde van dit onderwerp al aardig is geminderd en ietwat uit de hand dreigt te lopen naar iets wat steeds meer te maken krijgt met installatie van software. Of jij moet dat geen probleem vinden, natuurlijk.
    How vivid is the letting go of knowledge, where experience ends.

    Desktop AMD A6-3650 APU with Radeon(tm) HD Graphics, Leap 42.1
    Laptop HP Compaq 6710b, 64-bit, openSUSE Tumbleweed

  2. #12
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: Spotify en ondersteuning in opensource software, zoals in clementine

    Deze post van je had ik gemist toen ik net keek. Vandaar :http://dl.dropbox.com/u/11099229/spo...116-2.i386.rpm

    Wat ik gedaan heb:
    - Via software.opensuse.org: Zoekresultaten "alien" geïnstalleerd. Vind je ook wel als je zoekt op "deb to rpm".
    - Daarna in een terminal venster dit gedaan:
    Code:
     
    laptop:/home/glosscomputer/temp # alien -r ../Downloads/spotify-client-qt_0.6.2.291.gcccc1f5.116-1_i386.deb 
    spotify-client-qt-0.6.2.291.gcccc1f5.116-2.i386.rpm generated
    find: `spotify-client-qt-0.6.2.291.gcccc1f5.116': No such file or directory
    De onderste regel heb ik laten staan, maar is het gevolg van een bugje in alien, dat 2 keer hetzelfde wil opruimen. Als je zoiets probeert te doen, kan het zijn, dat je allerlei meldingen krijgt, omdat je geen ontwikkelomgeving geïnstalleerd hebt. En ik had die al.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #13
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    370

    Default Re: Spotify en ondersteuning in opensource software, zoals in clementine

    Quote Originally Posted by Knurpht View Post
    Deze post van je had ik gemist toen ik net keek. Vandaar :http://dl.dropbox.com/u/11099229/spo...116-2.i386.rpm

    Wat ik gedaan heb:
    - Via software.opensuse.org: Zoekresultaten "alien" geïnstalleerd. Vind je ook wel als je zoekt op "deb to rpm".

    De onderste regel heb ik laten staan, maar is het gevolg van een bugje in alien, dat 2 keer hetzelfde wil opruimen. Als je zoiets probeert te doen, kan het zijn, dat je allerlei meldingen krijgt, omdat je geen ontwikkelomgeving geïnstalleerd hebt. En ik had die al.
    Alien en een ontwikkelomgeving heb ik beiden. Nu ik weet dat jij ook met alien rpm's hebt gemaakt, weet ik in ieder geval wat mij te doen staat: fijn! Echter, downgraden van openssl en libcrypto is iets waar ik aarzelingen bij heb. Levert dat een beveiligingsrisico op?
    Wat ik persoonlijk ietwat pijnlijk vind, is dat ik tijdens het installeren van de door alien gemaakte rpm's er niet aan heb gedacht om de verbose optie aan te zetten. Dan had ik ook meteen gezien dat er een depency probleem is met de nieuwere spotify versies. Heb ik me daar in allerlei bochten gewrongen en me suf gezocht, terwijl de oplossing voor de hand lag. Maar: ik heb nu wel clementine erop gezet, mèt ondersteuning voor liedteksten, artiestinfo en een grote prent van de cd hoes op mijn bureaublad. Veel geleerd, veel gewonnen.

    Tot vanavond in Alphen (a/d rijn).
    How vivid is the letting go of knowledge, where experience ends.

    Desktop AMD A6-3650 APU with Radeon(tm) HD Graphics, Leap 42.1
    Laptop HP Compaq 6710b, 64-bit, openSUSE Tumbleweed

  4. #14
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    370

    Default Re: Spotify en ondersteuning in opensource software, zoals in clementine

    Erg relativerend zo voor de feestdagen: spotify heeft net een nieuwe versie vrijgegeven waarin de functionaliteit die ik zocht (liedteksten enzo) gewoon zit ingebouwd. Dat verzin je toch niet? Gisteren installeerde de update zichzelf in de spotify onder wine en het werkte ook nog.
    How vivid is the letting go of knowledge, where experience ends.

    Desktop AMD A6-3650 APU with Radeon(tm) HD Graphics, Leap 42.1
    Laptop HP Compaq 6710b, 64-bit, openSUSE Tumbleweed

  5. #15

    Default Re: Spotify en ondersteuning in opensource software, zoals in clementine

    Quote Originally Posted by akaper View Post
    Uhuh, behalve ik dus.
    Ik ben zo'n duurzaam tiep die hardware tot op het bot gebruikt en dus heb ik een, dankzij linux volledig functionele, 32 bits bak van zes jaar oud, met tandwielen en een stoommachine.

    Kan ik jouw rpm installeren of raad je me dat af?

    groet'n uut 't Oost'n.
    Ik heb begin deze maand spotify met alien omgezet naar rpm.
    installeert goed met rpm --nodeps, daarna moet je even jouw versie van libssl.so linken naar libssl.so.0.9.8 zodat spotify start.

    met het commando ldd /usr/bin/spotify kun je nagaan welke bibliotheken spotify wil gebruiken.
    installeer eventuele ontbrekende bibliotheken en als je ze wel hebt, maar in een andere versie: even symlinks aanmaken zodat spotify ze alsnog kan vinden.

  6. #16
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: Spotify en ondersteuning in opensource software, zoals in clementine

    Quote Originally Posted by RinseDeVries View Post
    Ik heb begin deze maand spotify met alien omgezet naar rpm.
    installeert goed met rpm --nodeps, daarna moet je even jouw versie van libssl.so linken naar libssl.so.0.9.8 zodat spotify start.

    met het commando ldd /usr/bin/spotify kun je nagaan welke bibliotheken spotify wil gebruiken.
    installeer eventuele ontbrekende bibliotheken en als je ze wel hebt, maar in een andere versie: even symlinks aanmaken zodat spotify ze alsnog kan vinden.
    Da's nou net het verwarrende. openSUSE heeft een 0.9.8 versie beschikbaar. Die bestaat en is ook officieel gedefinieerd als zijnde een specifieke versie. Het, excusez le mot, maffe van spotify is dat spotify de "normale" libopenssl" wil hebben, maar ook dat die voor het gemak maar de naam van een compatible versie moet hebben. Plak daar nog aan vast, dat de libs onder openSUSE (en in de toekomst ook bij andere distro's) niet in /usr/lib(64) geplaatst worden, maar in /lib(64). En de te linken bestanden uit de posts staan, als je de 0.9.8 versie installeert, echt in /usr/lib(64). Verwarrend. Maar kijk maar even in de andere post die ik in Andre's draadje onder Programma's gezet heb, daarmee crasht de boel bij mij niet meer, en lijkt het werkend.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •