Results 1 to 3 of 3

Thread: Latest KDE Repository downgrades some packages

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Latest KDE Repository downgrades some packages

    There are two repository version to choose from when upgrading KDE with OpenSuse 12.1

    Stable aka. KDS (KDE SC 4.7)
    The same version of the KDE Software Collection included in the latest official openSUSE release (KDE 4.7.2). This repository is used for developing online updates for the latest openSUSE release. If you want to upgrade the KDE from that shipped with your openSUSE, we recommend the latest stable upstream KDE.
    Upstream release aka. KR47 (KDE SC 4.7)
    The latest stable point release of KDE SC 4.7. Use these repositories, if you want to have the latest version of KDE.
    However: If I choose the recommended upgrade repository for KDE it downgrades some of the packages that came with OpenSuse 12.1. The KDS repository does not (except for a handfull of OpenSuse packages).
    How can a repository which contains a newer version of KDE downgrade some of it packages, when a lesser version of KDE has a newer version of those downgraded packages. Example KNetworkmanager, Kipi, Phonom and Soprano.

    So I am a bit confused. Should I choose KR47 instead of KDS?

  2. #2
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Latest KDE Repository downgrades some packages

    Here is a screen shot of my YAST containing most of the packages in question that will be downgraded.

  3. #3
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Latest KDE Repository downgrades some packages

    I think I'll wait to upgrade KDE. I don't like to downgrade some of my packages just for the sake of a newer version of KDE.

    Though no one who know why this KDE upgrade repository has older versions of some of its packages?
    Some of the packages has minor version changes, but some have major version changes. Like Kipi and Digikam from 2.3 to 2.2 with this KDE repository.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •