Results 1 to 7 of 7

Thread: Latest KDE update broke it [openSUSE 11.4)

  1. #1

    Exclamation Latest KDE update broke it [openSUSE 11.4)

    The KDE packages that came out about two or three days ago broke it.

    I'm using openSUSE 11.4 (x86_64) and the following KDE repositories:

    Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.4
    Index of /repositories/KDE:/Extra/openSUSE_11.4_KDE_Distro_Factory

    The problem seems to be that the plasma-desktop and kwin don't start, and the keyboard doesn't work either.
    When I try to start plasma-desktio on the command line, I get the following error:

    plasma-desktop: symbol lookup error: /usr/lib64/libplasmagenericshell.so.4: undefined symbol: _ZN19QAbstractProxyModel11setItemDataERK11QModelIndexRK4QMapIi8QVariantE

    I also tried renaming the .kde4 directory, but I doesn't help.

    Any idea if/when a fix is coming?

    Thanks.
    KS.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Latest KDE update broke it [openSUSE 11.4)

    You have KDF!
    Those are building for 12.2 and are very unstable

    You should remove them and use the R47 repos
    Then update from those
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Latest KDE update broke it [openSUSE 11.4)

    but in the path it says "openSUSE_11.4". Which repositories should I use then? There are so many of them...

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Latest KDE update broke it [openSUSE 11.4)

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Latest KDE update broke it [openSUSE 11.4)

    Do you know how to get yourself out of this mess?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Latest KDE update broke it [openSUSE 11.4)

    Quote Originally Posted by caf4926 View Post
    Do you know how to get yourself out of this mess?
    I guess I'll let zypper do that for me. Thanks for your help.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Latest KDE update broke it [openSUSE 11.4)

    Make sure you remove the old repos

    Then use zypper dup -r reponame or number

    ( reponame or number = replace with either the repo name or number )

    Eg: zypper dup -r 1
    where 1 is the repo number for

    zypper dup
    (will do a system wide upgrade/downgrade)

    either will work
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •