Results 1 to 5 of 5

Thread: Samba - has something changed??

  1. #1

    Default Samba - has something changed??

    Hi,
    I have a problem with Samba that is driving me crazy!!
    I have just reinstalled SuSE11.4 due to a major problem with Nvidia driver and kernel driver mismatches - but thats another story....
    Before my systems x got wrecked I used to have a shared folder setup in samba - anyone on my windows network could both browse and connect to the share without being prompted for a username or password.
    This was achieved simply by adding the folder I wanted to share and adding browesable and guest OK in the Yast samba config tool.
    I have now setup the share exactly as before and added guest OK and Browseable to the smb.conf yet although Windows machines can see the share when they try to connect they get a 'Windows cannot access \\PHY-Katana\**** and you do not have permission to access \\PHY-Katana\**** please contact your system administrator.

    Here is my smb.conf.
    [global]
    workgroup = PART1LAB
    passdb backend = tdbsam
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    # logon path = \\%L\profiles\.msprofile
    # logon home = \\%L\%U\.9xprofile
    # logon drive = P:
    usershare allow guests = Yes
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain logons = Yes
    domain master = Yes
    local master = Yes
    netbios name = PHY-Katana
    os level = 65
    preferred master = Yes
    # Security = user
    wins support = Yes



    ## Share disabled by YaST
    # [users]
    # comment = All users
    # path = /home
    # read only = No
    # inherit acls = Yes
    # veto files = /aquota.user/groups/shares/

    ## Share disabled by YaST
    # [groups]
    # comment = All groups
    # path = /home/groups
    # read only = No
    # inherit acls = Yes
    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    [Software]
    comment = general software and apps
    inherit acls = No
    path = /Public/Software
    read only = No
    browseable = Yes
    guest ok = Yes

    i have hashed out the logon lines and security = user as I dont recall them existing in my previous smb.conf - but this hasnt helped any - if only I had kept my original smb.conf file :-(.
    I have also read various threads on the net about creating a user smbguest and doing various things to enable passwordless access - I have tried several all without success. But what is really bugging me is that before I reinstalled my last setup just worked out of the box simply by adding the share /Public/Software and Guest OK and Browseable in the config.....

    Hope someone has some idea of what is wrong here....

    Chris.

  2. #2

    Default Re: Samba - has something changed??

    I just upgraded to 11.4 and seems to have the same problem, here is a piece of my smb.conf:
    Code:
    workgroup = casa
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = Yes
    security = user
    usershare max shares = 100
    add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain logons = No
    domain master = No
    netbios name = pierluigi2smb
    ....
    
    I cannot access to this and other like this
    
    [abbaino]
    comment = abbaino
    path = /abbaino/
    read only = No
    create mask = 0600
    directory mask = 0700
    force user = pla
    force group = users
    case sensitive = no
    hide dot files = no
    host allow = 192.168.1.1/32
    guest ok = yes

  3. #3
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    974

    Default Re: Samba - has something changed??

    Since at least one of you are re-installing 11.4, can it be assumed you are aware of the AppArmor bug in 11.4 that needs to be dealt with?

    There is a good discussion in this thread: http://forums.opensuse.org/english/g...a-sharing.html

  4. #4

    Default Re: Samba - has something changed??

    Thanks for that - I will give it a try later. I have found since I posted, that if I create my 'guest' share folder under /home/ then there is no problem with access form other machines, the problem only arises with shares mounted under / even though I changed the ownership and permissions to my own user name. Similarly if I try and create a share with user/passwd access set alongside my now working 'guest' share under /home, then it breaks everything and I am back to not being able to access the 'guest' share. Obviously something has gone very very very wrong with something - hopefully the AppArmor thing might sort it.

    Cheers
    Chris

  5. #5

    Default Re: Samba - has something changed??

    disable apparmor and reboot works for me, thanks to this

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •