Results 1 to 3 of 3

Thread: Yast via VNC

  1. #1

    Default Yast via VNC

    I recently converted my tower PC (used as a file server & media server/ uPNP) from Win 7 to openSuse 11.4. I was able to get everything to work, and it works great in my home as a file server, and i love it. One thing though is that i have this computer in my closet upstairs in my house w/o a monitor attached to it (and the onboard video card is bad). I currently use SSH to connect to it remotely and it works great. Sometimes i want to use my Mac Book or PC on my network to connect to the GUI via VNC. For basic functions, it works fine. But when i run Yast/ Install Software (requires root password), i get the pop up for the root password and after i enter it, nothing happens. I've searched various forums and Google and have found no luck. I consider myself a novice Unix user for many years, but this has me stumped; as i can only use Yast via SSH (graphical session), but anything else like install software, nothing happens. If i need to hook up a monitor temporarily, I can get one there, but my onboard video card is blown, i went to best buy and purchased a pci express card and it works fine (out-ruled that). I dont need a video card per-say, since its used just as a file server. But if i want to install software, or any other admin windows that dont have a graphical window like yast does, i'm out of luck. I read somewhere there might be a bug with 11.4, and it has something to do with elevated rights. I really dont want to go to 12 as i have installed 11.4 a few times and i got it to work, along with a few scripts and cronjob for my backups.

    I was wondering if there is anything i can do. I hope this was the most correct forum to post in, and i have tried searching for the solution.

    Thanks again, Joe.

  2. #2
    Join Date
    Jun 2008
    Florida, USA

    Default Re: Yast via VNC

    I have been successfully using VNC between 11.4/KDE4.7.2 machines, including root access applications on the remote end.

    There was a period of time when VNC was broken in the standard repos, I found solutions in other repos.
    Take a look 11.4/KDE4.7.1 VNC crash after recent update - a fix here

    Unfortunately, I am away from my systems for a few more days and can't say that these are the most recent versions.
    I would suggest you use the package search Download openSUSE 11.4 to look for updates if your problems continue.

  3. #3

    Default Re: Yast via VNC

    Thanks for the info & links. I disabled the VNC service in Yast and installed tight vnc and followed the documentation, and i was able to access yast and software mgr through a VNC sessions (before it would prompt for a root password and didnt show anything) both on a browser and vnc app on my mac book. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts