Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Kein Wlan mit Broadcom-Karte, open SUSE 12.1

  1. #1

    Default Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    Hallo liebes Forum.
    Ich bin ganz neu...sowohl hier als auch mit Linux, sprich ich hab so gut wie keine Ahnung (außer n paar Uni-stunden).
    Ich hab mit jetzt openSuse 12.1 installiert(neben Windows).
    Mein problem ist, dass ich mein Wlan nicht zum laufen kriege...mir ist klar, dass die Informationen euch wohl nich ausreichen...aber ich weiß nich was ihr sonst noch braucht...
    Ich hab einen HP-Laptop mit einer Broadcom W-Lan-Karte. "Broadcom 802.11g" sagt windows.
    Jetz hab ich mir von der Broadcomseite den Treiber geholt, aber kann den nicht installieren, weil mir das Verzeichnis "/lib/modules/`uname -r`/build" fehlt.
    Ich hab den KDE-Desktop installiert. Wenn ich das in diversen How-tos und Foren richtige gelesen hab(in der Readme von Broadcom stand das auch) muss mein Kernel geupdatet werden(oder auch nicht???) also hab ich mir hier The Linux Kernel Archives den neuesten stable geholt...aber wenn ich den installieren will, sagt der mir, dass er usr/bin/apper nicht finden kann(was in der tat da nicht ist) ich hab leider nicht gefunden wo ich das herkriege...aus dem selben grund geht auch ndiswrapper nicht(apper fehlt)...außerdem hab ich kein Lan-Kabel und muss somit ständig den Lappy neustarten um sachen bei windows zu laden und dann bei Linux zu installieren

    Wenn mir jmd helfen könnte, wär das ganz große Klasse...aso und Sorry wenn ich den alten Thread hochhole, aber is besser als n neuen aufzumachen, oder?
    Lg

    Anmerkung: Habe die beiden Beiträge aus dem alten Thread mit diesem neuen Thread vereint und ein paar Stichworte vergeben.
    Gruß Martin (pistazienfresser)
    Last edited by pistazienfresser; 26-Nov-2011 at 15:10. Reason: Anmerkung zum Absplitten, Bewegen und Vereinen

  2. #2
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    361

    Default AW: Re: Hilfe! Kein WLAN mit broadcom card (OpenSuse 11.4)

    Quote Originally Posted by gelberTextmarker View Post
    und Sorry wenn ich den alten Thread hochhole, aber is besser als n neuen aufzumachen, oder?
    Lg
    Nein, es ist besser ein eigenes Thema zu eröffnen. Hast du openSUSE 11.4? Nein! Hast du die gleiche Karte/den gleichen Chip? Wer weiß. Also eröffne ein eigenes Thema mit den Ergebnissen von folgenden Eingaben:
    Code:
    cat /etc/SuSE-*
    Code:
    uname -a
    Code:
    /sbin/lspci -nnk | grep -i -A2 net
    und/oder
    Code:
    /usr/sbin/hwinfo --netcard

  3. #3

    Default Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    Hallo liebes Forum.
    Ich bin ganz neu...sowohl hier als auch mit Linux, sprich ich hab so gut wie keine Ahnung (außer n paar Uni-stunden).
    Ich hab mit jetzt openSuse 12.1 installiert(neben Windows).
    Mein problem ist, dass ich mein Wlan nicht zum laufen kriege...mir ist klar, dass die Informationen euch wohl nich ausreichen...aber ich weiß nich was ihr sonst noch braucht...
    Ich hab einen HP-Laptop mit einer Broadcom W-Lan-Karte. "Broadcom 802.11g" sagt windows.
    Jetz hab ich mir von der Broadcomseite den Treiber geholt, aber kann den nicht installieren, weil mir das Verzeichnis "/lib/modules/`uname -r`/build" fehlt.
    Ich hab den KDE-Desktop installiert. Wenn ich das in diversen How-tos und Foren richtige gelesen hab(in der Readme von Broadcom stand das auch) muss mein Kernel geupdatet werden(oder auch nicht???) also hab ich mir hier The Linux Kernel Archives den neuesten stable geholt...aber wenn ich den installieren will, sagt der mir, dass er usr/bin/apper nicht finden kann(was in der tat da nicht ist) ich hab leider nicht gefunden wo ich das herkriege...aus dem selben grund geht auch ndiswrapper nicht(apper fehlt)...außerdem hab ich kein Lan-Kabel und muss somit ständig den Lappy neustarten um sachen bei windows zu laden und dann bei Linux zu installieren

    Wenn mir jmd helfen könnte, wär das ganz große Klasse...ja der Text is gecopy und pasted, is hoffentlich ncih so schlimm

    Hier noch die Ergebnisse zu den Eingaben:

    cat /etc/SuSE-*
    openSUSE
    VERSION = 12.1
    openSUSE 12.1 (i586)
    VERSION = 12.1
    CODENAME = Asparagus
    uname -a
    Linux ***** 3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) i686 i686 i386 GNU/Linux
    Wobei für ***** mein Name da steht

    /sbin/lspci -nnk | grep -i -A2 net
    02:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Hewlett-Packard Company BCM4312 802.11b/g Wireless LAN Controller [103c:137d]
    Kernel driver in use: b43-pci-bridge
    03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)
    Subsystem: Hewlett-Packard Company Device [103c:3603]
    Kernel driver in use: r8169
    und zu guter letzt:
    /usr/sbin/hwinfo --netcard
    30: PCI 200.0: 0282 WLAN controller
    [Created at pci.319]
    Unique ID: y9sn.bL_9V016GP1
    Parent ID: z8Q3.TJZXZ7JTzMB
    SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:02:00.0
    SysFS BusID: 0000:02:00.0
    Hardware Class: network
    Model: "Hewlett-Packard Company BCM4312 802.11b/g Wireless LAN Controller"
    Vendor: pci 0x14e4 "Broadcom"
    Device: pci 0x4315 "BCM4312 802.11b/g"
    SubVendor: pci 0x103c "Hewlett-Packard Company"
    SubDevice: pci 0x137d "BCM4312 802.11b/g Wireless LAN Controller"
    Revision: 0x01
    Driver: "b43-pci-bridge"
    Driver Modules: "ssb"
    Device File: wlan0
    Features: WLAN
    Memory Range: 0xde200000-0xde203fff (rw,non-prefetchable)
    IRQ: 16 (1628 events)
    HW Address: 00:21:00:96:7e:9d
    WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
    WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
    WLAN encryption modes: WEP40 WEP104 TKIP CCMP
    WLAN authentication modes: open sharedkey wpa-psk wpa-eap
    Module Alias: "pci:v000014E4d00004315sv0000103Csd0000137Dbc02sc80i00"
    Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #13 (PCI bridge)

    31: PCI 300.0: 0200 Ethernet controller
    [Created at pci.319]
    Unique ID: rBUF.gXGq1Cq2Y94
    Parent ID: qTvu.V8S1XGYt08C
    SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:03:00.0
    SysFS BusID: 0000:03:00.0
    Hardware Class: network
    Model: "Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller"
    Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
    Device: pci 0x8168 "RTL8111/8168B PCI Express Gigabit Ethernet controller"
    SubVendor: pci 0x103c "Hewlett-Packard Company"
    SubDevice: pci 0x3603
    Revision: 0x02
    Driver: "r8169"
    Driver Modules: "r8169"
    Device File: eth0
    I/O Ports: 0x6000-0x7fff (rw)
    Memory Range: 0xd4010000-0xd4010fff (ro,non-prefetchable)
    Memory Range: 0xd4000000-0xd400ffff (ro,non-prefetchable)
    Memory Range: 0xd4020000-0xd402ffff (ro,non-prefetchable,disabled)
    IRQ: 48 (no events)
    HW Address: 00:23:8b:5d:51:39
    Link detected: no
    Module Alias: "pci:v000010ECd00008168sv0000103Csd00003603bc02sc00i00"
    Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #14 (PCI bridge)
    Lg

    ich seh grad ich hab die Ausgaben nicht ordentlich angezeigt, sorry sagt mir doch bitte wie das richtig geht ^^

  4. #4
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    361

    Default AW: Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    So ist doch schon besser und brauchbarer. Du hast jetzt zwei Möglichkeiten:

    1. Du installierst dir das Paket b43-firmware von PackMan, startest das Netzwerk neu, z.B. mit:
    Code:
    systemctl restart network.service
    oder wenn der NetworkManager verwendet wird geht auch:
    Code:
    systemctl restart NetworkManager.service
    Vor openSUSE 12.1 und der Verwendung von systemd war es
    Code:
    rcnetwork restart
    , welches aufgrund einer Verknüpfung noch immer funktioniert und verbindest dich mit dem gewünschten Netzwerk.

    2. Du installierst stattdessen die Pakete broadcom-wl sowie broadcom-wl-kmp-desktop von PackMan und startest den Computer neu.

    Am besten ist wenn du mit dem Laptop am LAN bist, dann kannst du, da es später noch öfters gebraucht wird, das Repo von PackMan gleich hinzufügen und alles direkt über die Paketverwaltung (YaST, Zypper) online installieren.

    Repo von PackMan hinzufügen:
    Code:
    zypper ar -f -n "PackMan Repo" http://ftp.halifax.rwth-aachen.de/packman/suse/12.1/ Packman
    Paket(e) installieren:
    Bei Verwendung des freien b43 und der proprietären Firmware(1. Möglichkeit):
    Code:
    zypper in b43-firmware
    Bei Verwendung des proprietären Treibers (2. Möglichkeit, broadcom-wl/sta):
    Code:
    zypper in broadcom-wl broadcom-wl-kmp-desktop
    Alle Schritte sind als Root/su auszuführen.

    Quote Originally Posted by gelberTextmarker View Post
    ich seh grad ich hab die Ausgaben nicht ordentlich angezeigt, sorry sagt mir doch bitte wie das richtig geht ^^
    Du hast Zitat (quote) statt Code verwendet. Nimm nicht die Sprechblase, sondern die Raute, oder:
    [code]Text[/code]

    Ergebnis:
    Code:
    Text
    Was du verwendet hast:
    [quote]Text[/quote]

    Ergebnis:
    Text

  5. #5

    Default Re: AW: Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    Hey Tommfa, danke für deine Hilfe also das klingt ja alles nicht nur schön und gut, sondern auch einfach aber was mach ich denn, wenn ich mit meinem Linux System gar nicht ins internet komme? Ich kann irgendwie nicht das Paket b43-firmware von Packman runterladen, da steht nur Function ereg() is deprecated wenn ich auf Download klicke...und das Problem hab ich bei dem Broadcom-wl Paket auch...ich muss eigtl alles (zumindest bis mein Linux system auch ins internet will) mit Windows laden und dann bei Linux installieren...Lan-kabel hab ich nicht, kann mich also nicht mit Lan an den Router hängen...
    Lg

  6. #6

    Default Re: AW: Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    Sorry, dass ich meinen alten Beitrag nich editiere, aber irgendwie zeigt der mir das nicht an (??)
    Jedenfalls hab ich dein Link(PackMan), bei dem ich ja nicht runterladen konnte, mit "ziel speichern unter" doch eine rpm Datei speichern können. Leider kann ich die nicht wirklich installieren unter Linux...da krieg ich die Meldung: "Missing usr/bin/apper" also so in etwa, der genau wortlaut is n bisschen anders aber er sagt halt nur dass usr/bin/apper nicht da ist, was ich in der tat nicht habe...

    Lg

  7. #7
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    361

    Default AW: Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    Dann erkläre doch bitte wie du das gemacht hast, USB-Stock?
    Quote Originally Posted by gelberTextmarker View Post
    Jetz hab ich mir von der Broadcomseite den Treiber geholt,
    Jedenfalls holst du dir das Paket b43-firmware von hier, installierst es als Root/su über die Konsole mit:
    Code:
    rpm -ivh Pfad/zum/Paket/b43-firmware-4.174.64.19-3.2.noarch.rpm
    und startest das Netzwerk neu.

    Edit: Jetzt habe ich deinen letzten Beitrag überlesen, aber das mit rpm passt schon.

  8. #8

    Default Re: AW: Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    Originally Posted by tommfa
    Dann erkläre doch bitte wie du das gemacht hast, USB-Stock?
    Originally Posted by gelberTextmarker
    Jetz hab ich mir von der Broadcomseite den Treiber geholt,
    Das hab ich mir von hier runtergeladen:
    Broadcom.com - 802.11 Linux STA driver
    Dann aufn USB stick und dann halt mit linux gestartet...aber wie gesagt, ich kann das halt nicht installieren.

    Ich hab den in der "README" aufgezeigten fehler:
    Code:
    make: *** /lib/modules/"release"/build: No such file or directory. Stop.
    So....ich hab jetzt den Link den du mir im letzten Post geschickt hast, geöffnet, geladen und installiert, und bin jetzt mit openSUSE online...ich danke dir damit hat Linux einen User mehr ohne Internet könnte ich wohl kaum was mit Linux anfangen
    Ach und soll ich mir eigtl Sorgen machen, dass ich bei jeder Installation von RPM-Paketen die Meldung kriege, dass mir usr/bin/apper fehlt?

  9. #9
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    361

    Default AW: Re: AW: Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    Mir ging es nur darum wie der Pakettransfer Windows > Linux stattgefunden hatte. Bei Dualboot kannst du ja auf die Partition von Windows unter Linux zugreifen.

    Quote Originally Posted by gelberTextmarker View Post
    Ach und soll ich mir eigtl Sorgen machen, dass ich bei jeder Installation von RPM-Paketen die Meldung kriege, dass mir usr/bin/apper fehlt?
    Ist auch noch neu für mich, keine Ahnung. Hier ist Apper zwar installiert, gibt aber die gleiche Meldung. Ich habe mich noch nicht richtig darum gekümmert, da für mich eigentlich uninteressant.

  10. #10

    Default Re: AW: Re: AW: Kein Wlan mit Broadcom-Karte, open SUSE 12.1

    Ja das hab ich aber auch erst später selbst gecheckt, ich hab ein USB stick genommen (inzwischen lustig weil kompliziert^^) ich habs jetz aber mit dem Link den du mir geschickt hast ohne USB-Stick gemacht sondern auf direkt auf meinen Downloadordner von Windows zugegriffen. Ja die RPM-Pakete werden zwar installiert aber trotzdem gibts die Meldung...also erstmal ignorieren bis mir mein Linux abschmiert
    Lg und vielen Dank nochmal

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •