Results 1 to 8 of 8

Thread: KDE errors slow login

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,330

    Default KDE errors slow login

    12.1 32bit KDE. My .xsession-errors lists repeated...

    HTML Code:
    X Error: BadValue (integer parameter out of range for operation) 2
      Major opcode: 53 (X_CreatePixmap)
      Resource id:  0x0
    X Error: BadDrawable (invalid Pixmap or Window parameter) 9
      Major opcode: 14 (X_GetGeometry)
      Resource id:  0x260026c
    X Error: BadWindow (invalid Window parameter) 3
      Major opcode: 3 (X_GetWindowAttributes)
      Resource id:  0xb73a1ff4
    X Error: BadDrawable (invalid Pixmap or Window parameter) 9
      Extension:    148 (RENDER)
      Minor opcode: 4 (RenderCreatePicture)
      Resource id:  0x260026c
    X Error: RenderBadPicture (invalid Picture parameter) 160
      Extension:    148 (RENDER)
      Minor opcode: 8 (RenderComposite)
      Resource id:  0x260026c
    X Error: BadDrawable (invalid Pixmap or Window parameter) 9
      Major opcode: 55 (X_CreateGC)
      Resource id:  0x260026c
    ...for a long time. 57 Kbs long. I renamed the .kde4 directory in my home and started KDE again. The login time is long and the errors the same. I never had this problem with 11.3 on this box. Neither have I had it with 12.1 on my other (64bit) box. Googling brought no useful hits.

    Any suggestions? Thanks.

  2. #2

    Default Re: KDE errors slow login

    Hi,

    well on my 11.3 box, where login time is normal, my xsession-error file is 138 KB long, so I don't think that's the direct cause of the problem.

    Perhaps you could make a whole new user and see whether his login time is just as long?

    HTH

    Lenwolf

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,330

    Default Re: KDE errors slow login

    Quote Originally Posted by lenwolf View Post


    Perhaps you could make a whole new user and see whether his login time is just as long?

    HTH

    Lenwolf
    New user. Same delay. Same errors.

  4. #4
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,330

    Default Re: KDE errors slow login

    Some further information. I cannot change the display resolution from Personal Settings. Running as root I cannot get sax3 to run. Yast hardware reports the on-board card as being a VIA CN700/P4M800 S3 Unichrome Pro. But tells me the driver for the display is NOT active.

  5. #5
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,330

    Default Re: KDE errors slow login

    My /var/log/Xorg.log file tells me...

    HTML Code:
    [    39.485] (II) Loading extension DRI2
    [    39.485] (==) Matched via as autoconfigured driver 0
    [    39.485] (==) Matched openchrome as autoconfigured driver 1
    [    39.485] (==) Matched unichrome as autoconfigured driver 2
    [    39.485] (==) Matched fbdev as autoconfigured driver 3
    [    39.485] (==) Matched vesa as autoconfigured driver 4
    [    39.485] (==) Assigned the driver to the xf86ConfigLayout
    [    39.485] (II) LoadModule: "via"
    [    39.489] (WW) Warning, couldn't open module via
    [    39.489] (II) UnloadModule: "via"
    [    39.489] (II) Unloading via
    [    39.489] (EE) Failed to load module "via" (module does not exist, 0)
    [    39.489] (II) LoadModule: "openchrome"
    [    39.491] (WW) Warning, couldn't open module openchrome
    [    39.491] (II) UnloadModule: "openchrome"
    [    39.491] (II) Unloading openchrome
    [    39.491] (EE) Failed to load module "openchrome" (module does not exist, 0)
    [    39.491] (II) LoadModule: "unichrome"
    [    39.494] (WW) Warning, couldn't open module unichrome
    [    39.494] (II) UnloadModule: "unichrome"
    [    39.494] (II) Unloading unichrome
    [    39.494] (EE) Failed to load module "unichrome" (module does not exist, 0)
    [    39.494] (II) LoadModule: "fbdev"
    [    39.495] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [    39.522] (II) Module fbdev: vendor="X.Org Foundation"
    [    39.522]     compiled for 1.10.4, module version = 0.4.2
    [    39.523]     ABI class: X.Org Video Driver, version 10.0
    [    39.523] (II) LoadModule: "vesa"
    [    39.523] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [    39.531] (II) Module vesa: vendor="X.Org Foundation"
    [    39.531]     compiled for 1.10.4, module version = 2.3.0
    [    39.531]     Module class: X.Org Video Driver
    [    39.531]     ABI class: X.Org Video Driver, version 10.0
    [    39.531] (II) FBDEV: driver for framebuffer: fbdev
    [    39.531] (II) VESA: driver for VESA chipsets: vesa
    [    39.531] (--) using VT number 7
    ...now since my card is a VIA I would expect that the via module should be loaded. But it does not exist. Does that mean that the install did not recognize the card? I never had such problems with previous installs on this box.

  6. #6

    Default Re: KDE errors slow login

    I don't use 12.1 (yet), but I have a couple of suggestions:

    To diagnose:
    1. If you have the KDE Desktop Effects enabled, disable them - Configure Desktop -> Desktop Effects -> uncheck Enable desktop effects on startup; if now the login is "normal" then indeed video driver is the root of your problem. If still slow, then define what exactly is "slow" and what is normal.

    2. Have you modified /etc/hosts entries by any chance - is there any way your local IPv4 or IPv6 address could be resolving to something else, or not resolving locally?

    To repair:
    1. Reinstall X packages, and verify you have video drivers, openchrome and unichrome X packages installed. You can also manually verify what drivers you have installed in /usr/lib/xorg/modules/drivers
    2. Remove offending hosts entries.

  7. #7
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,330

    Default Re: KDE errors slow login

    Quote Originally Posted by zurab View Post
    I don't use 12.1 (yet), but I have a couple of suggestions:


    To diagnose:
    1. If you have the KDE Desktop Effects enabled, disable them - Configure Desktop -> Desktop Effects -> uncheck Enable desktop effects on startup; if now the login is "normal" then indeed video driver is the root of your problem. If still slow, then define what exactly is "slow" and what is normal.

    2. Have you modified /etc/hosts entries by any chance - is there any way your local IPv4 or IPv6 address could be resolving to something else, or not resolving locally?

    To repair:
    1. Reinstall X packages, and verify you have video drivers, openchrome and unichrome X packages installed. You can also manually verify what drivers you have installed in /usr/lib/xorg/modules/drivers
    2. Remove offending hosts entries.
    Thank you for the suggestions.

    1. Desktop effects were disabled immediately after installation.

    2. Yes I disabled the loopback.

    HTML Code:
    # special IPv6 addresses
    #::1             localhost ipv6-localhost ipv6-loopback
    
    fe00::0         ipv6-localnet
    
    ff00::0         ipv6-mcastprefix
    ff02::1         ipv6-allnodes
    ff02::2         ipv6-allrouters
    ff02::3         ipv6-allhosts
    Based on the output to /var/log/Xorg.0.log I determined that no VIA or Openchrome drivers were being loaded. I installed Openchrome and loaded it at boot time. This speeded up the first part of the boot a bit. But the time between user login and a useable desktop is still about two minutes and my .xsession-errors still reports the same BadWindow, BadValue, BadDrawable errors.

    It seems like the Openchrome drivers are bug ridden as noted at [Bug 731978] unichrome: Playing Videos crashes X-server but I am continuing the search.

  8. #8
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,330

    Default Re: KDE errors slow login

    [QUOTE=zurab;2410465

    To repair:
    1. Reinstall X packages, and verify you have video drivers, openchrome and unichrome X packages installed. You can also manually verify what drivers you have installed in /usr/lib/xorg/modules/drivers
    2. Remove offending hosts entries.[/QUOTE]

    On your suggestion I installed the Unichrome driver and replaced the Openchrome I was loading. User login time has dropped from two minutes to about 30 seconds. I can live with that.

    Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •