Beste forummers,
Alweer een draadloos probleem.

Allereerst: over het begin van dit probleem heb ik op 17 november gepost in het engelstalige forum. Daarop is één (niet erg nuttige) reactie gekomen. Ik heb intussen wel verder geklust, maar de draadloze verbinding komt nog steeds niet tot stand. Ik hoop dus dat iemand op dit NL forum me verder kan helpen.

Systeem: openSUSE 11.4 64b (desktop) met KDE 4.7.0
Netwerk hardware:
- Ethernet op moederbord (defekt)
- Ethermet op losse kaart (werkt normaal)
- Access point: Fritz!Boz 7170 modem/router (werkt normaal)
- Wlan: Linksys WUSB100 V2 adapter.

Bij het installeren van oS11.4, ongeveer een jaar geleden, was alleen ethernet beschikbaar. De Linksys adapter heb ik 2 weken geleden gekocht om de overgang naar een andere provider (binnenkort) te vergemakkelijken. Deze uitbreiding achteraf zal wel de reden zijn waarom de KDE NetworkManager widget niet was geïnstalleerd. Dit manco heb ik intussen verholpen.
Installeren via ifup werkt niet: ik kan geen netwerk kiezen, geen versleuteling kiezen en geen wachtwoord opgeven.
Met NetworkManager zijn die instellingen wel mogelijk.
Eerste vraag: het wachtwoord voor de WPA2 beveiliging bestaat uit 16 cijfers. Het is me niet duidelijk of ik die moet opgeven als 1111-2222-3333-4444 of als 1234567890123456. Ik heb beide zonder succes geprobeerd: het probleem ligt blijkbaar ergens anders.
In NetwerkManager heb ik ook ingesteld dat het wachtwoord onversleuteld in een bestand wordt opgeslagen.

Hieronder een stukje output van /var/log/NetworkManager
Code:
uit /var/log/NetworkManager
voorafgaand: Ethernetplug uitgetrokken, plug in Linksys UB wireless adapter, reboot.

Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0) starting connection 'FRITZ!Box 7170'
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> (wlan0): device state change: 3 -> 4 (reason 0)
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  associating -> disconnected
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0/wireless): connection 'FRITZ!Box 7170' requires no security.  No secrets needed.
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Config: added 'ssid' value 'FRITZ!Box 7170'
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Config: added 'mode' value '1'
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Config: added 'frequency' value '2437'
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Config: added 'bssid' value '00:1c:4a:4b:f9:a0'
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Config: added 'key_mgmt' value 'NONE'
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Config: set interface ap_scan to 2
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  scanning -> associating
Nov 26 12:12:31 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  associating -> disconnected
Nov 26 12:12:31 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
Nov 26 12:12:31 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  scanning -> associating
Nov 26 12:12:41 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  associating -> disconnected
Nov 26 12:12:41 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
Nov 26 12:12:41 oS114 NetworkManager[1395]: <info> (wlan0): supplicant connection state:  scanning -> associating
Nov 26 12:12:47 oS114 NetworkManager[1395]: <warn> Activation (wlan0/wireless): association took too long, failing activation.
Nov 26 12:12:47 oS114 NetworkManager[1395]: <info> (wlan0): device state change: 5 -> 9 (reason 11)
Nov 26 12:12:47 oS114 NetworkManager[1395]: <warn> Activation (wlan0) failed for access point (FRITZ!Box 7170)
Nov 26 12:12:47 oS114 NetworkManager[1395]: <info> Marking connection 'FRITZ!Box 7170' invalid.
Nov 26 12:12:47 oS114 NetworkManager[1395]: <warn> Activation (wlan0) failed.
Nov 26 12:12:47 oS114 NetworkManager[1395]: <info> (wlan0): device state change: 9 -> 3 (reason 0)
Nov 26 12:12:47 oS114 NetworkManager[1395]: <info> (wlan0): deactivating device (reason: 0).
Nov 26 12:12:47 oS114 NetworkManager[1395]: <info> (wlan0): reset MAC address to 00:00:00:00:00:00
oS114:~ # cat /var/log/NetworkManager
Interessant hierin vind ik de regel:
"Nov 26 12:12:21 oS114 NetworkManager[1395]: <info> Activation (wlan0/wireless): connection 'FRITZ!Box 7170' requires no security. No secrets needed."
Vreemd, omdat het AP wel degelijk WPA2 met wachtwoord verlangt.

In de log is correct dat de SSID "Fritz!Box 7170" de SSID is van het WAP. Ook is de gelogde waarde van BSSID inderdaad het MAC adres van het WAP.

Maar de verbinding komt kennelijk niet tot stand.

Kan iemand me verder helpen?
Alvast bedankt !