Results 1 to 2 of 2

Thread: Samba vfs=recycle problem (bug?)

  1. #1

    Default Samba vfs=recycle problem (bug?)

    I am trying to setup my home server again with openSuse 12.1. Samba is up and running with the exception of the vfs=recycle module.

    It is working but only with directories. If I delete fileA... it disappears and doesn't go to the trashbin but if I delete new_folder, the folder and any sub folders will go to the trashbin BUT any files within the folder will not.

    By the way, my vfs is located under global and my recycle:repository = [absolute path] .

    I have tried creating recycle bins in each share and it works without a hitch but I am really trying to create a "central" trashbin where everything goes regardless of what share it comes from.

    I have tried ../trashbin but the files keep disappearing (the folders are, as stated, kept there)


    Also, I had this same exact setup before (11.4) and it was working so I was wondering if this is a bug in the updated samba, or something? I have search google but nothing really came up.

    Thank you in advance for any information about the subject.

  2. #2

    Default Re: Samba vfs=recycle problem (bug?)

    *nudge* *nudge* -- I am still having the issues and I have attempted several courses of actions to resolve it:

    1. Reinstalling samba
    2. Configuring from scratch
    3. Restart of all clients (I found a forum about issues due to the clients instead) but didn't work.

    Can vfs recycle:repository handle absolute paths? I found forums that said it couldn't but it worked for me in the past. It still works.. the only difference is that files are not copied to the trash - they just disappear while folders remain.

    Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •