Results 1 to 8 of 8

Thread: [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

  1. #1

    Question [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

    Hello, everyone.

    I am new to openSUSE and these forums, but not (completely) new to Linux.

    I have been an Ubuntu/Linux Mint user for nearly the past five years. Unfortunately, due to some regressions in accessibility in these distros, I have been thinking of switching over to openSUSE's KDE edition based upon some research which I have been doing over the past month or so. I am very interested in what openSUSE has to offer, and I want to learn more about it.

    I'll keep this part of my description brief, but I want to give as complete a background of my situation as I can. I use Compiz's Enhanced Zoom Desktop (eZoom) plugin for screen magnification on my current Linux Mint 11 installation (running GNOME 2.32). Unfortunately, however, this feature has been limited both in GNOME 3 and in Ubuntu's Unity desktop, making them (for the most part) unusable to me. I have been tryi8ng out KDE for the past month or so, and I am loving it. the KWin Window Manager hs a built-in "Zoom" feature which can be accessed by the following keyboard shortcuts:

    Zoom In: Meta+Plus (+)
    Zoom Out: Meta+Minus (-)
    Normal Size: Meta+0

    I recently downloaded the final release of openSUsE 12.1, and I found that the screen panned VERY smoothly when using the KWin Zoom feature, so this may be a viable alternative to Compiz for me. I have been testing openSUSE both on a virtual machine and in a live USB environment, and I have encountered a slight problem. When I zoom my screen, the mouse pointer is not scaled (or it is somehow transparent) and so I am unable to navigate the system. Scaling works fine on my Linux Mint 11 system, but movement while the screen is magnified is very jumpy compared to openSUSE which is very smooth.

    To access the settings for the Zoom feature, just do the following:

    1. Open the Kicker menu
    2. Search for Desktop Effects
    3. In the Desktop Effects window, click the All Effects tab
    4. Under the Accessibility category, select the Zoom feature and access its settings

    It is set to Scale by default.

    I do not know if this could be related to my video card. Just in case this information might be helpful, the lshw command returns this information about my video card:

    Code:
    *-display
              description: VGA compatible controller
              product: C61 [GeForce 6150SE nForce 430]
              vendor: nVidia Corporation
              physical id: d
              bus info: pci@0000:00:0d.0
              version: a2
              width: 64 bits
              clock: 66MHz
              capabilities: pm msi vga_controller bus_master cap_list rom
              configuration: driver=nvidia latency=0
              resources: irq:22 memory:fb000000-fbffffff memory:e0000000-efffffff memory:fc000000-fcffffff memory:c0000000-c001ffff

    I have also e-mailed the KDE Accessibility mailing list about this, but I still have not found a solution to this issue.

    I apologize if I have posted this in the wrong forum. Since this was nto related to a particular application, I thought that this would be the best place for my post.

    Thanks for any input on this issue. If any further information can assist in solving this, please let me know what I would need to provide and I will do so.

    Take care.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

    On 11/25/2011 06:06 AM, RKCole wrote:
    >
    > Hello, everyone.
    >
    > I am new to openSUSE and these forums, but not (completely) new to
    > Linux.
    >
    > I have been an Ubuntu/Linux Mint user for nearly the past five years.
    > Unfortunately, due to some regressions in accessibility in these
    > distros, I have been thinking of switching over to openSUSE's KDE
    > edition based upon some research which I have been doing over the past
    > month or so. I am very interested in what openSUSE has to offer, and I
    > want to learn more about it.
    >
    > I'll keep this part of my description brief, but I want to give as
    > complete a background of my situation as I can. I use Compiz's Enhanced
    > Zoom Desktop (eZoom) plugin for screen magnification on my current Linux
    > Mint 11 installation (running GNOME 2.32). Unfortunately, however, this
    > feature has been limited both in GNOME 3 and in Ubuntu's Unity desktop,
    > making them (for the most part) unusable to me. I have been tryi8ng out
    > KDE for the past month or so, and I am loving it. the KWin Window
    > Manager hs a built-in "Zoom" feature which can be accessed by the
    > following keyboard shortcuts:
    >
    > Zoom In: Meta+Plus (+)
    > Zoom Out: Meta+Minus (-)
    > Normal Size: Meta+0
    >
    > I recently downloaded the final release of openSUsE 12.1, and I found
    > that the screen panned VERY smoothly when using the KWin Zoom feature,
    > so this may be a viable alternative to Compiz for me. I have been
    > testing openSUSE both on a virtual machine and in a live USB
    > environment, and I have encountered a slight problem. When I zoom my
    > screen, the mouse pointer is not scaled (or it is somehow transparent)
    > and so I am unable to navigate the system. Scaling works fine on my
    > Linux Mint 11 system, but movement while the screen is magnified is very
    > jumpy compared to openSUSE which is very smooth.
    >
    > To access the settings for the Zoom feature, just do the following:
    >
    > 1. Open the Kicker menu
    > 2. Search for Desktop Effects
    > 3. In the Desktop Effects window, click the All Effects tab
    > 4. Under the Accessibility category, select the Zoom feature and access
    > its settings
    >
    > It is set to Scale by default.
    >
    > I do not know if this could be related to my video card. Just in case
    > this information might be helpful, the lshw command returns this
    > information about my video card:
    >
    >
    > Code:
    > --------------------
    >
    > *-display
    > description: VGA compatible controller
    > product: C61 [GeForce 6150SE nForce 430]
    > vendor: nVidia Corporation
    > physical id: d
    > bus info: pci@0000:00:0d.0
    > version: a2
    > width: 64 bits
    > clock: 66MHz
    > capabilities: pm msi vga_controller bus_master cap_list rom
    > configuration: driver=nvidia latency=0
    > resources: irq:22 memory:fb000000-fbffffff memory:e0000000-efffffff memory:fc000000-fcffffff memory:c0000000-c001ffff
    >
    > --------------------
    >
    >
    >
    > I have also e-mailed the KDE Accessibility mailing list about this, but
    > I still have not found a solution to this issue.
    >
    > I apologize if I have posted this in the wrong forum. Since this was
    > nto related to a particular application, I thought that this would be
    > the best place for my post.
    >
    > Thanks for any input on this issue. If any further information can
    > assist in solving this, please let me know what I would need to provide
    > and I will do so.
    >
    > Take care.
    >
    >


    -=WELCOME=- new poster, and potential new openSUSE user..

    unfortunately i'm afraid i can't directly help you...but, i just
    couldn't stand to see your post sit with no response for (now) almost
    ten hours...

    my guess is that means that we don't have very many sight impaired among
    our usual helpers or daily visitors...please don't take that to mean we
    are not wanting/willing to try to help..

    i say this: you made a very well constructed post....i think if i
    actually knew how to help it would be easy for me...but, what i did was
    enable desktop effects and set the zoom feature to on....but, i wasn't
    able to do any zooming (what might my "Meta" key look like? i tried
    every combo of alt, ctrl, alt gr, shift, space i could think of)

    so, let me give some theoretical questions/answers:

    -Why might it work in Mint but not in openSUSE? possible answers 1)
    different kernel, 2) compiz is better at it than is KDE's magic, 3)
    version of video driver in use

    -What can be done? well, i would start by checking to see what video
    driver you are now using...you can do that in KDE by clicking on "My
    Computer" and read it directly (near the bottom right) and if it is nv
    or (i forget the names of the other open drivers) then you might want to
    follow this path to install the proprietary nVidia driver:
    http://tinyurl.com/37v9y7m

    caution: read the caveat in my sig....and, do your homework on how to
    roll back to the driver you have now prior to beginning..

    you might also experiment with:
    - turning off all other desktop effects (maybe?)
    - or, maybe choose a different desktop theme
    - or, a different mouse pointer [pick a bigger or smaller to begin with??]
    - or, in the config desktop zoom, set the mouse pointer away from scaled
    to "keep" or "hide" (maybe they mislabeled the switches??) *or* use a
    different zoom factor (maybe it works at a different factor???)

    --
    DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
    http://tinyurl.com/DD-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

    On 11/25/2011 04:36 PM, DenverD wrote:
    > you might also experiment with:


    well SHUCKS...i was experimenting with the desktop effect of "Magnify
    the section of the screen that is near the mouse cursor" along with
    every potential 'Meta' key combo i could think of and accidently found a
    keycombo which cause the mail to be sent before i was ready...

    so....try some of the ideas mentioned and come back (hopefully, to find
    a *real* guru on zoom (and/or other things to help you) has already
    given good advice)..

    --
    DD http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

    I tried what you describe now (and also did not know what the meat key
    is, so I defined a new shortcut for it alt++ and alt+- to see the effect).

    Using also a nvidia card the mouse pointer can not be influenced by the
    scale setting. I am using the proprietary nvidia driver. Of course I am
    not sure if it has anything to do with the graphics card.
    I hope that someone with a different hardware will also try that so that
    we can at least narrow there the problem might be (nvidia problem, kde
    problem or whatever else).

    Is it an option for you for the moment to simply use in general a large
    mouse pointer by selecting different mouse pointer icons? There are
    plenty available.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

    I changed no for testing the mouse cursor theme to oxygen white and
    guess what, now the mouse cursor zooms with the zoom feature!

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

    Am 25.11.2011 16:36, schrieb DenverD:
    > (what might my "Meta" key look like?


    I found that on my machine the meta key is the "windows key"

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  7. #7

    Default Re: [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

    Hello there, everyone.

    Thank you for your replies, DenverD and martin_helm.

    I am very sorry about not clarifying the "Meta" key. From my research, and as martin_helm discovered, KDE refers to the Windows logo key as the Meta key. I've noticed that a lot of Linux distros also refer to it as the Super key.

    I should have thought to change the cursor theme to test it out when I was testing openSUSE. That solves the problem!

    To the both of you: thank you for the wealth of information.

    I will report this to the KDE list as well in case others had this concern/issue.

    Thanks again for all of the help.

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: [Blind User] openSUSE 12.1 (KDE) and KWin "Zoom" Scaling

    Glad you have it working.
    Not sure where this bug belongs to, I would guess you are right about
    KDE and thank you for reporting it to their list, also consider to file
    a bug report.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •