Results 1 to 4 of 4

Thread: Pulseaudio and Amarok in 12.1

  1. #1

    Default Pulseaudio and Amarok in 12.1

    As allays pulseaudio isn't working but in 12.1 its disabling doesn't help. The issue is: my 5.1 system sounds crappy (and subwoofer doesn't work) when I use amarok and pulseaudio is enabled, but VLC and other videoplayers are able to play 5.1 sound. If I disable pulseaudio amarok sounds great (and subwoofer works), but videoplayers are unable to play 5.1 - only stereo (VLC claims that audio device is busy).

    Seems that I need amarok to use other sound device than pulseaudio, but when pulseaudio is enabled I have no other options in phonon audio setup. What should I do?

  2. #2

    Default Re: Pulseaudio and Amarok in 12.1

    I've reinstalled the system and started all over. Seems that actual issue is Phonon. My soundcard is 7.1, but I use 5.1 output. Phonon seems to remember about subwoofer only when 7.1 device is enabled. So after each reboot I have to go to the Phonon settings, change output audio device to 7.1 and then back to 5.1 again to make subwoofer work for audio files playing in browser and make amarok play 5.1 sound. Otherwise there are no subwoofer output for browser and only stereo output for amarok.

  3. #3
    Join Date
    Nov 2009
    Location
    United States
    Posts
    5

    Default Re: Pulseaudio and Amarok in 12.1

    what i have noticed in phonon, one or the other devices need to be manually turned off.

    for example: hdmi profile needs to be set to off in order for iec958 to function.

    this is all using pulse, the problem with pulse, is these settings don't exist, one does in phonon, i can set hdmi to off, i cannot locate iec958 profile.

    i found it using pavucontrol - PulseAudio Volume Control.

    that's as far as i got.

    i will soon take this box to my tv and try it via hdmi with iec958 off.

    edit: you may want to try and reverse what you've done, idk how, but just a suggestion.

  4. #4

    Default Re: Pulseaudio and Amarok in 12.1

    The problem solved, tnx to this post.
    In /et/pulse/daemon.conf I've made following changes:

    Code:
     
    enable-lfe-remixing = yes
    default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •