Results 1 to 3 of 3

Thread: first samba attempt: smbd wont start and cifs wont enable

  1. #1

    Default first samba attempt: smbd wont start and cifs wont enable

    hi,

    I am trying to set up a samba server on suse with the help of this video tutorial:

    Network File-sharing Tutorial video tutorial - Using Samba to Share Network Files and Printers - Learn: SUSE, yast, software, linux, web, shared, windows, browser, notes, available, settings, systems, files, making, tutorials, share, sharing, service

    after doing a bunch of configuration of the samba interface, the tutorial states to 'check to make sure nmbd and smbd services are running'. unfortunately smbd is not. I also look back (yast) and notice that cifs is not enabled, and I can't get it to enable. this is the first time I have ever attempted to set up a samba server. My terminal skills are pretty good, however I will need alot of help with configuration files.

    my purpose for setting up a samba server is to allow my sister internet access to family pictures that are on external hard drives. she lives about 50 miles from me. we both have high speed cable (road runner).

    any help would be most appreciated. progress of ANY kind would be awesome.
    forgive me for not replying later today, I have to work, but I PROMISE to reply tonight and tomorrow.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: first samba attempt: smbd wont start and cifs wont enable

    Never tried to share over Road Runner to another system. Its important to know:

    1. openSUSE version & Desktop for Host (Server)
    2. Guest Computer System
    3. How do you configure Samba? YaST, SWAT, Manual?

    I suggest you want to also look at the following site for more help with Samba: openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna

    You can also post a copy of your smb.conf file:
    Code:
    in terminal: sudo cat /etc/samba/smb.conf
    Copy the text from terminal and post it in a forum message using the Advanced Message Editor and place the text inside of a Code # field (Looks kind of like the command above, but longer and with different text).

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: first samba attempt: smbd wont start and cifs wont enable

    The non-running of the samba daemons has been a problem in 11.4 and now also in 12.1. And to cap it off, the problem is different from 11.4 to 12.1.
    Have a look at this thread if you have 11.4: post number three here: Samba set up : nmb is not starting
    Have a look at the sticky at top of newtworking forum if you have 12.1 : Problem with Samba in openSUSE 12.1 re systemd
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •