Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: neither yast nor zypper works in opensuse 12.1

  1. #1

    Default neither yast nor zypper works in opensuse 12.1

    I upgraded from 11.4 to 12.1. Nice many things are working.

    Except the updates!!! Neither zypper nor yast work. I removed PackageKit as it was blocking the former two. Still no use. I donot know now how to update the system for patches and/or bug fixes.

    I use KDE. (My laptop is Macbook Pro 7.1 with NVIDIA graphic card). It is not shutting down as well after the upgrading to 12.1. The screen flickers hundreds of times. But does not shut down. I have updated all Nvidia drivers and added Nvidia repos while upgrading.

    Can anybody help fix these issues ?

    Thanks in advance.

    HSN

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: neither yast nor zypper works in opensuse 12.1

    It's all working here

    If you open a terminal and do

    Code:
    su -
    zypper up
    Post the resulting feedback from the terminal
    You can use your mouse to copy and paste
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,714
    Blog Entries
    1

    Default Re: neither yast nor zypper works in opensuse 12.1

    It might be useful to see your configured repos too:

    Code:
    zypper lr -d
    Don't forget to post your output between CODE tags.

  4. #4

    Default Re: neither yast nor zypper works in opensuse 12.1

    Download (curl) error for 'http://packman.inode.at/suse/Factory/Essentials/repodata/repomd.xml':
    Error code: User abort
    Error message: connect() timed out!

  5. #5

    Default Re: neither yast nor zypper works in opensuse 12.1

    17 | repo-12.1-non-oss | openSUSE-12.1 Non-OSS | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/non-oss |
    18 | repo-12.1-nvidia | NVIDIA | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/12.1/ |
    19 | repo-12.1-oss | openSUSE-12.1 OSS | Yes | Yes | 99 | yast2 | Index of /distribution/12.1/repo/oss |
    20 | repo-12.1-packman | packman | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_12.1/ |
    21 | repo-12.1-update | openSUSE-12.1 Updates | Yes | Yes | 99 | rpm-md | Index of /update/12.1 |
    22 | wrapped | Wrapped proprietary applications | Yes | Yes | 99 | rpm-md | Index of /wrapped/openSUSE_11.3/
    12 | packman-essentials | packman-essentials | Yes | Yes | 99 | rpm-md | Index of /suse/Factory/Essentials/

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: neither yast nor zypper works in opensuse 12.1

    Please post result of

    zypper lr -d

    Tell us if there is anything unusual about your internet connection (ie; Proxy)
    Where in the world are you?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: neither yast nor zypper works in opensuse 12.1

    zypper rr 12

    You don't need that repo
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: neither yast nor zypper works in opensuse 12.1

    Hi, there is no problem with my internet connection. I am using high speed bradband connection. I can open those URLs and check. I am in Japan now.

    Thanks for your help in advance.

    (All other repos are disabled. Above are the only ones which are enabled.)

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: neither yast nor zypper works in opensuse 12.1

    You should also remove repo 22 it's for 11.3
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: neither yast nor zypper works in opensuse 12.1

    zyper rr 12 I used it as it was mostly demanded when I upgraded from 11.4 to 12.1. Many packages of 11.4 which were installed already in the system like k3b, amarok, libav*, xine etc. were not there in packman. So, the zypper dup stopped before the installation. I had to add this repo. and re-run zypper dup. Only then it proceeded with installation.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •