Results 1 to 2 of 2

Thread: Nvidia drivers with 12.1

Hybrid View

  1. #1

    Default Nvidia drivers with 12.1

    Here's a comment for anybody else having the same problem.

    Basic problem: GUI does not load with NVIDIA drivers in opensuse 12.1 (also in 11.4 and 11.3)

    Hardware: NVIDIA 7300 GS

    Situation: Fresh install of 12.1 and it worked OK, GUI loaded and system was OK but graphics a bit sluggish. I installed the NIVIDIA drivers and then it would not load GUI. I downloaded the nvidia drivers, file "NVIDIA-Linux-x86_64-285.05.09.run" and executed it. The nvidia install automatically removed the nouveau driver. When logging in it would display all of the icons but fail when at the point it was displaying the large blue K for KDE.

    I tried a to run the install with the update flag "NVIDIA-Linux-x86_64-285.05.09.run --update". It downloaded the driver version 290.10 and installed it and all was well.

    Hope it helps somebody else.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Arizona, USA
    Posts
    488

    Default Re: Nvidia drivers with 12.1

    This is a conflict between nVidia and KDE. I learned this from our friends at Arch Linux. KDE4 is not finishing because of this conflict. In order to correct it you must edit this file:

    ~/.kde4/share/config/kwinrc

    In it you will add to the Composting section:

    Enabled=false

    In order to edit this file you must either boot up in Failsafe mode -or- use Clt-Alt-F1 to exit out to the Command line and sign on there.

    Take care,
    Chuck
    Box: Intel Core i7-4790 3.6Ghz | AMD Radeon R7 240 | 32GB RAM | openSuSE Leap 15/ KDE Plasma 5.12.6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •