Results 1 to 7 of 7

Thread: Vim crashes

  1. #1

    Default Vim crashes

    Hi,

    I'm new to openSUSE. I just installed 12.1 and tried to configure vim.
    I noticed a lot of python related plugins crashed gVim, and simply typing
    Code:
    :python print 0
    caused it to crash. This hasn't happened in any other distribution I've tried.
    The output I see is
    Code:
    ...
    7f5f4ad7d000-7f5f4ad7e000 rw-p 00021000 08:02 11010119                   /lib64/ld-2.14.1.so
    7f5f4ad7e000-7f5f4ad7f000 rw-p 00000000 00:00 0 
    7fffd58ab000-7fffd58cc000 rw-p 00000000 00:00 0                          [stack]
    7fffd59ff000-7fffd5a00000 r-xp 00000000 00:00 0                          [vdso]
    ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
    Vim: Caught deadly signal ABRT
    Vim: Finished.
    I'm just using the vim version that comes with openSUSE, as well as
    gVim installed from YaST:
    Code:
    > rpm -qa | grep vim
    vim-base-7.3-22.1.3.x86_64
    vim-7.3-22.1.3.x86_64
    gvim-7.3-22.1.3.x86_64
    vim-data-7.3-22.1.3.noarch
    How can I fix this behaviour?

  2. #2

    Default Re: Vim crashes

    I got it working after installing vim from source.

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Vim crashes

    Am 22.11.2011 06:26, schrieb sYFFAN:
    >
    > I got it working after installing vim from source.
    >
    >

    Would you so nice to file a bug report to the novell bugzilla, otherwise
    it will never be fixed for other users.
    https://bugzilla.novell.com/

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  4. #4

    Default Re: Vim crashes

    It would also be interesting to know how you compiled it. Did you enable or disable ... or even patch something?

  5. #5

    Default Re: Vim crashes

    Quote Originally Posted by please_try_again View Post
    It would also be interesting to know how you compiled it. Did you enable or disable ... or even patch something?
    I removed the original vim with yast, and then I just used this shell script to install everything.
    It applies all patches and installs with
    --enable-gui --enable-gnome-check --enable-perlinterp --enable-pythoninterp
    --enable-rubyinterp --enable-cscope --enable-multibyte --enable-fontset --with-features=huge

  6. #6

    Default Re: Vim crashes

    Quote Originally Posted by martin_helm View Post
    Am 22.11.2011 06:26, schrieb sYFFAN:
    >
    > I got it working after installing vim from source.
    >
    >

    Would you so nice to file a bug report to the novell bugzilla, otherwise
    it will never be fixed for other users.
    https://bugzilla.novell.com/
    The bug already exists, it is https://bugzilla.novell.com/show_bug.cgi?id=510306, and it's there since 2009...

  7. #7

    Default Re: Vim crashes

    Thanksfully, the one in Index of /repositories/editors/openSUSE_12.1 repo works fine with Python.
    Dell Precision T7500 | Nvidia | 12GB Ram | openSUSE 12.1 x86-64 | Gnome 3.2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •