Results 1 to 5 of 5

Thread: openSUSE 12.1: Can't Install or Update Packages Using YaST

  1. #1
    Join Date
    Dec 2008
    Location
    Ile-Aux-Noix, QC
    Posts
    57

    Default openSUSE 12.1: Can't Install or Update Packages Using YaST

    I just installed openSUSE 12.1... I'm a long time user and supporter of SuSE, but this latest version has not been a pleasant experience so far.

    First, there was no network device during setup, so I was unable to configure my LDAP authentication until I rebooted the system and restarted setup. This was very frustrating to figure out. I wasted a long time trying to guess why I couldn't access my LDAP server. I read that this was an issue with RC builds, but this is a final release. I expected this kind of terrible bug to be fixed by now.

    Then, on every subsequent boot, openSUSE tries to access the LDAP server BEFORE the network interfaces are up!!! This creates a long delay during every boot. More frustration.

    Now, I get a failure every time I try to install anything using YaST. The error I get is:

    Code:
    Subprocess failed. Error: RPM failed: error: Unable to open current directory: Permission denied
    I don't get this error when logged in as root, only when logged in as a regular user via LDAP. But I don't want to have to log into the root account every time I need to make package changes to my system, that's a huge PITA.

    None of these issues ever happened with previous versions of openSUSE. So far this is very disappointing.
    Frank Gore
    - '78 Trans Am, Pontiac 400... oops, wrong forum!
    - 2008 Kona Hoss, custom built from scratch... oops, wrong forum again!
    ...bah! Forget it! Who needs a sig anyways?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: openSUSE 12.1: Can't Install or Update Packages Using YaST

    You might want to watch this thread
    Yast software manager, permissions errors
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 12.1: Can't Install or Update Packages Using YaST

    On 2011-11-22 04:46, puregore wrote:
    > I don't get this error when logged in as root, only when logged in as a
    > regular user via LDAP. But I don't want to have to log into the root
    > account every time I need to make package changes to my system, that's a
    > huge PITA.


    Are you using "su" or "su -"?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4
    Join Date
    Dec 2008
    Location
    Ile-Aux-Noix, QC
    Posts
    57

    Default Re: openSUSE 12.1: Can't Install or Update Packages Using YaST

    neither, I was logging out of my DE and logging back in as root.

    However, I have successfully done it using both su and su - and running YaST in ncurses mode.
    Frank Gore
    - '78 Trans Am, Pontiac 400... oops, wrong forum!
    - 2008 Kona Hoss, custom built from scratch... oops, wrong forum again!
    ...bah! Forget it! Who needs a sig anyways?

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: openSUSE 12.1: Can't Install or Update Packages Using YaST

    On 2011-11-22 19:16, puregore wrote:
    >
    > neither, I was logging out of my DE and logging back in as root.


    You should not do that.

    > However, I have successfully done it using both su and su - and running
    > YaST in ncurses mode.


    You can call the graphical yast from a terminal. Just call "yast2".

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •