Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Change Yast2 style in 12.1 to be consistent with system style

  1. #1
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    28

    Question Change Yast2 style in 12.1 to be consistent with system style

    Hi everyone,
    Is there a way to change the new style for Yast in Opensuse 12.1?
    I don't really like to have it not consistent with Oxygen theme.

    Thank you in advance for your help

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    Do you have
    yast2-theme-openSUSE-Oxygen
    installed?

  3. #3
    Join Date
    Sep 2008
    Location
    Rostov-on-Don, Russia
    Posts
    25

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    I changed the yast style to Oxygen-like by installing another "branding" packages.
    Code:
    #  rpm -qa|grep yast2-qt-branding
    yast2-qt-branding-basedonopensuse-12.1-6.1.2.x86_64
    Code:
    #  rpm -qa|grep yast2-branding
    yast2-branding-basedonopensuse-12.1-6.1.2.x86_64
    Code:
    # rpm -qa|grep yast2-theme
    yast2-theme-openSUSE-Oxygen-2.21.18-2.1.1.noarch
    yast2-theme-openSUSE-2.21.18-2.1.1.noarch
    As far as I remember it required some replacement like "branding-openSUSE" to "branding-basedonopensuse"
    KDE 4.11 | openSUSE 12.3 (x86_64)

  4. #4

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    Hi,

    I have the same problem (namely that Yast turned ugly with 12.1). I do have the Oxygen theme installed. The control center is oxygen themed (and looks normal), but other Yast apps (like software management or lan management) do not pick it up. Installing yast2-branding-bastonopensuse did the trick for me. Can someone say "strange default settings"? :-)

  5. #5
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    28

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    I've tryed installing the package you suggested but i got a problem.
    Here is the out... can someone give me a hint? I've never received such an output from zypper.
    Code:
    fra@linux-22uv:~> sudo zypper in yast2-branding-basedonopensuse
    root's password:
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: yast2-branding-basedonopensuse-12.1-6.1.2.x86_64 conflicts with namespace:otherproviders(yast2-branding) provided by yast2-branding-openSUSE-2.18.0-11.1.1.noarch
     Solution 1: deinstallation of yast2-branding-openSUSE-2.18.0-11.1.1.noarch
     Solution 2: do not install yast2-branding-basedonopensuse-12.1-6.1.2.x86_64
    
    Choose from above solutions by number or cancel [1/2/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...
    
    Problem: yast2-branding-basedonopensuse-12.1-6.1.2.x86_64 requires branding-basedonopensuse, but this requirement cannot be provided
      uninstallable providers: branding-basedonopensuse-12.1-6.1.2.i586[repo-oss]
                       branding-basedonopensuse-12.1-6.1.2.x86_64[repo-oss]
     Solution 1: deinstallation of branding-openSUSE-12.1-15.3.9.x86_64
     Solution 2: do not install yast2-branding-basedonopensuse-12.1-6.1.2.x86_64
     Solution 3: do not install yast2-branding-basedonopensuse-12.1-6.1.2.x86_64
     Solution 4: break yast2-branding-basedonopensuse by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/c] (c): c
    and these are my repos
    Code:
    fra@linux-22uv:~> sudo zypper lr -d
    # | Alias        | Name                     | Enabled | Refresh | Priority | Type   | URI                                                                      | Service
    --+--------------+--------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------+--------
    1 | Tumbleweed   | Tumbleweed               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ |        
    2 | packman      | packman                  | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed                         |        
    3 | repo-non-oss | openSUSE-Current-Non-Oss | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ |        
    4 | repo-oss     | openSUSE-Current-Oss     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/     |        
    5 | repo-update  | openSUSE-Current-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-current/                    |

  6. #6
    Join Date
    Sep 2008
    Location
    Rostov-on-Don, Russia
    Posts
    25

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    Choose deinstallation of branding-openSUSE (this will cause the installation of branding-basedonopensuse package)
    KDE 4.11 | openSUSE 12.3 (x86_64)

  7. #7
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    28

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    thanks, i was just a little worried of consequences so i preferred to ask to be sure...

    all is fine now, thank you!

  8. #8
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    I made this change this morning and had many ill results.

    It basically broke most network related services I have running.

    I would have to manually start network, then mysql, apache2, smb, nmb, mythbackend, and on and on.............

    Firefox continued to work as did skype. That was the strange part.

    System related network services were broke.

    I reverted back and everything is fine now.

    It was odd, but just posting so folks who have system network services running can get a heads up.

  9. #9

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    Quote Originally Posted by alvanx View Post
    Hi,

    I have the same problem (namely that Yast turned ugly with 12.1). I do have the Oxygen theme installed. The control center is oxygen themed (and looks normal), but other Yast apps (like software management or lan management) do not pick it up. Installing yast2-branding-bastonopensuse did the trick for me. Can someone say "strange default settings"? :-)
    No kidding. Poor default choice indeed. I installed 12.1 on a test machine, and I was disappointed at some of the oversights. This one in particular was noticeable: Yast Qt looks cheesy and ugly in the software manager and network manager modules, and it does not honor the user's theme. On openSUSE 11.4, there was no such problem. Sure, it can be solved by removing a package and replacing it with another, but why? Why was this shipped as the default?

    Speaking of poor defaults, don't even get me started on KPackageKit (now replaced by Apper).

  10. #10
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    28

    Default Re: Change Yast2 style in 12.1 to be consistent with system style

    I do completely agree with flansuse.

    It's a really weird and disappointing choice...

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •