Results 1 to 5 of 5

Thread: Wunderlist on Opensuse 12.1 x86_64

  1. #1
    Join Date
    Mar 2008
    Location
    Kentucky
    Posts
    1,126

    Default Wunderlist on Opensuse 12.1 x86_64

    I installed Wunderlist on Opensuse 11.4 x86_64 & the only problem was having to write a sym-link for libffi:
    Code:
    cd /usr/lib64
    ln -s /usr/lib64/libffi.so.4 /usr/lib64/libffi.so.5
    and Wunderlist runs perfectly.

    However, when I install Wunderlist on Opensuse 12.1, it installs without error; however, when I run the executable, I get:
    Code:
    > cd /home/jim/bin/Wunderlist-1.2.4
    > ./Wunderlist
    /home/me/bin/Wunderlist-1.2.4/installer/installer: /usr/lib64/libcurl.so.4: no version information available (required by /home/jim/bin/Wunderlist-1.2.4/installer/installer)
    
    (process:5589): GLib-WARNING **: goption.c:2168: ignoring no-arg, optional-arg or filename flags (32) on option of type 4
    
    (process:5589): GLib-WARNING **: goption.c:2168: ignoring no-arg, optional-arg or filename flags (32) on option of type 1
    
    (process:5589): GLib-WARNING **: goption.c:2168: ignoring no-arg, optional-arg or filename flags (32) on option of type 0
    
    (process:5589): GLib-WARNING **: goption.c:2168: ignoring no-arg, optional-arg or filename flags (32) on option of type 5
    
    (installer:5589): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed
    
    (installer:5589): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed
    ~/bin/Wunderlist-1.2.4>
    Todate, I have:

    1. written a sym-link linking /usr/lib64/libcurl.so.4 with /home/jim/Wunderlist-1.2.4/runtime/1.2.0.RC3/libcurl.so.4
    Code:
    ln -s /usr/lib64/libcurl.so.4 /home/jim/Wunderlist-1.2.4/runtime/1.2.0.RC3/libcurl.so.4
    and,
    2. When that didn't work, I renamed home/jim/Wunderlist-1.2.4/runtime/1.2.0.RC3/libcurl.so.4 to home/jim/Wunderlist-1.2.4/runtime/1.2.0.RC3/libcurl.so.4.bak
    and copied /usr/lib64/libcurl.so.4 to /home/jim/Wunderlist-1.2.4/runtime/1.2.0.RC3 and still got the same error above.

    In 11.4, the curl packages were version 7.21.2-9.1; in 12.1 the curl packages are 7.22.02.1.3.

    Any ideas to get Wunderlist up and running are greatly appreciated, jim
    Desktop Asus X-99 Viper. uefi & secure Boot, Win10, Leap 15.1; Laptop: ASUS GL752VW Optimus, uefi+Secure Boot, Win10, Leap 15.1 & T-weed and IMac

  2. #2
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    5

    Default Re: Wunderlist on Opensuse 12.1 x86_64

    Same issues, had Wunderlist working fine in 11.4. I've done a fresh install of 12.1, same problems as snakedriver.
    ORIGIN PC EON15-S Pro - openSUSE 13.2 x64 KDE 4.14.6

  3. #3
    Join Date
    Dec 2011
    Location
    Nebraska
    Posts
    1

    Default Re: Wunderlist on Opensuse 12.1 x86_64

    I got it working this morning. It took a little doing, but seems to be fine now.
    Here's what i did.

    1. Add the link for libffi.so.4 mentioned previously
    Code:
    ln -s /usr/lib64/libffi.so.4 /usr/lib64/libffi.so.5
    2. Added a link for libnotify.so.1
    Code:
    ln -s /usr/lib64/libnotify.so.4.0.0 /usr/lib64/libnotify.so.1
    3. Installed libpng12.so.0 from the normal OpenSuSE 12.1 repository

    4. Added the 11.4 repository

    5. Installed libgnutls.so.26

  4. #4

    Default Re: Wunderlist on Opensuse 12.1 x86_64

    Thanks for this information.

    Forgive my ignorance, but can dprekker can you indicate which 11.4 repo is the one i should add? I added the OSS repo and it didn't contain the required file.

    Cheers.

    p.s. i'm giving Suse a go again after distro hopping a year ago after a few problems I had with 11.4 (all is going well so far)

  5. #5

    Default Re: Wunderlist on Opensuse 12.1 x86_64

    Quote Originally Posted by trenthawkins View Post
    Forgive my ignorance, but can dprekker can you indicate which 11.4 repo is the one i should add? I added the OSS repo and it didn't contain the required file.
    I just did the same thing. It is in the oss repo. Just the name is libgnutls26. You can just download .rpm and install it:
    software.opensuse.org: Search Results

    -Joon
    Dell Precision T7500 | Nvidia | 12GB Ram | openSUSE 12.1 x86-64 | Gnome 3.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •