Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: NVIDIA drivers hangs opensuse 12.1

  1. #1

    Default NVIDIA drivers hangs opensuse 12.1

    Hi, community!
    I just installed opensuse 12.1 (clean installation).
    I have a Geforce FX 5500 graphic card installed in my equipment, so I installed the drivers from NVIDIA by "easy way", with 1-click-install (http://http://en.opensuse.org/SDB:NVIDIA_drivers): a repo (ftp://download.nvidia.com/opensuse/12.1/) and "nvidia-gfxG01-kmp-default" and "x11-video-nvidiaG01" packages were installed on my system.
    "Display Info" in My Computer show "2D driver: fbdev", now instead of "nouveau".
    After that, the system hangs after login screen. Only failsafe mode is possible.

    I tried with and without "nomodeset" option, "NO_KMS_IN_INITRD=yes" and "NO_KMS_IN_INITRD=no", and so on.
    Also, I tried to compile the drivers, but I got the same result.

    Do you have any idea?
    Thanks.
    [Adrián E. Córdoba]

  2. #2
    Join Date
    Jun 2008
    Location
    Arizona, USA
    Posts
    487

    Default Re: NVIDIA drivers hangs opensuse 12.1

    I have learned from our Arch Linux friends that there is a conflict with KDE4 and the nVidia Drivers. Or at least some of them. You seem to be describing the same problem that I, and they, had... the logon will not finish. You get the first 4 symbols and then the last one hangs - blurred. To fix this you need to edit:

    ~/.kde4/share/config/kwinrc

    In this file you need to edit the 'Composting' section and add:

    Enabled=false

    Seems that there is a conflict on the startups.

    Take care,
    Chuck
    Box: Intel Core i7-4790 3.6Ghz | AMD Radeon R7 240 | 32GB RAM | openSuSE Leap 42.3/ KDE Plasma 5.8

  3. #3

    Default Re: NVIDIA drivers hangs opensuse 12.1

    Thank you, Chuck.
    But I tried by setting Enabled=false, under "Compositing" in kwinrc file, and persist the same problem.

    Also, if I get a console (by clicking Ctrl+Alt+F1), after login screen, I see that a message is printed out every second, saying:

    serial18250: too much work for irq16
    Thank you, again.
    [Adrián E. Córdoba]

  4. #4
    Join Date
    Jun 2008
    Location
    Arizona, USA
    Posts
    487

    Default Re: NVIDIA drivers hangs opensuse 12.1

    I didn't see you mention anything about blacklisting nouveau. This can be done by editing:

    /etc/modprobe.d/50-blacklist.conf

    Add: blacklist nouveau to the end

    NO_KMS_IN_INITRD=yes should be the setting that you use.

    also use nomodeset

    The above assumes that you have the nVidia driver properly installed.

    As for the "too much work for irq16" I don't believe that is connected with your display problems. I could be wrong but all the searches that we did on the Net brought up Wireless Connection problems for that message. You might try that search yourself cause it may give you some ideas.

    Take care,
    Chuck
    Box: Intel Core i7-4790 3.6Ghz | AMD Radeon R7 240 | 32GB RAM | openSuSE Leap 42.3/ KDE Plasma 5.8

  5. #5
    Join Date
    Apr 2011
    Location
    Bulgaria
    Posts
    5

    Default Re: NVIDIA drivers hangs opensuse 12.1

    Hello dear Suse users. I have the similar problem. My video is NVIDIA FX Go5200. When successfully install driver by "hard way" or trough "one-click", after log into system, have only black (blank) screen with mouse cursor. No changes with any some options: nomodeset, blacklist nouveau and NO_KMS_IN_INITRD=yes/no. Now using standard nouveau driver, but KDE working slow.

  6. #6

    Default Re: NVIDIA drivers hangs opensuse 12.1

    Quote Originally Posted by chucktr View Post
    I didn't see you mention anything about blacklisting nouveau. This can be done by editing:

    /etc/modprobe.d/50-blacklist.conf

    Add: blacklist nouveau to the end

    NO_KMS_IN_INITRD=yes should be the setting that you use.

    also use nomodeset

    The above assumes that you have the nVidia driver properly installed.

    As for the "too much work for irq16" I don't believe that is connected with your display problems. I could be wrong but all the searches that we did on the Net brought up Wireless Connection problems for that message. You might try that search yourself cause it may give you some ideas.

    Take care,
    Chuck
    Chuck:
    "blacklist nouveau" is added automatically when drivers are loaded.

    Thank you, very much.
    [Adrián E. Córdoba]

  7. #7

    Default Re: NVIDIA drivers hangs opensuse 12.1

    Also, I installed GNOME environment in a new fresh installation, and when I loaded NVIDIA drivers from the repository, the system became too slow.
    So, I executed a new installation with KDE desktop only.

    I draw much attention "Display Info" in My Computer show "2D driver: fbdev"

    Thank you, again.
    [Adrián E. Córdoba]

  8. #8
    Join Date
    Mar 2009
    Location
    Burgas,Bulgaria
    Posts
    94

    Default Re: NVIDIA drivers hangs opensuse 12.1

    After a fresh Install of 12.1 laptop with nvidia GEFORCE G105m, I noticed that windows freezes for half a minute or less at once, but definitely have a problem there
    openSUSE Tumbleweed KDE
    Linux user #543309
    http://cazadordevarna-kennel.com/suse/

  9. #9
    upscope NNTP User

    Default Re: NVIDIA drivers hangs opensuse 12.1

    aecordoba wrote:

    >
    > chucktr;2406741 Wrote:
    >> I didn't see you mention anything about blacklisting

    nouveau. This can
    >> be done by editing:
    >>
    >> */etc/modprobe.d/50-blacklist.conf*
    >>
    >> Add: *blacklist nouveau* to the end
    >>
    >> NO_KMS_IN_INITRD=YES[/B] SHOULD BE THE SETTING THAT

    YOU USE.
    >>
    >> ALSO USE [B]NOMODESET
    >> The above assumes that you have the nVidia driver

    properly installed.
    >>
    >> As for the "too much work for irq16" I don't believe

    that is connected
    >> with your display problems. I could be wrong but

    all the searches that
    >> we did on the Net brought up Wireless Connection

    problems for that
    >> message. You might try that search yourself cause it

    may give you some
    >> ideas.
    >>
    >> Take care,
    >> Chuck

    >
    > Chuck:
    > "blacklist nouveau" is added automatically when

    drivers are loaded.
    >
    > Thank you, very much.
    >
    >

    I thought the latest how to say to blacklist nouveau in
    the new /etc/modprobe.d/50-nvidia.config

    code
    ---------
    options nvidia NVreg_DeviceFileUID=0
    NVreg_DeviceFileGID=33 NVreg_DeviceFileMode=0660
    blacklist nouveau

    /code
    --------
    In looking in 50-blacklist.conf there is no reference
    to nouveau and only a blacklist-Nvidiafb.

    I am running this config. on both 11.4 and 12.1. I do
    have a slightly newer GeForce Card. are you sure the
    FX5500 is still supported on 12.1. I have a system with
    a FX5200 but have not tried 12.1 yet.

    Also 12.1 latest kernel require a version 285 at least
    for 64 Bit. is the G01 compatible with the 3.1.0
    kernel??

    I install only using the hardway.

    --
    Russ
    openSUSE 12.1(Linux 3.1.0-1.2-desktop x86_64)|KDE
    Platform Version 4.7.3 (4.7.3)
    |Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce 8400GS
    (NVIDIA-Linux-x86_64-285.05.09)


  10. #10

    Default Re: NVIDIA drivers hangs opensuse 12.1

    Russ:
    NVIDIA drivers installation creates two files: "/etc/modprobe.d/nvidia.conf" and "/etc/modprobe.d/50-nvidia.conf"

    /etc/modprobe.d/nvidia.conf
    blacklist nouveau
    /etc/modprobe.d/50-nvidia.conf
    options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=33 NVreg_DeviceFileMode=0660
    After your message, I tried adding "blacklist nouveau" at the end of 50-nvidia.conf file, with the same result.
    The version of the installed drivers is 172.14.30, but my openSuse 12.1 is 32 bits.

    Thank you for your help.
    [Adrián E. Córdoba]

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •