Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Yast fonts horrible on cli server mode.

  1. #1

    Default Yast fonts horrible on cli server mode.

    Ok, I decided to try out OpenSuSE on a vm. Problem is, it's only cli (which I chose and is going to stay that way) and yast looks horrible. Here's what I get:
    Bad Fonts

    Are there other packages I need to install? I installed Yast2-ncurses...to no avail. I've searched for answers to this, but the only thing I get is something from 12-2009 regarding the same issue with an upgrade from 11.1 to 11.2. Is this not fixed yet?

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Yast fonts horrible on cli server mode.

    Am 19.11.2011 17:46, schrieb manwichmakesameal:
    >
    > Ok, I decided to try out OpenSuSE on a vm. Problem is, it's only cli
    > (which I chose and is going to stay that way) and yast looks horrible.
    > Here's what I get:
    > 'Bad Fonts' (http://imageshack.us/photo/my-images...stbadfonts.png)
    >
    > Are there other packages I need to install? I installed
    > Yast2-ncurses...to no avail. I've searched for answers to this, but the
    > only thing I get is something from 12-2009 regarding the same issue with
    > an upgrade from 11.1 to 11.2. Is this not fixed yet?
    >
    >

    This seems to be a wrong mapping of the characters not a bad font. You
    can change console font and mapping with the command "setfont", btw waht
    output does the command "locale" give you?

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  3. #3

    Default Re: Yast fonts horrible on cli server mode.

    locale gives:
    Code:
    LANG=POSIX
    LC_CTYPE=en_US.UTF-8
    LC_NUMERIC="POSIX"
    LC_TIME="POSIX"
    LC_COLLATE="POSIX"
    LC_MONETARY="POSIX"
    LC_MESSAGES="POSIX"
    LC_PAPER="POSIX"
    LC_NAME="POSIX"
    LC_ADDRESS="POSIX"
    LC_TELEPHONE="POSIX"
    LC_MEASUREMENT="POSIX"
    LC_IDENTIFICATION="POSIX"
    LC_ALL=
    setfont didn't fix it, but it did seem to "sharpen" the fonts.

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Yast fonts horrible on cli server mode.

    Am 19.11.2011 18:36, schrieb manwichmakesameal:
    >
    > setfont didn't fix it, but it did seem to "sharpen" the fonts.
    >

    Your locale looks good, with setfont I did not mean to just type the
    command but to inspect the man page. The -m option gives you the
    possibility to play with unicode mappings until you have it right.
    You may try something like setfont -m 8859-1 (I do not have your problem
    it is correct on my machine so you have to try several options).


    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,128

    Default Re: Yast fonts horrible on cli server mode.

    To me it looks also if somewhere your UTF-8 characters are interpreted as something else. Could it be the terminal simulator? What software is the terminal simulator?
    Henk van Velden

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,609
    Blog Entries
    3

    Default Re: Yast fonts horrible on cli server mode.

    Quote Originally Posted by manwichmakesameal View Post
    ... and yast looks horrible.
    Yes, I got that yesterday.

    I just completed an install.
    Booting gave me the kdm login screen.
    I hit CTL-ALT-F1 to get a virtual terminal.
    I logged into the virtual terminal as root.
    I ran "yast".

    My plan had been to set the system hostname and domain to what I want, before a GUI login. Scrap that. It was a struggle just to work out how to get out of Yast with that funky screen.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,128

    Default Re: Yast fonts horrible on cli server mode.

    When you have that immediatly after install and in fact nothing else, that looks like a bug to me.

    And, like Martin Heml, think it is not a font, but an encoding problem.
    Last edited by hcvv; 20-Nov-2011 at 07:04.
    Henk van Velden

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Yast fonts horrible on cli server mode.

    Am 20.11.2011 10:36, schrieb hcvv:
    >
    > To me it looks also if somewhere your UTF-8 characters are interpreted
    > as something else. Could it be the terminal simulator? What software is
    > the terminal simulator?
    >

    There is no terminal emulator involved it is the text console.


    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,128

    Default Re: Yast fonts horrible on cli server mode.

    Yes, that is clear to me now. But I still think somewhere the UTF-8 encoding is interpreted as if it were Latin-1 or even ASCII.
    Henk van Velden

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Yast fonts horrible on cli server mode.

    On 2011-11-20 15:06, hcvv wrote:
    >
    > When you have that immediatly after install and in fact nothing else,
    > that looks like a bug to me.


    It works alright for me. But mine is an RC2 updated.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •