Results 1 to 8 of 8

Thread: Mixed languages in KDE

  1. #1
    Join Date
    Nov 2011
    Location
    Brühl, Germany
    Posts
    4

    Default Mixed languages in KDE

    Hello,

    I installed openSUSE 12.1 and set my language in YAST and KDE control center to German. But in KDE I have a mixture between English and German. Inside the applications everything is in German. But the program Icons on the desktop, the entries in the application launcher menu (Kickoff), as well as the different program icons inside Kontact are in English. This also occurs if I create a complete new user account. As far as I can see, I have all language packages installed. I can not find any corresponding error message in '~/.xsession-error' or '/var/log/boot.msg'. Does anyone have an idea how to fix that problem or where to find an error message that can help to solve the problem?

    Thank you
    Hollen

  2. #2

    Default Re: Mixed languages in KDE

    Quote Originally Posted by Hollen77 View Post
    Hello,

    I installed openSUSE 12.1 and set my language in YAST and KDE control center to German. But in KDE I have a mixture between English and German.
    Does it get any better if you include the following line inside your $HOME/.profile directory?

    Code:
    export LANG=de_DE.UTF-8
    You will need to log out of your account and back in for that change to take effect.


    Sorry, I just noticed that you mention having installed 12.1. Was that an upgrade from a previous version of OpenSUSE, and if so, did it exhibit the same behaviour?

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Mixed languages in KDE

    We have a thread in the german forum which may help you, for me
    Code:
    sudo zypper inr
    solved that, for others it was
    Code:
    sudo zypper dup
    which installed some missing localizations.

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Mixed languages in KDE

    Am 19.11.2011 17:28, schrieb Martin Helm:
    > We have a thread in the german forum which may help you, for me
    >
    Code:
    > sudo zypper inr
    >
    > solved that, for others it was
    >
    Code:
    > sudo zypper dup
    >
    > which installed some missing localizations.
    >

    Forgot the link http://forums.opensuse.org/showthread.php?t=468016

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  5. #5
    Join Date
    Nov 2011
    Location
    Brühl, Germany
    Posts
    4

    Default Re: Mixed languages in KDE

    Thank you very much for your fast replies!

    Martins comments helped. 'zypper inr' and 'zypper dup' solved the problem.

  6. #6

    Default Re: Mixed languages in KDE

    I had the same problem with the KDE Live CD, in my case with the spanish language, it must be the same problem.

    In solved looking for packages in YAST that contained the string "-es" (es for spanish) and selecting all packages related with KDE4, YAST, Online help, etc. It seems that the Live CD does't load this packages properly when selecting a different language.

    Just in case this helps someone.

  7. #7

    Default Re: Mixed languages in KDE

    I realize this is an old post. I am running Leap 42.1 and KDE Plasma 5. In the last 3 days Kontact's side menu is displaying in German. Tool tips, and virtually everything else is in English

    The language setting in Yast is English-US. It isn't a hardship. If anything it is probably an opportunity to learn German. But I would like to know how to change this.

    Thanks

  8. #8

    Default Re: Mixed languages in KDE

    Quote Originally Posted by crglasoe View Post
    But I would like to know how to change this.
    systemsettings5->Locale->Translations (and be sure to use systemsettings5, *not* KDE4's systemsettings)

    The reason why this changed *now* might be that you installed KDEPIM5 instead of KDEPIM4, and you probably configured the language in KDE4 differently than in Plasma5.

    You can set a language for one particular application specifically in the "Help" menu, so check what's set there for Kontact.

    If that doesn't help, try to delete your user's ~/.cache/, the files ksycoca* in particular. Those contain a cache of all menu entries and plugins in the corresponding language. If they contain the strings in the wrong language, the system will just use them regardless of what's configured.
    Last edited by wolfi323; 20-Jan-2016 at 10:52.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •