Results 1 to 6 of 6

Thread: Atheros 2413 wireless and the nohwcrypt option...

  1. #1
    Join Date
    Mar 2011
    Location
    Norway
    Posts
    77

    Default Atheros 2413 wireless and the nohwcrypt option...

    Code:
    /sbin/lspci -k
    
    09:04.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
    
    	Subsystem: Askey Computer Corp. Device 7094
    
    	Kernel driver in use: ath5k
    I'm running openSUSE 12.1, 32-bit, with Gnome on a Toshiba laptop. To have my wireless working flawlessly I have to add the nohwcrypt=1 option to the ath5k module.

    Been around Google a few times now to find out where to pass this option to the module @ boot, but can't seem to figure out what file to modify.

    Gnome uses network manager to manage its connections, so I've tried through YaST – which just tells me to use Network Manager.

    Somewhere under /etc I would guess there's a file where this can be added, just needs to be pointed in the right direction. Cheers!

  2. #2
    Join Date
    Mar 2011
    Location
    Norway
    Posts
    77

    Default Re: Atheros 2413 wireless and the nohwcrypt option...

    Well, I added
    Code:
    options ath5k nohwcrypt=1
    to /etc/modprobe.d/99-local.conf, like this
    Code:
    echo "options ath5k nohwcrypt=1" >> /etc/modprobe.d/99-local.conf
    If this is horrendously wrong and will make my laptop blow up in my face, please tell me now. Seems to be working alright though.

  3. #3
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Atheros 2413 wireless and the nohwcrypt option...

    On 11/19/2011 02:26 PM, back space wrote:
    >
    > Well, I added
    >
    > Code:
    > --------------------
    > options ath5k nohwcrypt=1
    > --------------------
    >
    > to /etc/modprobe.d/99-local.conf, like this
    >
    > Code:
    > --------------------
    > echo "options ath5k nohwcrypt=1">> /etc/modprobe.d/99-local.conf
    > --------------------
    >
    > If this is horrendously wrong and will make my laptop blow up in my
    > face, please tell me now. Seems to be working alright though.


    That is the correct way to make the change. All you are doing is telling the
    driver to do the encryption in software rather than using the hardware
    (firmware). Network operations will consume a bit more CPU, but otherwise,
    nothing should be affected.

    Why do you need this option?


  4. #4
    Join Date
    Mar 2011
    Location
    Norway
    Posts
    77

    Default Re: Atheros 2413 wireless and the nohwcrypt option...

    Quote Originally Posted by lwfinger View Post

    That is the correct way to make the change. All you are doing is telling the
    driver to do the encryption in software rather than using the hardware
    (firmware). Network operations will consume a bit more CPU, but otherwise,
    nothing should be affected.

    Why do you need this option?
    Thanks for your reply!

    Unless that option is added web pages never seem to finish loading, and the interface hangs a lot. Found this page which suggests that this chip should be loaded with the nohwcrypt option enabled.

    Why exactly it is needed? Well, I have no idea really. But at least wireless is working properly.

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Atheros 2413 wireless and the nohwcrypt option...

    On 11/19/2011 03:46 PM, back space wrote:
    >
    > lwfinger;2406552 Wrote:
    >>
    >>
    >> That is the correct way to make the change. All you are doing is
    >> telling the
    >> driver to do the encryption in software rather than using the hardware
    >> (firmware). Network operations will consume a bit more CPU, but
    >> otherwise,
    >> nothing should be affected.
    >>
    >> Why do you need this option?

    >
    > Thanks for your reply!
    >
    > Unless that option is added web pages never seem to finish loading, and
    > the interface hangs a lot. Found 'this page'
    > (http://en.opensuse.org/HCL:Network_%28Wireless%29) which suggests that
    > this chip should be loaded with the nohwcrypt option enabled.
    >
    > Why exactly it is needed? Well, I have no idea really. But at least
    > wireless is working properly.


    As you are running 12.1, file a Bug with bugzilla.opensuse.org. After you do
    that, report the bug number in this thread. I will make certain that the Atheros
    maintainer is notified.


  6. #6
    Join Date
    Mar 2011
    Location
    Norway
    Posts
    77

    Default Re: Atheros 2413 wireless and the nohwcrypt option...

    Quote Originally Posted by lwfinger View Post
    As you are running 12.1, file a Bug with bugzilla.opensuse.org. After you do
    that, report the bug number in this thread. I will make certain that the Atheros
    maintainer is notified.
    Well, I just submitted my first bug. Bug number 731576.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •