Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: vnc root access doesn't work

  1. #1

    Default vnc root access doesn't work

    Hi!

    I connect to my openSuse 12.1 remotely from win7 through tightVNC. when i launch anything that requires root password in gnome, it silently doesn't launch. In IceWM i get this error message
    (y2base:4506): Gtk-WARNING **: cannot open display: ::1:1

    i've tried to google it, but haven't found anything. is it a bug? if so, does anyone know a workaround for it?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: vnc root access doesn't work

    On 2011-11-19 02:36, baltic8 wrote:
    >
    > Hi!
    >
    > I connect to my openSuse 12.1 remotely from win7 through tightVNC. when
    > i launch anything that requires root password in gnome, it silently
    > doesn't launch. In IceWM i get this error message
    > (y2base:4506): Gtk-WARNING **: cannot open display: ::1:1


    I'm not sure if you are attempting to open a graphical session as root, or
    as user and then trying to open an application as root.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: vnc root access doesn't work

    On 11/19/2011 02:48 AM, Carlos E. R. wrote:

    > I'm not sure if you are attempting to open a graphical session as root, or
    > as user and then trying to open an application as root.


    i'm not sure either, so let me say to the OP: do not log into gnome as
    root..

    but, once logged in as a normal user (via VNC or other), then to launch
    an application (say nautilus) as root type the following into a non-root
    terminal/console/xterm (or in a alt+F2 run command popup inside gnome)

    Code:
    gnomesu nautilus
    --
    DD http://gplus.to/DenverD
    http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Automobiles" of operating systems

  4. #4

    Default Re: vnc root access doesn't work

    Hi!

    I've tried both actually. root and user. Doesn't work either way.

    I've removed the horrible thing. Wasted 2 nights on it, trying to make it work. With win7 i've got everything working in an hour, despite I've never done it before.

    Thanks for the help anyway.

    P.S. I wonder do they ever test their "releases" at all?

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: vnc root access doesn't work

    > I've removed the horrible thing.

    hahahahahaha you removed the "horrible thing" but kept Win7, what a
    belly laugh....

    --
    DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
    http://tinyurl.com/DD-Software
    dump Flash: http://www.bbc.co.uk/news/technology-15797399

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: vnc root access doesn't work

    On 2011-11-19 17:56, baltic8 wrote:

    > P.S. I wonder do they ever test their "releases" at all?


    By people like you. If you don't test it and report in bugzilla, nobody
    will do it. This is community, you are expected to do things for us.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: vnc root access doesn't work

    On 2011-11-19 17:56, baltic8 wrote:

    > P.S. I wonder do they ever test their "releases" at all?


    It could also be a problem with tightVNC.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  8. #8

    Default Re: vnc root access doesn't work

    Quote Originally Posted by DenverD View Post
    you removed the "horrible thing" but kept Win7, what a
    belly laugh....
    I didn't keep it. I installed it. See, I just wanted a fileserver working 24/7 with remote access to it and got a small atom based PC for this. Nothing fancy. Yet, even those simple things don't work well on suse. I've wasted 2 nights on this. With win7 i made it up and running in just about an hour with a little help from google. The quality of the open source operating system is awful. And if I do my job like this, I'd rather be ashamed than have a belly laugh.

    Cheers!

  9. #9

    Default Re: vnc root access doesn't work

    Quote Originally Posted by robin_listas View Post
    If you don't test it and report in bugzilla, nobody
    will do it. This is community, you are expected to do things for us.
    I've actually filed a few detailed bugs about the problems I've encountered. With screenshots and all the info I was able to get. Though I don't think it's going to help at all, seeing the attitude of "the community"

  10. #10

    Default Re: vnc root access doesn't work

    Quote Originally Posted by robin_listas View Post
    It could also be a problem with tightVNC.
    I also tried UltraVNC. It didn't work at all. I wasnt able to connect tosuse machine. Just black screen and a cross instead of the cursor.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •