Results 1 to 5 of 5

Thread: openSUSE 12.1 iFolder client fails to run

  1. #1

    Default openSUSE 12.1 iFolder client fails to run

    I have installed openSUSE 12.1 Gnome 64 bit - very nice!!

    Installed the iFolder packages from software.opensuse.org for openSUSE 12.1 using 1-Click Install.

    When I click on the iFolder3 icon the Novell iFolder banner/panel appears and then goes. There are other iFolder panels.

    As a newbie I am unsure where to go to see the error generated.

    Rgds.

    Stan Chelchowski

  2. #2

    Default Re: openSUSE 12.1 iFolder client fails to run

    I am facing the same problem.
    Starting ifolder from a console windows give the following messages:
    ---
    user@linux86_x64:~> ifolder
    Error: Cannot start the local web services.
    Error: The Simias process failed to initialize.
    Use the command line switch --showconsole to view the error.

    Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
    at Novell.iFolder.iFolderApplication.StartiFolder () [0x00000] in <filename unknown>:0
    at System.Threading.Thread.StartUnsafe () [0x00000] in <filename unknown>:0
    [ERROR] FATAL UNHANDLED EXCEPTION: System.NullReferenceException: Object reference not set to an instance of an object
    at Novell.iFolder.iFolderApplication.StartiFolder () [0x00000] in <filename unknown>:0
    at System.Threading.Thread.StartUnsafe () [0x00000] in <filename unknown>:0
    ---

    Starting ifolder with the option --showconsole does not give any additional information.

    Regards

    Dieter

  3. #3

    Default Re: openSUSE 12.1 iFolder client fails to run

    Hi,

    after some debugging with strace I found that you need to install the package mono-wcf (version mono-wcf-2.10.6-2.1.3.x86_64 on my machine).
    I needed to reboot then ifolder worked fine on my system.

    Hope that helps

    Dieter

  4. #4

    Default Re: openSUSE 12.1 iFolder client fails to run

    Dieter,

    Thank you !!! ....... it works for me too!!!

    I guess the powers that be need to adjust the dependecies on the iFolder installation so mono-wcf is also installed.

    I am now going to play around with strace... a new "feature" to explore for this newbie..

    Thanks

    Stan Chelchowski

  5. #5

    Default Re: openSUSE 12.1 iFolder client fails to run

    Hi Stan,

    thanks for your feedback.
    Now that the problem is fixed on your machine too, I created bug 731589 in bugzilla for this issues.

    Dieter

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •