I have installed 12.1. (I had been running KDE 4.6.5 in 11.4.) When I opened Kontact I agreed to let it migrate the mail but 'Migration to KMail 2 failed. In case you want to try again, run 'kmail-migrator --interactive' manually.'

So I ran 'kmail-migrator --interactive' with this result
kmail-migrator(6725) main: Migration of kmailrc has already run, not running it again
Whenever I tried to open Kontact I encountered this error message: 'KMail encountered a fatal error and will terminate now. Failed to fetch the resource collection.'

I have uninstalled Kontact and rebooted and installed it again. Same errors. I can see no entries in the calendar or addressbook or mail parts of Kontact.

Opening kmail2 from the command line gives this message:

kmail2(6653)/libakonadi Akonadi::SpecialCollectionsRequestJobPrivate::resourceScanResult: Failed to request resource "akonadi_maildir_resource_0" : "Unknown error. (Failed to fetch the resource collection.)"
I tried some workarounds for this error which I found by googling:

creating an empty folder ~/Maildir
moving ~/.kde4/share/apps/kmail

but still the same 'Failed to fetch the resource collection' error.

Would really appreciate some help.