Results 1 to 4 of 4

Thread: Error message when trying to install Reddit. Second post for this error

  1. #1

    Default Error message when trying to install Reddit. Second post for this error

    I am currently using Opensuse 11.4 64 bit.
    Installed all the reddit dependancies without any problems

    Attempted to execute step 2 titled "Run the setup" found in RedditStartToFinish – reddit – Trac;

    Code:
     sudo python setup.py develop
    gives me the following error

    Code:
    dhseagles:/home/reddit/r2 # sudo python setup.py develop
    Installing pylibmc
    Downloading http://github.com/downloads/ketralnis/pylibmc/pylibmc-1.0-reddit-04.tar.gz
    Processing pylibmc-1.0-reddit-04.tar.gz
    Running pylibmc-1.0-reddit-04/setup.py -q bdist_egg --dist-dir /tmp/easy_install-tXKY1P/pylibmc-1.0-reddit-04/egg-dist-tmp-ZfMmPR
    warning: no files found matching 'MANIFEST'
    In file included from _pylibmcmodule.c:34:0:
    _pylibmcmodule.h:189:7: error: ‘MEMCACHED_BEHAVIOR_NUMBER_OF_REPLICAS’ undeclared here (not in a function)
    _pylibmcmodule.c: In function ‘pylibmc_memcached_fetch_multi’:
    _pylibmcmodule.c:1074:3: warning: passing argument 2 of ‘memcached_mget’ from incompatible pointer type
    /usr/include/libmemcached/memcached_get.h:23:18: note: expected ‘char **’ but argument is of type ‘const char **’
    error: Setup script exited with error: command 'gcc' failed with exit status 1
    I have gcc installed and working.

    I know gcc is working as I have compiled some C programs by hand.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Error message when trying to install Reddit. Second post forthis error

    Am 14.11.2011 17:46, schrieb sourtzis:

    > _pylibmcmodule.c:1074:3: warning: passing argument 2 of ‘memcached_mget’ from incompatible pointer type
    > /usr/include/libmemcached/memcached_get.h:23:18: note: expected ‘char **’ but argument is of type ‘const char **’
    > error: Setup script exited with error: command 'gcc' failed with exit status 1
    >

    Without being an expert here, it looks to me like you have the wrong
    version of libmemcached or some related library.
    What does reddit say which version you need?

    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Error message when trying to install Reddit. Second post forthis error

    Am 14.11.2011 18:00, schrieb Martin Helm:
    > Am 14.11.2011 17:46, schrieb sourtzis:
    >
    >> _pylibmcmodule.c:1074:3: warning: passing argument 2 of ‘memcached_mget’ from incompatible pointer type
    >> /usr/include/libmemcached/memcached_get.h:23:18: note: expected ‘char **’ but argument is of type ‘const char **’
    >> error: Setup script exited with error: command 'gcc' failed with exit status 1
    >>

    > Without being an expert here, it looks to me like you have the wrong
    > version of libmemcached or some related library.
    > What does reddit say which version you need?
    >

    I quickly looked myself it says memcached (1.4+)
    Please post the output from
    Code:
    rpm -qa '*memcache*'
    --
    PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
    4.6.0 | GeForce GT 420 | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
    nVidia ION | 3GB Ram

  4. #4

    Default Re: Error message when trying to install Reddit. Second post forthis error

    Running the rpm query command, here is my output:
    Code:
    dhseagles:~/Downloads # rpm -qa '*memcache*'
    libmemcached2-0.30-3.1.x86_64
    libmemcachedutil0-0.30-3.1.x86_64
    libmemcached-0.30-3.1.x86_64
    memcached-1.4.5-4.1.x86_64
    libmemcached-devel-0.30-3.1.x86_64

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •