Results 1 to 6 of 6

Thread: [SUSE 11.4] certain packages are not udating

  1. #1

    Question [SUSE 11.4] certain packages are not udating

    Hi all,

    This maybe a newbie question but I want to know the inside out. When I try to update SUSE using zypper command I have noticed some of the packages are not getting updated/installed.

    like:-

    Code:
    sudo zypper update
    root's password:
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      gstreamer-0_10 gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-base 
      gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang k3b kaffeine 
      libdrm libdrm-devel libgstapp-0_10-0 libgstinterfaces-0_10-0 
      libgstreamer-0_10-0 libpciaccess0 libpciaccess0-devel libpixman-1-0 
      libpixman-1-0-devel libtag-extras1 libwavpack1 libXi6 libxine1 
      libxine1-gnome-vfs libxine1-pulse linphone Mesa mjpegtools python-numpy 
      taglib xkeyboard-config xorg-x11 xorg-x11-driver-input xorg-x11-driver-video 
      xorg-x11-driver-video-intel-legacy xorg-x11-driver-video-nouveau 
      xorg-x11-driver-video-radeonhd xorg-x11-fonts xorg-x11-fonts-core 
      xorg-x11-libfontenc xorg-x11-libICE xorg-x11-libs xorg-x11-libSM 
      xorg-x11-libX11 xorg-x11-libX11-ccache xorg-x11-libXau xorg-x11-libxcb 
      xorg-x11-libXdmcp xorg-x11-libXext xorg-x11-libXfixes 
      xorg-x11-libXfixes-devel xorg-x11-libxkbfile xorg-x11-libXmu xorg-x11-libXp 
      xorg-x11-libXpm xorg-x11-libXprintUtil xorg-x11-libXrender xorg-x11-libXt 
      xorg-x11-libXv xorg-x11-server xorg-x11-xauth xorg-x11-Xvnc 
    
    Nothing to do.
    Why is that is there a conflict in my repositories? My repositories are

    Code:
    #  | Alias                            | Name                             | Enabled | Refresh | URI                                                                                
    ---+----------------------------------+----------------------------------+---------+---------+------------------------------------------------------------------------------------
     1 | Compiz                           | Compiz                           | Yes     | Yes     | http://download.opensuse.org/repositories/X11:/Compiz/openSUSE_11.4/               
     2 | Packman                          | Packman                          | Yes     | Yes     | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_11.4                  
     3 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     | http://download.opensuse.org/update/11.4/                                          
     4 | google-chrome                    | google-chrome                    | Yes     | Yes     | http://dl.google.com/linux/chrome/rpm/stable/i386                                  
     5 | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0             | Yes     | No      | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SH-222BB_R8SR6GAB903872,/dev/sr0
     7 | repo-debug                       | openSUSE-11.4-Debug              | No      | Yes     | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                     
     9 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes     | http://download.opensuse.org/distribution/11.4/repo/non-oss/                       
    10 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes     | http://download.opensuse.org/distribution/11.4/repo/oss/                           
    11 | repo-source                      | openSUSE-11.4-Source             | No      | Yes     | http://download.opensuse.org/source/distribution/11.4/repo/oss/                    
     8 | repo-debug-update                | openSUSE-11.4-Update-Debug       | No      | Yes     | http://download.opensuse.org/debug/update/11.4/                                    
     6 | openSUSE_11.4                    | openSUSE_11.4                    | Yes     | Yes     | http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.4/
    thanks.
    GT540

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: [SUSE 11.4] certain packages are not udating

    On 11/07/2011 06:46 PM, gt540 wrote:
    >
    > Why is that is there a conflict in my repositories? My repositories are


    read the paragraph beginning with "IMPORTANT!" in this thread
    http://tinyurl.com/33qc9vu and then follow that advice until you have
    only four repos enabled (oss, non-oss, update and packman)...and only
    two refreshing (update and packman).. then try your update again

    --
    DD
    http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Automobiles" of operating systems

  3. #3

    Default Re: [SUSE 11.4] certain packages are not udating

    Quote Originally Posted by DenverD View Post
    On 11/07/2011 06:46 PM, gt540 wrote:
    >
    > Why is that is there a conflict in my repositories? My repositories are


    read the paragraph beginning with "IMPORTANT!" in this thread
    NEW Users - openSUSE Pre-install (general) - PLEASE READ and then follow that advice until you have
    only four repos enabled (oss, non-oss, update and packman)...and only
    two refreshing (update and packman).. then try your update again

    --
    DD
    DD Caveat
    openSUSE®, the "German Automobiles" of operating systems
    Ok I did exactly as it mentioned but still I'm getting unable to install message for some packages

    Code:
    The following package updates will NOT be installed:
      gstreamer-0_10 gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-base 
      gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang k3b kaffeine 
      libgstapp-0_10-0 libgstinterfaces-0_10-0 libgstreamer-0_10-0 libtag-extras1 
      libwavpack1 libxine1 libxine1-gnome-vfs libxine1-pulse linphone mjpegtools 
      python-numpy taglib

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: [SUSE 11.4] certain packages are not udating

    On 2011-11-07 18:46, gt540 wrote:
    >
    > Hi all,
    >
    > This maybe a newbie question but I want to know the inside out. When I
    > try to update SUSE using zypper command I have noticed some of the
    > packages are not getting updated/installed.


    Probably because they are available on a different repo that the one the
    current versions come from (different vendor).

    One way to see is using yast package manager (qt or kde version), and list
    all those packages. They will show in color, with the possible upgrade in
    parenthesis. If you then click on the versions tab, you will see where each
    possible upgrade comes from.

    There is also a way to show this info with zypper, but I do not remember it.

    Notice that mixing packages from different sources can make problems.
    Zypper not updating those is for good reasons.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: [SUSE 11.4] certain packages are not udating

    Quote Originally Posted by robin_listas View Post
    On 2011-11-07 18:46, gt540 wrote:
    >
    > Hi all,
    >
    > This maybe a newbie question but I want to know the inside out. When I
    > try to update SUSE using zypper command I have noticed some of the
    > packages are not getting updated/installed.


    Probably because they are available on a different repo that the one the
    current versions come from (different vendor).

    One way to see is using yast package manager (qt or kde version), and list
    all those packages. They will show in color, with the possible upgrade in
    parenthesis. If you then click on the versions tab, you will see where each
    possible upgrade comes from.

    There is also a way to show this info with zypper, but I do not remember it.

    Notice that mixing packages from different sources can make problems.
    Zypper not updating those is for good reasons.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)
    Thanks, I have managed to resolve the conflicts through YaST package manager as you said. Those conflicts were came from Packman and Suse vendor repositories I have updated conflicting packages from Packman repository then the conflicts gone.

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: [SUSE 11.4] certain packages are not udating

    > I'm getting these unable to install message for some packages

    sorry...i'm out of ideas, lets see what others can suggest..

    --
    DD
    openSUSE®, the "German Automobiles" of operating systems

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •