Results 1 to 8 of 8

Thread: Keyboard layout issues and unrelated problems with kile, kwrite and texmaker

  1. #1

    Default Keyboard layout issues and unrelated problems with kile, kwrite and texmaker

    Hello, I am using opensuse 11.4, and I have recently run into problems with various applications. This might sound crazy, but out of a sudden I can't delete text in kwrite, kile and texmaker, but I can do so in other applications, such as libreoffice. It was working fine a few weeks ago and I haven't installed anything since (apart from the recommended security updates).
    Since the upgrade to 11.4 (some time ago) I have also experienced intermittent keyboard layout issues (dead keys out of a sudden stop working, and I have to restart the application), which seem to affect quite a lot of users, but insofar I haven't found any solution that works for me (ibus qt deactivates dead keys altogether for me, and I de-installed it). This is a very annoying bug, and I was wondering whether anyone here has managed to avoid the issue.
    I would be very grateful for any feedback! b

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Keyboard layout issues and unrelated problems with kile, kwriteand texmaker

    On 11/04/2011 01:56 AM, barbara2 wrote:
    >
    > Hello, I am using opensuse 11.4, and I have recently run into problems
    > with various applications. This might sound crazy, but out of a sudden I
    > can't delete text in kwrite, kile and texmaker, but I can do so in other
    > applications, such as libreoffice. It was working fine a few weeks ago
    > and I haven't installed anything since (apart from the recommended
    > security updates).
    > Since the upgrade to 11.4 (some time ago) I have also experienced
    > intermittent keyboard layout issues (dead keys out of a sudden stop
    > working, and I have to restart the application), which seem to affect
    > quite a lot of users, but insofar I haven't found any solution that
    > works for me (ibus qt deactivates dead keys altogether for me, and I
    > de-installed it). This is a very annoying bug, and I was wondering
    > whether anyone here has managed to avoid the issue.
    > I would be very grateful for any feedback! b
    >
    >


    i have none of the issues you describe...they are not routine problems
    for anyone i know..

    something is VERY wrong with you system setup..

    you say this all started after your "upgrade" to openSUSE 11.4 so i must
    assume that somehow your 11.4 was damaged from the start...that often
    happens if folks do the upgrade incorrectly..

    did you upgrade from a well running and updated openSUSE 11.3? or was it
    from some other version? and, did you follow one of the two supported
    upgrade paths: http://tinyurl.com/35p966c or http://tinyurl.com/6kvoflv

    alternatively, maybe you have a hardware or BIOS problem, please
    describe your hardware...and, mention if maybe it has been dropped or
    roughly handled..

    if you boot from an openSUSE live cd do you see any of the symptoms?

    --
    DD
    http://tinyurl.com/DD-Caveat
    openSUSE®, the "German Automobiles" of operating systems

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Keyboard layout issues and unrelated problems with kile, kwriteand texmaker

    Welcome to the forum; as DenverD says, these are unusual problems - I would guess, because you say that you have had intermittent keyboard problems, that the problems are related to keyboard settings. Which keyboard layout are you using and have you customised any of the key combinations?

  4. #4

    Default Re: Keyboard layout issues and unrelated problems with kile, kwriteand texmaker

    Hello, many thanks for your replies! The keyboard issue is well documented and seems to affect a lot of people, in particular with polytonic Greek, which is what I am using, but I also had the same issues with other languages. Basically, when you switch the keyboard to a different language, you can use it for a while, and after 10 min. or so it will out of a sudden stop working, for no apparent reason. Close the application and open it again, and it is working, for the next few minutes. So this is nothing out of the ordinary. In earlier distributions, there were no problems with this; my guess is that this probably has been broken for at least two years now.

    No, I did not customize anything, I basically added another keyboard layout, using the KDE control module. I switch between keyboard layouts by clicking on the button on the panel on the bottom of the screen.

    The problem with deleting is new, it must have happened within the past three weeks. Currently, I am using the default gb keyboard layout. I can delete text on this forum website, and in libreoffice, but not in e.g. in kwrite or texmaker.

    I don't think there was anything wrong with the upgrade to opensuse 11.4 (it went smoothly, by the way). This bug does not appear to be specific to opensuse - usually, when this is discussed anywhere, you would find the advice to install ibus qt, which I have tried, and which made it worse, so I de-installed it (this was months ago). See for instance Texmaker (free cross-platform latex editor) under "linux":

    "Installing the ibus-qt package is recommended to avoid some trouble with accentued characters on some linux distributions (like debian/ubuntu). "

    To test the polytonic Greek on your machine, just select this keyboard layout, and then type what is a semicolon and then an "a" on the British keyboard. This should produce an alpha with an accent on top - if it is working. For me, it is usually working fine for a few minutes, but some people don't seem to get any output at all.

    I would be really grateful for any advice! B

  5. #5

    Default Re: Keyboard layout issues and unrelated problems with kile, kwriteand texmaker

    Hello, I think I fixed it!! The only thing that I had changed over the past weeks was to add yet another keyboard layout - sy (Syriac) in addition to gr (polytonic) and gb - and this seems to have disabled the backspace key in all three layouts, when working in certain applications. So apparently you can only have two layouts at a time.

    Many thanks for both your replies! B

  6. #6
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Keyboard layout issues and unrelated problems with kile, kwriteand texmaker

    You can in practice have up to four layouts; so this appears to be a bug associated with the Syriac layout. It may be worth checking bugs.kde.org to see if anyone has reported it and, if not, put in a bug report.

  7. #7
    Join Date
    Aug 2010
    Location
    Germany
    Posts
    101

    Default Re: Keyboard layout issues and unrelated problems with kile, kwriteand texmaker

    Are you changing the KB layouts with YAST or another application?

    I'm running SCIM on OS 11.4 x64 w/o problems, use it for RU(phonetic), JP(Canna) and disable it for DE (w/o deadkeys).

  8. #8
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: Keyboard layout issues and unrelated problems with kile, kwriteand texmaker

    With KDE the normal way is to use System settings>Input devices>Keyboard>Layouts

    YaST is best left for what KDE calls Locale.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •