This KPackageKit issue is driving me up the wall. When I do a command-line software update, I see this...

Code:
> su -c "zypper ref; zypper up"
Password: 
Repository 'Updates for openSUSE 11.4 11.4-0' is up to date.
Repository 'Packman' is up to date.
Repository 'libdvdcss repository' is up to date.
Repository 'openSUSE-11.4-OssopenSUSE-11.4-Oss' is up to date.
Repository 'openSUSE:11.4:Contrib' is up to date.
Repository 'openSUSE:11.4:NonFree' is up to date.
Repository 'openSUSE-11.4-Debug' is up to date.
Repository 'openSUSE-11.4-Update-Debug' is up to date.
All repositories have been refreshed.
Loading repository data...
Reading installed packages...

The following package updates will NOT be installed:
  clucene-core-devel dropbox gstreamer-0_10 gstreamer-0_10-plugins-bad 
  gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good 
  gstreamer-0_10-plugins-good-lang kaffeine libgstbasecamerabinsrc-0_10-0 
  libgstreamer-0_10-0 libgstreamer-0_10-0-32bit liblash1 libproxy1 
  libproxy1-config-gnome libproxy1-config-kde4 libproxy1-networkmanager 
  libproxy1-pacrunner-mozjs libshout3 libsidplay1 libtag-extras1 libvpx0 
  libxine1 libxine1-gnome-vfs libxine1-pulse libxml2-32bit libxmmsclient6 
  libxmmsclient-glib1 linphone luvcview python-numpy x11vnc xmms2 
  xmms2-plugin-base 

Nothing to do.
When I pull up KPackageKit, I see these two updates:



When I select them and install updates, I see this error.



Code:
patch:libproxy-5021.noarch conflicts with libproxy1.x86_64 < 0.4.7-6.3.1 provided by libproxy1-0.4.6-12.1.x86_64
adobeair-2.6.0-19170.x86_64 requires /usr/lib/libxml2.so.2, but this requirement cannot be provided
My repos:



Why am I seeing non-functioning updates in KPackageKit that aren't visible in zypper?