Results 1 to 9 of 9

Thread: Custom entries in KDE-Menu are ignored

  1. #1
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Custom entries in KDE-Menu are ignored

    Hello community,

    I installed libreoffice 3.3.4 from the libreoffice.org site next to the version from OpenSuse (3.4.2+) [Libreoffice Stable Repo].
    Side remark: I considered the installation of the 3.3 branch of LibreOffice necessary due to this bug:
    https://bugs.freedesktop.org/show_bug.cgi?id=38327

    I did the installation via zypper and did not install the desktop integration pack.
    The software is installed in /opt/. The installation went fine.

    I wanted to create a custom menu entry in the KDE menu in order to be able to conveniently launch Calc 3.3.4 whenever I need to use a datapilot. In order to create this entry, I rightclicked on the Geecko --> Edit applications, entered a description and the appropriate command to launch the application and saved. To my surprise, even after logout/login the menu entry was not made. However, when I go to edit applications I can see it.

    Any hints?
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

  2. #2

    Default Re: Custom entries in KDE-Menu are ignored

    Hello Nikos78,

    Quote Originally Posted by Nikos78
    I installed libreoffice 3.3.4 from the libreoffice.org site next to the version from OpenSuse (3.4.2+) [Libreoffice Stable Repo].
    Side remark: I considered the installation of the 3.3 branch of LibreOffice necessary due to this bug:
    https://bugs.freedesktop.org/show_bug.cgi?id=38327

    I did the installation via zypper and did not install the desktop integration pack.
    The software is installed in /opt/. The installation went fine.

    I wanted to create a custom menu entry in the KDE menu in order to be able to conveniently launch Calc 3.3.4 whenever I need to use a datapilot. In order to create this entry, I rightclicked on the Geecko --> Edit applications, entered a description and the appropriate command to launch the application and saved. To my surprise, even after logout/login the menu entry was not made. However, when I go to edit applications I can see it.

    Any hints?
    Strange problem, which version of openSUSE do you run?
    And which version of KDE?

    Could you post the output when you run the menu editor from terminal:
    Code:
    kmenuedit
    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Re: Custom entries in KDE-Menu are ignored

    Hello Edward_Iii,

    thanks for the reply and the wishes. I am running KDE 4.7 on 11.4 (I indicate this in my signature, but just saw that this is not visible when entering the post editor).

    Running kmenuedit from the terminal does not provide any error messages. It just starts the KDE Menu Editor.
    In the editor my manually created entry is visible. However, it is not visible in the menu itself.

    PS: Hidden Entry is of course not ticked
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

  4. #4
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Question Re: Custom entries in KDE-Menu are ignored

    I did a little more reading, but I am not so sure I got it right.
    The KDE Menu editor handbook from this site http://docs.kde.org/stable/en/kdebas.../kmenuedit.pdf does not provide any hints.

    On this site Human Readable - Modifying the KDE K-Menu Globally, which does not relate to OpenSuse, they mention .desktop files in relation to kmenuedit.

    I have such files in /usr/share/applications. However, not for the entries I created manually.
    Do I have to create such files for my custom menu entries or are they completely unrelated or should kmenuedit have created them, but could not since it was run as a normal user?

    Regards
    Nikos
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

  5. #5

    Default Re: Custom entries in KDE-Menu are ignored

    Hello Nikos78,

    Quote Originally Posted by Nikos78
    I did a little more reading, but I am not so sure I got it right.
    The KDE Menu editor handbook from this site http://docs.kde.org/stable/en/kdebas.../kmenuedit.pdf does not provide any hints.

    On this site Human Readable - Modifying the KDE K-Menu Globally, which does not relate to OpenSuse, they mention .desktop files in relation to kmenuedit.

    I have such files in /usr/share/applications. However, not for the entries I created manually.
    Do I have to create such files for my custom menu entries or are they completely unrelated or should kmenuedit have created them, but could not since it was run as a normal user?
    The files in /usr/share/applications are indeed menu entries.
    They are however only the system wide entries, meaning that when you add one there every user will have it in his menu.

    The location the menu entries are placed for users is in ~/.local/share/applications/.
    You could try adding a .desktop file there.
    If you do you'll also need to edit the ~/.config/menus/applications-kmenuedit.menu file.

    Before manually adding the menu entries make sure that these files exist and that your user can write to them.

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  6. #6
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: Custom entries in KDE-Menu are ignored

    I recently experienced this same problem as the OP: edit menu, new entry does not appear in system menu, yet appears when attempt to edit. Check the permission(s) of ~/.config/menus/. For some unknown reason, mine were set to "Forbidden" for Group and Other. When updated to "Can View", the new items appeared in the system menu. (These entries were, of course, "local" additions, and appeared only for the user adding them).
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  7. #7
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Re: Custom entries in KDE-Menu are ignored

    Check the permission(s) of ~/.config/menus/
    They were ok, but this led me to check the permissions of
    ~/.local/share/applications/
    , where I found the .desktop files for the entries I had manually made, and they were in fact set to 700, after I changed them to 744 the menu entries appeared.

    Thank, you Edward for pointing me to the right location and thank you Sean for pointing me to the solution.
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

  8. #8

    Default Re: Custom entries in KDE-Menu are ignored

    Quote Originally Posted by Nikos78 View Post
    They were ok, but this led me to check the permissions of , where I found the .desktop files for the entries I had manually made, and they were in fact set to 700, after I changed them to 744 the menu entries appeared.

    Thank, you Edward for pointing me to the right location and thank you Sean for pointing me to the solution.
    Are the icons showing correctly now too?

    Here's what I've got on this.

    I can get the menu entries to show in kmenu but not the icons. They do show correctly in gnome, however, icons and all, regardless of size.

    I went as far as creating icons in the global usr/share/icons/hicolor folder for the 32x32 48x48 and 64x64 sizes but even with those icons showing in the "applications" icon view and selected the icon still didn't show right in the menu.

    Seems that others have had similar problems.

    Applications/Web Browsers/Firefox's icon shows correctly. Applications/Edutainment/Marble's does not.

    I also had a problem with permissions, similar but different from that mentioned above.

    Somehow during one of my installs I managed to set the permissions on all the files in my /var/tmp/kdecache-<uname> folders to root/root but they should have been <uname>/users (with stricter access set only for the folders, i.e., 0700 or thereabouts).

    This was causing errors to show when launching kwrite and other kde applications from a terminal, typically about being unable to write to the icon cache and inability to share memory ("memory usage will increase").

    Oddly, this did not affect this missing or incorrectly showing icon issue here. It only gave rise to EXTREMELY noisey outputs from kde apps executed from the commandline.

  9. #9
    Join Date
    Dec 2008
    Location
    Athens
    Posts
    296

    Default Re: Custom entries in KDE-Menu are ignored

    Quote Originally Posted by rainbowsally View Post
    Are the icons showing correctly now too?
    Yes, icons show correctly too. I had also added them manually of course (not the icons, their association with the menu entry).
    Main box: OpenSuse 12.3)/KDE 4.10 64bit
    Older Box: OpenSuse 12.2/KDE 4.8.5 64bit (my mediabox)
    Laptop: Debian Wheezy/KDE 4.8.4 64bit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •