Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Intel Mac user with install problems

  1. #21
    Join Date
    Sep 2009
    Location
    Argentina, Buenos Aires
    Posts
    100

    Default Re: Intel Mac user with install problems

    I also tried booting with Ubuntu 10.10 and OpenSUSE 11.4 64bits both, and its the same problem as in OpenSUSE 12.1, I think it would be an incompatibility with MacBook Pro 8.2... something with the video and cdrom drivers, I dont know how to go on
    Lap #1: openSUSE 11.4 Kernel 2.6.37.6-0.7-desktop | 64bits | i7-720QM 1.60GHz | KDE 4.6 (ex Gnome 2.32.1 user) | ATI HD 5650 1GB | HP Pavilion dv7-4190us | 6GB RAM

  2. #22

    Default Re: Intel Mac user with install problems

    You're not the only one having issues with a MacBook Pro 8.2: OpenSUSE 11.3/11.4 in new Macbook Pro 8,2

  3. #23
    Join Date
    Sep 2009
    Location
    Argentina, Buenos Aires
    Posts
    100

    Default Re: Intel Mac user with install problems

    I found a solution... I think. You have to copy the DVD to a USB pendrive, then insert the DVD and the pendrive. I have refit installed and I have already resized the partitions.

    So start the mac presing the C key, then select to boot from the 12.1 opensuse DVD. Then when you come to the first page (the one that appears as soon as you boot with the CD. There the splashscreen lets you select the installation source, there you select Hard Disk (then let it start)

    You will have booted from the CD(because USB boot seems not to work yet) and then you tell the installer to look into every hard disk (this will also scan the USB pendrive :-)

    Then the installation goes smooth, now I am seting the mac bookpro 8.2 with KDE as I wanted!!!

    I have a lot to test but at least the MAC OS X works fine and the openSUSE too.

    Sl

    S.
    Lap #1: openSUSE 11.4 Kernel 2.6.37.6-0.7-desktop | 64bits | i7-720QM 1.60GHz | KDE 4.6 (ex Gnome 2.32.1 user) | ATI HD 5650 1GB | HP Pavilion dv7-4190us | 6GB RAM

  4. #24

    Default Re: Intel Mac user with install problems

    Glad you got it to work. Maybe the explanation is here: http://forums.opensuse.org/english/g...ml#post2410667

  5. #25

    Question Re: Intel Mac user with install problems

    I own a macbook pro 8,1 and i just installed Opensuse 12.1. Seems fine, i've got almost everything working except the touchpad/trackpad - it is currently working but only a single button function. No gestures, Not even a right click. Any immediate help is very much appreciated as i have lots to do this coming days.
    Audit Trail:
    >lsusb
    return: "Bus 001 Device 005: ID 05ac:0252 Apple, Inc." for my trackpad

    > synclient -l
    returns:
    "Couldn't find synaptics properties. No synaptics driver loaded?"

    > cat /proc/bus/input/devices
    returns:
    "I: Bus=0003 Vendor=05ac Product=0252 Version=0111
    N: Name="Apple Inc. Apple Internal Keyboard / Trackpad"
    P: Phys=usb-0000:00:1a.7-1.2/input2
    S: Sysfs=/devices/pci0000:00/0000:00:1a.7/usb1/1-1/1-1.2/1-1.2:1.2/input/input1
    U: Uniq=
    H: Handlers=mouse0 event1
    B: PROP=0
    B: EV=17
    B: KEY=70000 0 0 0 0
    B: REL=3
    B: MSC=10"

    >xinput list
    returns:
    "Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Apple Inc. Apple Internal Keyboard / Trackpad id=11 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Apple Inc. Apple Internal Keyboard / Trackpad id=10 [slave keyboard (3)]
    ↳ FaceTime HD Camera (Built-in) id=12 [slave keyboard (3)]
    "

    the Xorg.0.log file also contains:
    [457.764] (II) config/udev: Adding input device Apple Inc. Apple Internal Keyboard / Trackpad (/dev/input/event1)
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: Applying InputClass "evdev pointer catchall"
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: Applying InputClass "evdev pointer catchall"
    [ 457.764] (II) Using input driver 'evdev' for 'Apple Inc. Apple Internal Keyboard / Trackpad'
    [ 457.764] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: always reports core events
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: Device: "/dev/input/event1"
    [ 457.764] (--) Apple Inc. Apple Internal Keyboard / Trackpad: Found 3 mouse buttons
    [ 457.764] (--) Apple Inc. Apple Internal Keyboard / Trackpad: Found relative axes
    [ 457.764] (--) Apple Inc. Apple Internal Keyboard / Trackpad: Found x and y relative axes
    [ 457.764] (II) Apple Inc. Apple Internal Keyboard / Trackpad: Configuring as mouse
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: YAxisMapping: buttons 4 and 5
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [ 457.764] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-1/1-1.2/1-1.2:1.2/input/input1/event1"
    [ 457.764] (II) XINPUT: Adding extended input device "Apple Inc. Apple Internal Keyboard / Trackpad" (type: MOUSE)
    [ 457.764] (II) Apple Inc. Apple Internal Keyboard / Trackpad: initialized for relative axes.
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: (accel) keeping acceleration scheme 1
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: (accel) acceleration profile 0
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: (accel) acceleration factor: 2.000
    [ 457.764] (**) Apple Inc. Apple Internal Keyboard / Trackpad: (accel) acceleration threshold: 4
    [ 457.765] (II) config/udev: Adding input device Apple Inc. Apple Internal Keyboard / Trackpad (/dev/input/mouse0)
    [ 457.765] (II) No input driver/identifier specified (ignoring)

    Kindly assist,
    Regards

  6. #26
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Intel Mac user with install problems

    On 2011-12-04 03:36, crack2mann wrote:
    >
    > I own a macbook pro 8,1 and i just installed Opensuse 12.1. Seems fine,
    > i've got almost everything working except the touchpad/trackpad - it is


    Your problem seems different that the one that originated this thread.
    I think you should open a new one with an appropriate title.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #27

    Default Re: Intel Mac user with install problems

    @crack2mann
    Actually, several people would be interested to read how you managed to install openSUSE on your macbook pro, and I was about to ask. But then I noticed that you have a macbook pro 8.1, and this too seems to be quite different from a macbook pro 8.2, at least regarding the issue discussed here.
    As for the touchpad/trackpad, it's a different problem indeed.

  8. #28

    Default Re: Intel Mac user with install problems

    @robin_listas, @please_try_again, u guys are absolutely right. i had problems starting a new thread earlier and i was desperate after days of trying to fix it myself. Anyway, its posted to the Hardware forum under the title "Macbook Pro 8,1 Touchpad/Trackpad Running Opensuse 12.1". I hope i get an immediate fix to this...i have work!!!!
    PS: apologies to anyone the earlier wrong post offended.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •