Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: DAViCal

  1. #11

    Default Re: DAViCal

    Könnte es sein, daß die Ursache für die Fehlermeldung daran liegt, daß ich das Skript create-database.sh schon mal als root statt als postgres aufgerufen hatte und sich jetzt irgendwas nicht mehr neu schreiben lässt?
    Aber wie bekomme ich heraus, was genau passiert, daß das Skript mit einer Fehlermeldung abbricht?

  2. #12
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: DAViCal

    Savis wrote:
    > Nein, immer noch nicht.
    > Könnte es vielleicht an DAViCal selbst liegen?
    > Hattest du für deinen Test die OBS Version von Jengelh, oder die
    > deutlich aktuellere von der Entwicklerseite genommen?
    >

    Die jengelh Version, das php-awl aus dem obs wäre sowieso inkompatibel wie
    ich sehe zu der neueren DAViCal Version (die brauch AwlCache.php das im
    älteren awl noch nicht enthalten ist).

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.2 | nVidia
    ION | 3GB Ram

  3. #13
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: DAViCal

    Savis wrote:

    >
    > Könnte es sein, daß die Ursache für die Fehlermeldung daran liegt,
    > daß ich das Skript create-database.sh schon mal als root statt als
    > postgres aufgerufen hatte und sich jetzt irgendwas nicht mehr neu
    > schreiben lässt?

    Das könnte sein.

    > Aber wie bekomme ich heraus, was genau passiert, daß das Skript mit
    > einer Fehlermeldung abbricht?
    >

    Leider gibt das Script fehlermeldungstechnisch nicht viel her.
    Schau mal im home Verzeichnis vom User postgres (das ist /var/lib/pgsql)
    nach ob da alles mit Onwer/Grup postgres angelegt ist oder irgendwelche
    Dateien mit Owner oder Group root herumhängen.

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.2 | nVidia
    ION | 3GB Ram

  4. #14

    Default Re: DAViCal

    Quote Originally Posted by martin_helm View Post

    Leider gibt das Script fehlermeldungstechnisch nicht viel her.
    Schau mal im home Verzeichnis vom User postgres (das ist /var/lib/pgsql)
    nach ob da alles mit Onwer/Grup postgres angelegt ist oder irgendwelche
    Dateien mit Owner oder Group root herumhängen.
    Mal wieder etwas Zeit gehabt weiter zu probieren.
    im home von postgres sieht alles gut aus, er ist überall Eigentümer der Dateien.

    Nun habe ich mal das loggign für Postgresql eingeschaltet und nochmal das:
    Code:
     # su - postgres -c /usr/share/davical/dba/create-database.sh
    ausgeführt.

    Code:
    # cat /var/lib/pgsql/data/pg_log/postgresql-2011-11-15_201504.log
    2011-11-15 20:43:08 CET postgres postgres ANWEISUNG:  CREATE DATABASE davical OWNER davical_dba ENCODING 'UTF8' TEMPLATE template0;
    
    2011-11-15 20:44:25 CET davical davical_dba LOG:  angegebener Benutzername (davical_dba) und authentifizierter Benutzername (postgres) stimmen nicht überein
    2011-11-15 20:44:25 CET davical davical_dba FATAL:  Ident-Authentifizierung für Benutzer »davical_dba« fehlgeschlagen
    2011-11-15 20:44:29 CET davical davical_dba LOG:  angegebener Benutzername (davical_dba) und authentifizierter Benutzername (postgres) stimmen nicht überein
    2011-11-15 20:44:29 CET davical davical_dba FATAL:  Ident-Authentifizierung für Benutzer »davical_dba« fehlgeschlagen
    Und wenn ich die Weboberfläche von DAViCal aufrufe loggt Postgresql:
    Code:
    2011-11-15 20:15:43 CET davical davical_dba FATAL:  Ident-Authentifizierung für Benutzer »davical_dba« fehlgeschlagen
    2011-11-15 20:29:55 CET davical davical_app LOG:  angegebener Benutzername (davical_app) und authentifizierter Benutzername (wwwrun) stimmen nicht überein
    2011-11-15 20:29:55 CET davical davical_app FATAL:  Ident-Authentifizierung für Benutzer »davical_app« fehlgeschlagen
    2011-11-15 20:29:58 CET davical davical_app LOG:  angegebener Benutzername (davical_app) und authentifizierter Benutzername (wwwrun) stimmen nicht überein
    2011-11-15 20:29:58 CET davical davical_app FATAL:  Ident-Authentifizierung für Benutzer »davical_app« fehlgeschlagen
    Irgendwie scheint das Problem wohl bei Postgresql zu liegen, oder im create-database.sh, welches die Datenbank und erforderlichen Benutzer anlegen sollte.
    Im Netz habe ich verschiedene Hinweise darauf gefunden, daß ein Problem für create-database.sh ein Fehler in der UTF-8 Kodierung sein kann. Oben beim Anlegen der Datenbank steht einfach nur UTF8, in der postgresql.conf steht jedoch de_DE.UTF-8, könnte das die Ursache sein?

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •