Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: kernel Disabling IRQ

  1. #1
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default kernel Disabling IRQ

    Hi,

    I got a strange message on all terminals and believe me I have seen some weired stuff in Linux before

    Syslog says ...
    kernel:[49025.045090] Disabling IRQ #16

    This only occurred today, the only thing that changed on this desktop was yesterdays updating for 11.4 64bits stuff, including kernel (2.6.37.6-0.7-desktop).
    Anyone knows about something similar?

    irq 16 according to

    Code:
    less  /proc/interrupts
    is

    Code:
     16:     246616         16     253402         19   IO-APIC-fasteoi   uhci_hcd:usb3, pata_jmicron, nvidia

    The previous kernel never gave any type of messages like these ...


    Regards

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: kernel Disabling IRQ

    On 2011-10-25 01:06, keyb user wrote:
    > I got a strange message on all terminals and believe me I have seen
    > some weired stuff in Linux before


    That's a big warning message, critical level: sent to everybody.
    You will see a more verbose message in the log.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default Re: kernel Disabling IRQ

    Hi Carlos,

    Quote Originally Posted by robin_listas View Post
    On 2011-10-25 01:06, keyb user wrote:
    > I got a strange message on all terminals and believe me I have seen
    > some weired stuff in Linux before


    That's a big warning message, critical level: sent to everybody.
    You will see a more verbose message in the log.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)
    no doubt

    the log shows some stuff like:

    [49025.044839] irq 16: nobody cared (try booting with the "irqpoll" option)
    [49025.044843] Pid: 0, comm: kworker/0:1 Tainted: P 2.6.37.6-0.7-desktop #1
    [49025.044845] Call Trace:
    [49025.044856] [<ffffffff810059b9>] dump_trace+0x79/0x340
    [49025.044860] [<ffffffff81522672>] dump_stack+0x69/0x6f
    [49025.044865] [<ffffffff810cc3be>] __report_bad_irq+0x1e/0x90
    [49025.044868] [<ffffffff810cc5d9>] note_interrupt+0x1a9/0x200
    [49025.044872] [<ffffffff810cd575>] handle_fasteoi_irq+0x105/0x140
    [49025.044876] [<ffffffff810058b5>] handle_irq+0x15/0x20
    [49025.044879] [<ffffffff810054fe>] do_IRQ+0x5e/0xe0
    [49025.044883] [<ffffffff81525f13>] ret_from_intr+0x0/0xa
    [49025.044898] [<ffffffffa0023a1a>] acpi_safe_halt+0x1e/0x30 [processor]
    [49025.044906] [<ffffffffa0023ab0>] acpi_idle_enter_c1+0x55/0x9f [processor]
    [49025.044912] [<ffffffff813f0b48>] cpuidle_idle_call+0xb8/0x370
    [49025.044917] [<ffffffff8100125c>] cpu_idle+0x4c/0xa0
    [49025.044919] handlers:
    [49025.044920] [<ffffffff813862f0>] (usb_hcd_irq+0x0/0x70)
    [49025.044923] [<ffffffff8136ed60>] (ata_bmdma_interrupt+0x0/0x1f0)
    [49025.044927] [<ffffffffa07553f0>] (nv_kern_isr+0x0/0x80 [nvidia])
    [49025.045090] Disabling IRQ #16
    Could be something about the bios setup ... there are some people complaining about this on the web (I google).
    But I writing on the computer and apparently everything looks ok ...

    I will recheck this tomorrow. gotogo.


    Regards.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: kernel Disabling IRQ

    Hi,

    I got a strange message on all terminals and believe me I have seen some weired stuff in Linux before

    Syslog says ...
    kernel:[49025.045090] Disabling IRQ #16

    This only occurred today, the only thing that changed on this desktop was yesterdays updating for 11.4 64bits stuff, including kernel (2.6.37.6-0.7-desktop).
    Anyone knows about something similar?

    irq 16 according to

    Code:

    less /proc/interrupts
    is

    Code:

    16: 246616 16 253402 19 IO-APIC-fasteoi uhci_hcd:usb3, pata_jmicron, nvidia

    The previous kernel never gave any type of messages like these ...


    Regards
    I notice that IRQ came up with nvidia AND the last time I saw such a message was after loading a newer kernel and having an old proprietary nVIDIA video driver loaded. I updated the video driver to the latest and the kernel error went away.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: kernel Disabling IRQ

    On 2011-10-25 03:16, keyb user wrote:
    > the log shows some stuff like:


    Which is reportable in bugzilla.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6
    Will Honea NNTP User

    Default Re: kernel Disabling IRQ

    keyb user wrote:

    >
    > Hi Carlos,
    >
    > robin_listas;2397004 Wrote:
    >> On 2011-10-25 01:06, keyb user wrote:
    >> > I got a strange message on all terminals and believe me I have seen
    >> > some weired stuff in Linux before

    >>
    >> That's a big warning message, critical level: sent to everybody.
    >> You will see a more verbose message in the log.
    >>
    >> --
    >> Cheers / Saludos,
    >>
    >> Carlos E. R.
    >> (from 11.4 x86_64 "Celadon" at Telcontar)

    >
    > no doubt
    >
    > the log shows some stuff like:
    >
    >>
    >> [49025.044839] irq 16: nobody cared (try booting with the "irqpoll"
    >> option)
    >> [49025.044843] Pid: 0, comm: kworker/0:1 Tainted: P
    >> 2.6.37.6-0.7-desktop #1
    >> [49025.044845] Call Trace:
    >> [49025.044856] [<ffffffff810059b9>] dump_trace+0x79/0x340
    >> [49025.044860] [<ffffffff81522672>] dump_stack+0x69/0x6f
    >> [49025.044865] [<ffffffff810cc3be>] __report_bad_irq+0x1e/0x90
    >> [49025.044868] [<ffffffff810cc5d9>] note_interrupt+0x1a9/0x200
    >> [49025.044872] [<ffffffff810cd575>] handle_fasteoi_irq+0x105/0x140
    >> [49025.044876] [<ffffffff810058b5>] handle_irq+0x15/0x20
    >> [49025.044879] [<ffffffff810054fe>] do_IRQ+0x5e/0xe0
    >> [49025.044883] [<ffffffff81525f13>] ret_from_intr+0x0/0xa
    >> [49025.044898] [<ffffffffa0023a1a>] acpi_safe_halt+0x1e/0x30
    >> [processor]
    >> [49025.044906] [<ffffffffa0023ab0>] acpi_idle_enter_c1+0x55/0x9f
    >> [processor]
    >> [49025.044912] [<ffffffff813f0b48>] cpuidle_idle_call+0xb8/0x370
    >> [49025.044917] [<ffffffff8100125c>] cpu_idle+0x4c/0xa0
    >> [49025.044919] handlers:
    >> [49025.044920] [<ffffffff813862f0>] (usb_hcd_irq+0x0/0x70)
    >> [49025.044923] [<ffffffff8136ed60>] (ata_bmdma_interrupt+0x0/0x1f0)
    >> [49025.044927] [<ffffffffa07553f0>] (nv_kern_isr+0x0/0x80 [nvidia])
    >> [49025.045090] Disabling IRQ #16
    >>
    >>

    >
    > Could be something about the bios setup ... there are some people
    > complaining about this on the web (I google).
    > But I writing on the computer and apparently everything looks ok ...
    >
    > I will recheck this tomorrow. gotogo.
    >


    I get a similar irq message during boot with a 6100 chip set. Once the boot
    finishes, the Nvidia driver has re-assigned that function to another irq and
    something else is using the orginally bad one. The whole sequence indicates
    to me that the BIOS is initializing the Nvidia chipset in a way that
    conflicts with something in the kernel which disables the offender and the
    Nvidia driver later assigns a non-conflicting irq. Check the disabled irq
    after the bootup is fully complete and see if something is using it.

    --
    Will Honea

  7. #7

    Default Re: kernel Disabling IRQ

    Carlos E. R. wrote:
    > On 2011-10-25 03:16, keyb user wrote:
    >> the log shows some stuff like:

    >
    > Which is reportable in bugzilla.


    except keyb user wrote:
    > the log shows some stuff like:
    >
    >> [49025.044839] irq 16: nobody cared (try booting with the "irqpoll"
    >> option)
    >> [49025.044843] Pid: 0, comm: kworker/0:1 Tainted: P


    So not likely to get much attention from kernel people, perhaps.


  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: kernel Disabling IRQ

    On 2011-10-25 12:31, Dave Howorth wrote:
    > Carlos E. R. wrote:


    > So not likely to get much attention from kernel people, perhaps.


    No matter, IMO if the kernel logs an error that way it is reportable.

    The "nobody" there doesn't mean a person.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9

    Default Re: kernel Disabling IRQ

    i don't have any advice on repairing the problem, but i can add broader depth to the discussion in that the same type of kernel message indicating a irq disable happens also using the newer fglrx driver.

    Usually the kernel message happens after a few seconds of starting a video, but it will also occur if you run fgl_glxgears. Up until now i suspected a problem with the driver.

    i have a 11.2 (2.6.31) and an 11.4 (2.6.37) installed on this machine and both environments exhibit this behavior. Nothing seems broken by the reallocation.... just the message is logged.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: kernel Disabling IRQ

    On 2011-10-25 12:31, Dave Howorth wrote:
    >>> [49025.044843] Pid: 0, comm: kworker/0:1 Tainted: P

    > So not likely to get much attention from kernel people, perhaps.


    Ah, I didn't notice the tainted thing. Mmmm... :-?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •