Results 1 to 9 of 9

Thread: VMPlayer 4.0 on OpenSuSE 11.4

  1. #1

    Default VMPlayer 4.0 on OpenSuSE 11.4

    Hi there,
    need some help with VMPlayer 4.0. I had it running under openSuSE 11.3, but since I upgraded to 11.4 I get an error message when it tries to comile the VM-Tools into the running kernel:

    Der Befehl „ ''\''/usr/bin/vmware-modconfig'\'' --icon='\''vmware-player'\'' --appname='\''VMware'\'' --gcc='\''/usr/bin/gcc'\'' --headers='\''/lib/modules/2.6.37.6-0.7-desktop/build/include'\'' --gcc-ignore-minor '“ kann nicht ausgeführt werden.

    Has anybody had this issue and resolved it? Aoo I could find on the net was about VMPlayer 3.1.3.

    Thanks!
    Reinhard

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: VMPlayer 4.0 on OpenSuSE 11.4

    On 2011-10-16 20:16, ReinhardD wrote:
    >
    > Hi there,
    > need some help with VMPlayer 4.0. I had it running under openSuSE 11.3,
    > but since I upgraded to 11.4 I get an error message when it tries to
    > comile the VM-Tools into the running kernel:
    >
    > DER BEFEHL „ ''\''/USR/BIN/VMWARE-MODCONFIG'\''
    > --ICON='\''VMWARE-PLAYER'\'' --APPNAME='\''VMWARE'\''
    > --GCC='\''/USR/BIN/GCC'\''
    > --HEADERS='\''/LIB/MODULES/2.6.37.6-0.7-DESKTOP/BUILD/INCLUDE'\''
    > --GCC-IGNORE-MINOR '“ KANN NICHT AUSGEFüHRT WERDEN.


    It seems there are German words there, could you translate? Or repeat the
    command forcing English? «LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 command»

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3

    Default Re: VMPlayer 4.0 on OpenSuSE 11.4

    Oh sorry.... The words outside the double qoutes mean: The command could not be executed.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: VMPlayer 4.0 on OpenSuSE 11.4

    On 2011-10-17 08:56, ReinhardD wrote:
    >
    > Oh sorry.... The words outside the double qoutes mean: *The command
    > could not be executed*.


    Dunno. With such a brief error message I have no idea. I have not installed
    version 4 yet.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: VMPlayer 4.0 on OpenSuSE 11.4

    What happens if you run /usr/bin/vmware-modconfig without the parameters?
    Does it even exist?

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.2 | nVidia
    ION | 3GB Ram

  6. #6

    Default Re: VMPlayer 4.0 on OpenSuSE 11.4

    I just did an install of 11.4 on a new hard disk, then downloaded and installed VMPlayer 4. The old system was 11.1 and 3.1.3.

    I used Yast to install the kernel sources for the same version that was installed (2.6.37.6-0.7), installed qt4-devel, make, and gcc, then ran "make config" to turn on pre-emptive multitasking and the CQF scheduler. These were already on this time, which is a change from 11.1.

    As root in /usr/src/linux, make, make modules_install, make install, reboot into new kernel. The kernel README says to do it as a user, but it seems to assume you're building in your home directory, whereas the distributions all seem to use /usr/src, which is normally only writable by root.

    Supposedly you can install VMware if you have the right kernel headers installed and you don't have to build the kernel, but I've had enough problems I just do it anyway now.

    With the new kernel running, su root, sh "./VMPlayer..." and go through the questions. VMPlayer came up with no problems. I had to reset some defaults for a few VMs.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: VMPlayer 4.0 on OpenSuSE 11.4

    On 2011-10-18 14:06, dlwilliams2 wrote:

    > As root in /usr/src/linux, make, make modules_install, make install,
    > reboot into new kernel. The kernel README says to do it as a user, but
    > it seems to assume you're building in your home directory, whereas the
    > distributions all seem to use /usr/src, which is normally only writable
    > by root.


    I did that once by changing the group permissions to allow write, and then
    have my user in the group "root".

    Code:
    
    > chmod --preserve-root --recursive g+w /usr/src/linux/* /usr/src/linux-2.6.11.4-21.7-obj/* /usr/src/kernel-modules/*
    
    and the parent dirs.

    Another trick is to change where make writes all things:

    BUILD directory for the kernel:

    When compiling the kernel all output files will per default be
    stored together with the kernel source code.
    Using the option "make O=output/dir" allow you to specify an alternate
    place for the output files (including .config).
    Example:
    kernel source code: /usr/src/linux-2.6.N
    build directory: /home/name/build/kernel

    To configure and build the kernel use:
    cd /usr/src/linux-2.6.N
    make O=/home/name/build/kernel menuconfig
    make O=/home/name/build/kernel
    sudo make O=/home/name/build/kernel modules_install install

    Please note: If the 'O=output/dir' option is used then it must be
    used for all invocations of make.



    I think I did this once because I had no free space in /usr/src.


    One more point: the instructions to use are in /usr/src/linux/README.SUSE

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  8. #8

    Default Re: VMPlayer 4.0 on OpenSuSE 11.4

    Thanks all for your suggestions.
    After installing the kernel sources I deinstalled VMware-Player and installed it again. And it worked .... hooorray!!!

  9. #9
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,877

    Default Re: VMPlayer 4.0 on OpenSuSE 11.4

    Solution here. It's the haldaemon thing. Again...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •