Results 1 to 2 of 2

Thread: Starting a Remote X session using XDMCP

  1. #1
    Join Date
    Jun 2008
    Florida, USA

    Default Starting a Remote X session using XDMCP

    This thread is motivated by the thread X bug? When using XDMCP the login works but desktop is never shown but I believe a different focus.

    I have two SUSE 11.4(x86_64) KDE 4.7.2 machines, I'll call SUSE1 and SUSE2.
    SUSE1 is my "local" machine, SUSE2 is my HTPC on the network, XDMCP is enabled.

    Prior to KDE 4.7, I used Start a new Session on SUSE1 to get a new greeter screen and chose remote login from there, but there appears to be a bug and that method fails(I have entered KDE bug after seeing similar reports from other distros).

    In the above Forum thread, I see the following comment:
    Actually, the easiest way to check if/how the XDMCP server is responding is to do an X query to it:

    X -query <server>
    It should start an X session.

    Depending on the server configuration, you might have to specify from which client:

    X -query <server> -from <client>
    Use hostnames or ips for server and client.
    I tried that from a Konsole window and also from CLI in VT2 (CTL-ALT F2) and get a similar message:
    carl@SUSE1:~> X -query SUSE2
    Fatal server error:
    Server is already active for display 0
            If this server is no longer running, remove /tmp/.X0-lock
            and start again.
    Must SUSE2 be at level 3 for this to work?
    In this test, Konsole is running on SUSE1:0 and I am logged in on SUSE2:0 via a local keyboard.
    I also have xvncserver running on SUSE2:1.
    vncviewer works on SUSE1, but seems to bog down other applications.

    Is the error message above complaining about SUSE1:0 or SUSE2:0 ?

  2. #2

    Default Re: Starting a Remote X session using XDMCP

    I am trying to configure XDMCP as well, same configuration.

    I had your problem and I fixed it by setting in gdm.conf DisplaysPerHost=2 and MaxRemoteSessions=16

    Look at this pages:
    GDM and XDMCP configuration for remote graphical Linux desktop access

    However, my problem is that GDM is not starting from the client side. Instead Xnest or X -query only shows a black screen and I can not login.

    I can also open individual windows through "ssh -X <host> xclock", but not all are able to open, and is not the same. I would like to have the full login window.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts